Jump to content
LaptopVideo2Go Forums
mobilenvidia

Latest Realtek Audio Codecs

Recommended Posts

AlexRe
12 hours ago, erp-ster7n said:

wrong hardware ID mentioned

yes, it's my mistake, sorry. The right ID is HDAUDIO\FUNC_01&VEN_10EC&DEV_0294&SUBSYS_10431A00&REV_1000

Share this post


Link to post
Share on other sites
Bordo38


hello my motherboard

CROSSHAIR V FORMULA-Z

SupremeFX III

Which one should I download?

HDAUDIO\FUNC_01&VEN_10EC&DEV_0899&SUBSYS_1043854B

FF00 Generic
FF01 with FMAPO
FF03 with Nahimic
FF04 with CXAPO
FF06 with MaxxAudio
FF10 with Creative
FF0C with DTS/SST

Edited by Bordo38

Share this post


Link to post
Share on other sites
alanfox2000

Realtek HD Audio Driver 6.0.1.8622 WHQL

Legacy HDA Driver
8622_FF0C_FF00_FF01_FF03_FF04_FF06_FF10_PG469_Win10_RS2_RS3_RS4_RS5_Win7_WHQL

8622_FF00 Generic
8622_FF01 with FMAPO
8622_FF03 with Nahimic
8622_FF04 with CXAPO
8622_FF06 with MaxxAudio
8622_FF10 with Creative
8622_FF0C with DTS/SST

Win 7,10 RS2 RS3 RS4 RS5 x32/64
PackageVersion = PG469
DriverVer= 01/22/2019, 6.0.1.8622

Edited by alanfox2000

Share this post


Link to post
Share on other sites
dealpapa

Realtek High Definition Audio (HDA) Version 6.0.1.8622 WHQL

 

Realtek High Definition Audio (HDA) Version 6.0.1.8622 WHQL. - New version of High Definition Audio drivers for sound card from the company Realtek, drivers are designed for operating systems Windows XP, Vista, Windows 7, Windows 8, Windows 8.1, Windows 10 - 32/64 bit.

Info about the driver:
Name: Realtek High Definition Audio drivers
(High Definition Audio System Software - Realtek ALC Audio drivers)
Package version driver:  2.82 PG 4.68
Windows XP:
DriverVer = 08/23/2016, 5.10.0.7514
Win Vista/7/8/8.1/10:
DriverVer = 06/14/2017, 6.0.1.8186
Windows 7/10:
DriverVer = 01/22/2019, 6.0.1.8622

  1.Supporting Realtek audio chips Vista, Windows 7, Windows 8/8.1, Windows 10:
ALC1220, ALC1150, ALC882, ALC883, ALC885, ALC886, ALC887, ALC888, ALC889, ALC892, ALC899, ALC861VD, ALC891, ALC900, ALC660, ALC662, ALC663, ALC665, ALC667, ALC668, ALC670, ALC671, ALC672, ALC676, ALC680, ALC221, ALC231, ALC233, ALC235, ALC236, ALC255, ALC256, ALC260, ALC262, ALC267, ALC268, ALC269, ALC270, ALC272, ALC273, ALC275, ALC276, ALC280, ALC282, ALC283, ALC284, ALC286, ALC288, ALC290, ALC292, ALC293, ALC298, ALC383
2.Supporting Realtek audio chips Windows 2000, Windows XP:
ALC880, ALC882, ALC883, ALC885, ALC886, ALC887, ALC888, ALC889, ALC892, ALC899, ALC861VC, ALC861VD, ALC891, ALC900, ALC660, ALC662, ALC663, ALC665, ALC667, ALC668, ALC670, ALC671, ALC672, ALC676, ALC680, ALC221, ALC231, ALC233, ALC235, ALC236, ALC255, ALC256, ALC260, ALC262, ALC267, ALC268, ALC269, ALC270, ALC272, ALC273, ALC275, ALC276, ALC280, ALC282, ALC283, ALC284, ALC286, ALC290, ALC292, ALC293, ALC383

Supported controllers Realtek: (with controller) (a partial list):
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0672
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0676
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0276
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0283
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0286
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0233
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0900
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0383
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0262
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0267
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0268
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0660
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0662
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0862
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0280
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0282
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0270
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0892
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0292
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0885
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0888
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0887
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0665
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0670
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0275
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0889
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0663
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0882
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0883
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0680
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0269
HDAUDIO \ FUNC_01 & VEN_10EC & DEV_0899

Windows: 7/10 : Update installation

Realtek High Definition Audio (HDA - 32/64 bit) Version 6.0.1.8622 WHQL

https://github.com/alanfox2000/realtek-hda-release/releases/download/6.0.1.8622/8622_FF0C_FF00_FF01_FF03_FF04_FF06_FF10_PG468_Win10_RS2_RS3_RS4_RS5_Win7_WHQL.rar

Share this post


Link to post
Share on other sites
erp-ster7n
On 2/11/2018 at 11:32 PM, mobilenvidia said:

Working fine for me, control panel look same as before
MaxxAudio Pro is active, can't see any ASIO settings, but these will be PCI_ID specific no doubt

@mobilenvidia

the Realtek ASIO options are found on a separate control panel (separate from the main Realtek HDA driver) but you need to use an ASIO capable program [like Reaper or Cakewalk XONAR] to access the config options (i know i'm nearly a year late in responding to this)

install the latest version of the foobar2000 app, and install the foobar2000 asio component / plugin, open its preferences and look in the Playback, Output section, there is an asio section below it that will allow access to the Realtek asio options.

in this screenshot below , I have the Realtek ASIO driver installed on my HP computer using Realtek ALC888s audio with HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A6C" and I'm accessing the Realtek ASIO control panel thru foobar2000

 

realtek-hda-asio-cpl-foobar2000-alc888s-hp.thumb.png.7f6cc1a24f6b780c7126479a359717ac.png

another thing is that I have to set foobar2000 to use Realtek ASIO for playback (aka. output) and not the "primary sound driver" in the Output section.

I've been dealing with a cold for a few days but I'm feeling much better recently

--------------

Note to AlexRe: may try the original Realtek HDA driver for your X542UQ from ASUS (v6.0.1.8210 - download here).  Or perhaps this ASUS based Realtek HDA v6.0.1.8514 driver (download here).

 

 

Share this post


Link to post
Share on other sites
mobilenvidia
10 hours ago, erp-ster7n said:

@mobilenvidia

the Realtek ASIO options are found on a separate control panel (separate from the main Realtek HDA driver) but you need to use an ASIO capable program [like Reaper or Cakewalk XONAR] to access the config options (i know i'm nearly a year late in responding to this)

install the latest version of the foobar2000 app, and install the foobar2000 asio component / plugin, open its preferences and look in the Playback, Output section, there is an asio section below it that will allow access to the Realtek asio options.

in this screenshot below , I have the Realtek ASIO driver installed on my HP computer using Realtek ALC888s audio with HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_103C2A6C" and I'm accessing the Realtek ASIO control panel thru foobar2000

another thing is that I have to set foobar2000 to use Realtek ASIO for playback (aka. output) and not the "primary sound driver" in the Output section.

I've been dealing with a cold for a few days but I'm feeling much better recently

 

 

Cool, that sorted that out only option in foobar2000 is the ASIO driver, CPL comes up when double clicked
Cheers for that

MaxxAudio also fully functional with 8622 driver

Got sidetracked on @alanfox2000 very good RAR compression of the driver sets with RAR
As the driver pack expands out to 5GB from 224mb RAR file (mainly due to same files in each folder), surely 7zip can do better and it can
Got the 5GB folder down to 176MB saving another 22% (incase @alanfox2000 is uploading the files)
 

Share this post


Link to post
Share on other sites
alanfox2000

Realtek HD Audio Driver 6.0.1.8625 WHQL

Legacy HDA Driver
8625_FF0C_FF00_FF01_FF03_FF04_FF06_FF10_PG470_Win10_RS2_RS3_RS4_RS5_Win7_WHQL

8625_FF00 Generic
8625_FF01 with FMAPO
8625_FF03 with Nahimic
8625_FF04 with CXAPO
8625_FF06 with MaxxAudio
8625_FF10 with Creative
8625_FF0C with DTS/SST

Win 7,10 RS2 RS3 RS4 RS5 x32/64
PackageVersion = PG470
DriverVer= 01/28/2019, 6.0.1.8625

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.1.8627 WHQL

8627_FF00

Win 7,10 x32/64
PackageVersion = PG470
DriverVer= 01/29/2019, 6.0.1.8627

Share this post


Link to post
Share on other sites
alanfox2000

Realtek HD Audio Driver 6.0.1.8627 WHQL

Legacy HDA Driver
8627_FF0C_FF00_FF01_FF03_FF04_FF06_FF10_PG470_Win10_RS2_RS3_RS4_RS5_Win7_WHQL

8627_FF00 Generic
8627_FF01 with FMAPO
8627_FF03 with Nahimic
8627_FF04 with CXAPO
8627_FF06 with MaxxAudio
8627_FF10 with Creative
8627_FF0C with DTS/SST

Win 7,10 RS2 RS3 RS4 RS5 x32/64
PackageVersion = PG470
DriverVer= 01/29/2019, 6.0.1.8627

Share this post


Link to post
Share on other sites
erp-ster7n
On 1/26/2019 at 2:55 PM, mobilenvidia said:

Cool, that sorted that out only option in foobar2000 is the ASIO driver, CPL comes up when double clicked
Cheers for that

MaxxAudio also fully functional with 8622 driver


 

 

the only downside to using the Realtek ASIO driver is that it has a lame asio control panel, compared to the options available when using the ASIO4ALL driver.

also playing media files thru foobar2000 (MP3, WAV, WMA) with the Realtek ASIO driver only works if those media files were recorded or created at a sampling rate of 44Khz or higher; otherwise I get this error message when playing an MP3 or WAV file that was created at a lower sample rate less than 44Khz (in this example; attempting to play a WAV file recorded at 11Khz sample rate)

 

foobar2000-playback-error-low-sample-rate.png

this does not happen if I play that same WAV file thru ASIO4ALL

-----

and speaking of 8622, Lenovo has a 6.0.1.8622 UAD driver for certain Lenovo Legion C530/C730/T530/T730 PCs (readme link)

edit 2/8: I'm still recovering from a stubborn cold that I had nearly a week ago

Share this post


Link to post
Share on other sites
erp-ster7n
On 1/18/2019 at 6:12 AM, dealpapa said:

installing

try 8586 UAD from Dell.

Share this post


Link to post
Share on other sites
erp-ster7n
On 12/21/2018 at 4:01 AM, LSudlow said:

Dell's version of 8569 works perfectly.  😎

unfortunately, it seems Dell has recently removed the 8569 A13 driver from their web site (like WTF)

it's no longer listed in the driver downloads for XPS 9560

Share this post


Link to post
Share on other sites
LSudlow
56 minutes ago, erp-ster7n said:

unfortunately, it seems Dell has recently removed the 8569 A13 driver from their web site (like WTF)

it's no longer listed in the driver downloads for XPS 9560

...AND all previous sound drivers for that machine. I wonder what's up?

Share this post


Link to post
Share on other sites
SupremeMaster

Did anyone notice anything difference between 8622 and 27 ? i think 22 was better.

Edited by SupremeMaster
numeros

Share this post


Link to post
Share on other sites
dealpapa
On 2/11/2019 at 4:27 PM, erp-ster7n said:

try 8586 UAD from Dell.

insttalling

Share this post


Link to post
Share on other sites
LSudlow
On 2/12/2019 at 1:17 PM, LSudlow said:

...AND all previous sound drivers for that machine. I wonder what's up?

Dell's 8569 A13 is restored now, unchanged as far as I can see.

Share this post


Link to post
Share on other sites
erp-ster7n
7 hours ago, LSudlow said:

Dell's 8569 A13 is restored now, unchanged as far as I can see.

yup - restored on Valentine's Day Feb. 14th as the new release date (driver details)

how cute of Dell 😃

Compatible systems listed are now Dell Latitude 3390 (2-in-1), Latitude 3490/3590, Precision 5520, XPS 13 (9360/9370) and XPS 15 (9560)

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.1.8633 WHQL

8633_FF00

Win 7,10 x32/64
PackageVersion = PG470
DriverVer= 02/12/2019, 6.0.1.8633

Share this post


Link to post
Share on other sites
alanfox2000

Realtek HD Audio Driver 6.0.1.8633 WHQL

Legacy HDA Driver
8633_FF0C_FF00_FF01_FF03_FF04_FF06_FF10_PG470_Win10_RS2_RS3_RS4_RS5_Win7_WHQL

8633_FF00 Generic
8633_FF01 with FMAPO
8633_FF03 with Nahimic
8633_FF04 with CXAPO
8633_FF06 with MaxxAudio
8633_FF10 with Creative
8633_FF0C with DTS/SST

Win 7,10 RS2 RS3 RS4 RS5 x32/64
PackageVersion = PG470
DriverVer= 02/12/2019, 6.0.1.8633

Share this post


Link to post
Share on other sites
Hanki

Dear Members!

I have some issue with ALC294 driver. At least I think this is the source of my problem.
When I restart my PC, the (internal) speaker works pefrect. But after some hours of work (without play any music/sound with the speaker) the speaker can't play anything. If I connect my bluetooth headset it works. But not with the internal speaker.
If I wanna activate it again, I need to disable/enable the Realtek Audio in the device manager. (Sometimes I need restart PC to work again. Or just need to run speaker sound test.)
There is no this kind of problem with HD Audio Driver, but with this I cant use my combo jack input/output. Just with the Realtek Driver.

Could you be so kind and help me with this to me?

Asus GL504GS, hardware ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0294&SUBSYS_10431251&REV_1000
OS: Windows 10

Thank you in advance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×