Jump to content
LaptopVideo2Go Forums

Latest Realtek Audio Codecs


Recommended Posts

Thanks erp-ster7n! I went with the larger one from Dell's site and it works perfectly!  :danke:

Link to post
Share on other sites
  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

  • erp-ster7n

    405

  • stasio

    216

  • alanfox2000

    71

  • Andi_84

    70

Top Posters In This Topic

Posted Images

Realtek HD Audio Driver 6.0.1.8451 WHQL

OEM drivers only

ASUS

MSI

Win 10 x64
PackageVersion = PG466
DriverVer=05/22/2018, 6.0.1.8451

 

Complete driver:

LINK

Win 7,10 x32/64
PackageVersion = PG466
DriverVer=05/22/2018, 6.0.1.8451

 

MS update:

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.1.8451

 

Link to post
Share on other sites
Realtek HD Audio Driver 6.0.1.8454 WHQL
 
OEM drivers only
 
 
Win 10 x64
PackageVersion = PG466
DriverVer=05/29/2018, 6.0.1.8454
 

Complete driver:

LINK

Win 7,10 x32/64
PackageVersion = PG466
DriverVer=05/29/2018, 6.0.1.8454

 

MS update:

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.1.8454

 

Realtek HD Audio Driver 6.0.1.8456 WHQL

OEM drivers only

ASUS
Gigabyte

Win 10 x64
PackageVersion = PG467
DriverVer=05/30/2018, 6.0.1.8456

Link to post
Share on other sites

In searching the new Dell XPS 9570 drivers, i found a newer Dell Realtek driver here:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=04Y4G

...which, intrestingly, does NOT include any Waves MaxxAudio software. Instead, they have you install this:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=VWPKK

...which directs you to the Microsoft Store to download a new Waves MaxxAudioPro app.

Of course I tried it!  🙂  The driver installed fine and is very LOUD! But then when I tried to install the MaxxAudioPro app, the Microsoft Store said it couldn't be found. Since the XPS 9570 is actually shipping, that's surprising, but maybe it comes pre-installed on new machines.

Regardless. this is a change of direction for Dell audio.

Link to post
Share on other sites
54 minutes ago, LSudlow said:

In searching the new Dell XPS 9570 drivers, i found a newer Dell Realtek driver here:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=04Y4G

...which, intrestingly, does NOT include any Waves MaxxAudio software. Instead, they have you install this:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=VWPKK

...which directs you to the Microsoft Store to download a new Waves MaxxAudioPro app.

Of course I tried it!  🙂  The driver installed fine and is very LOUD! But then when I tried to install the MaxxAudioPro app, the Microsoft Store said it couldn't be found. Since the XPS 9570 is actually shipping, that's surprising, but maybe it comes pre-installed on new machines.

Regardless. this is a change of direction for Dell audio.

Driver installs fine for me too, and yes very loud, jumped at the first sound that came forth

Driver MaxxAudio error for me too, only reference in MS Store is related to a XPS9560

Link to post
Share on other sites

A work in progress, apparently.

Link to post
Share on other sites

Still odd that the installed refers to MS store at the beginning
Wonder if it checks to see if Notebook is available before you can install it

Link to post
Share on other sites

MS store has a Maxxaudio for Acer and Fujitsu
They both install, but the driver from Larry above is too old

Installed 8451 Had to search all the INFs for my PCI_ID

Now Maxxaudio from MS store works but to not sure if its doing anything, things light up on the knobs but can't tell if anything is happening

Link to post
Share on other sites

Tried running Maxxaudio again the out of date driver now comes up again even with driver  only a few days old
Got me beat

Link to post
Share on other sites

Yeah, no more luck here either.

Link to post
Share on other sites

v6.0.1.8447 (old) from Gigabyte (ASIA) (EUR) (CH) (USA)

my Gigabyte GA-78LMT-USB3 R2 board can use that driver though I can only get basic audio features - the Realtek audio control UWP app from the MS store doesn't install nor work on that board...at least not yet.

Link to post
Share on other sites
8 hours ago, erp-ster7n said:

v6.0.1.8447 (old) from Gigabyte (ASIA) (EUR) (CH) (USA)

my Gigabyte GA-78LMT-USB3 R2 board can use that driver though I can only get basic audio features - the Realtek audio control UWP app from the MS store doesn't install nor work on that board...at least not yet.

 Is for AMD AORUS boards.

Link to post
Share on other sites
On 6/2/2018 at 1:00 PM, LSudlow said:

In searching the new Dell XPS 9570 drivers, i found a newer Dell Realtek driver here:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=04Y4G

...which, intrestingly, does NOT include any Waves MaxxAudio software. Instead, they have you install this:

http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=VWPKK

...which directs you to the Microsoft Store to download a new Waves MaxxAudioPro app.

Of course I tried it!  🙂  The driver installed fine and is very LOUD! But then when I tried to install the MaxxAudioPro app, the Microsoft Store said it couldn't be found. Since the XPS 9570 is actually shipping, that's surprising, but maybe it comes pre-installed on new machines.

Regardless. this is a change of direction for Dell audio.

 

that 8428 driver pack from Dell is a Realtek UAD driver, unlike the 8425 version from Dell (which is a classic non-UAD version of the Realtek audio driver).  you should have used 7zip to check its contents.

the Realtek HWID "INTELAUDIO\FUNC_01&VEN_10EC&DEV_0298&SUBSYS_102807BE" is listed in the HDXDELLSSTCSMB2018.inf file and notice the INF file section begins with this [AzaliaManufacturerID.NTamd64.10.0...15063]; means driver requires at least Win10 build 15063 (RS2).

also when installing that v8428 "UAD" driver, there should be some Realtek Software Components listed in the Software Components section of Device Manager, and "Waves APO" should also be listed as a "Device Extension" somewhere in Device Manager.

Link to post
Share on other sites

Thanks erp-ster7n. It installs fine here. The only problem is the missing Waves app from the Microsoft store. I suspect this will be the future direction for all Dell audio drivers.

Link to post
Share on other sites

v6.0.1.8454  from Gigabyte

Win 7,10 x32/64
PackageVersion = PG466
DriverVer=05/29/2018, 6.0.1.8454

Link to post
Share on other sites

Realtek HD Audio Driver 6.0.1.8458 WHQL

OEM drivers only

LINK

Win 10 x64
PackageVersion = PG467
DriverVer=05/31/2018, 6.0.1.8458

Link to post
Share on other sites
On 5/26/2018 at 6:13 PM, stasio said:

Realtek HD Audio Driver 6.0.1.8451 WHQL

 

 

Stasio, your consistent, procedural updating of this thread with the very latest realtek WHQL drivers saved me hours of CPU wasted by audio isolation.

So much so that leaving my laptop alone for 6 hours encoding adobe proxies meant that my audio isolation process used as much background CPU as heavy video encoding.

 

Thank you stasio, you helped me solve my problem today.

Taskmgr_2018-06-07_19-35-42.png

Link to post
Share on other sites
On 6/5/2018 at 1:05 AM, stasio said:

v6.0.1.8454  from Gigabyte

Win 7,10 x32/64
PackageVersion = PG466
DriverVer=05/29/2018, 6.0.1.8454

ah this one seems to have most of the Creative integration DLL files (mbapo64.dll, mbthx64.dll, mbapo264.dll, mbwrp64.dll, etc.)  The mbppcn64.dll & mbppld64.dll files are not included in the package though.

I can use this 8454 driver on my Gigabyte 78LMT-USB3 R2 board which uses hwid "HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1458A182" and is mentioned in the HDXRtGi.inf file.

-

The Waves MaxxAudio UWP app from MS store is pretty much a "beta" and is a work in progress (and only works with at least Windows 10 RS2 build 15063 - Creators Update).  can you still use the older Maxxaudio software from the MaxxAudio Installer MSI file?

On 6/4/2018 at 10:19 AM, LSudlow said:

Thanks erp-ster7n. It installs fine here. The only problem is the missing Waves app from the Microsoft store. I suspect this will be the future direction for all Dell audio drivers.

Link to post
Share on other sites
13 minutes ago, erp-ster7n said:

The Waves MaxxAudio UWP app from MS store is pretty much a "beta" and is a work in progress (and only works with at least Windows 10 RS2 build 15063 - Creators Update).  can you still use the older Maxxaudio software from the MaxxAudio Installer MSI file?

I din't try it, although maybe I should have. The structure of the new driver is different enough that I was pretty sure it wouldn't work.

Link to post
Share on other sites

Realtek HD Audio Driver 6.0.1.8467 WHQL

OEM drivers only

MSI RTK

MSI Creative

MSI Nahimic

Asus

Gigabyte

Lenovo

Samsung

Win 10 x64

 

Gigabyte

Complete driver

Win 7,10 x32/64

PackageVersion = PG467
DriverVer=06/12/2018, 6.0.1.8467

Link to post
Share on other sites
On 6/7/2018 at 11:16 AM, LSudlow said:

I din't try it, although maybe I should have. The structure of the new driver is different enough that I was pretty sure it wouldn't work.

 

How to install Realtek UAD driver from PureSoftApps blog page (posted 6/12)

Requires Win10 build 15063 (RS2/v1703) or higher and DriverStoreExplorer to install Realtek extensions.

I'll try installing the Realtek UAD driver on the Gigabyte board first which uses Realtek ALC892 chipset with HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1458A182" and Win10 v1709.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...



×
×
  • Create New...