Jump to content
LaptopVideo2Go Forums
mobilenvidia

Latest Realtek Audio Codecs

Recommended Posts

DmiTrah
14 hours ago, erp-ster7n said:

the USA ban on Huawei devices was lifted this past weekend - stories on Neowin.net here and here

 

FF10 not available for 8742.1, kumagaya.  Realtek did not produce it

 

hardware ID of your Realtek audio device on xiaomi, DmiTrah?  8726.1 or higher, no.  8721, maybe since that is the latest generic UAD.

unrelated note - 8710.1 from MS Update Catalog (MS posted this one very late near the end of June)

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8710.1

 

 

hello HDAUDIO\FUNC_01&VEN_10EC&DEV_0298&SUBSYS_1D721701&REV_1001 

 

Share this post


Link to post
Share on other sites
jvidal
On 7/1/2019 at 6:46 PM, stasio said:

Win 7 or Win 8.1...?

on both. I just showed the win7 dialog, but it is WHQL for win81 as well.

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.8746.1 WHQL

8746_FF00_FF03_FF06

Win 7,10 x32/64
PackageVersion = PG473
DriverVer= 07/02/2019, 6.0.8746.1

Share this post


Link to post
Share on other sites
bdyekita
On 7/5/2019 at 6:24 AM, stasio said:

Realtek HD Audio Driver 6.0.8746.1 WHQL

8746_FF00_FF03_FF06

Win 7,10 x32/64
PackageVersion = PG473
DriverVer= 07/02/2019, 6.0.8746.1

stasio how about FFOC plz?

Share this post


Link to post
Share on other sites
erp-ster7n
On 7/10/2019 at 3:43 PM, bdyekita said:

stasio how about FFOC plz?

why do you need the FF0C version, bdyekita?  FF0C not available for 8746.1 because Realtek did not make one.  what kind of computer are you using?

latest FF0C HDA driver version is 8703.1.

----

unrelated note: I decided to post the 8746.1 UAD Gigabyte "1320" driver that Realtek recently made (alanfox2000 does not have this specific version - he has 8746.1 UAD Gigabyte 1410 driver instead which is a little buggy and some features of the Nahimic 3 UWP app do not work correctly with the 1410 driver; Nahimic 3 uwp app works better with the 8746 UAD 1320 driver)

 

Share this post


Link to post
Share on other sites
alanfox2000

Realtek HD Audio Driver 6.0.8750.1 WHQL

8750_FF00

Win 10 RS4 x32/64
PackageVersion = PG473
DriverVer=07/09/2019, 6.0.8750.1

Share this post


Link to post
Share on other sites
bdyekita
5 hours ago, erp-ster7n said:

why do you need the FF0C version, bdyekita?  FF0C not available for 8746.1 because Realtek did not make one.  what kind of computer are you using?

latest FF0C HDA driver version is 8703.1.

----

unrelated note: I decided to post the 8746.1 UAD Gigabyte "1320" driver that Realtek recently made (alanfox2000 does not have this specific version - he has 8746.1 UAD Gigabyte 1410 driver instead which is a little buggy and some features of the Nahimic 3 UWP app do not work correctly with the 1410 driver; Nahimic 3 uwp app works better with the 8746 UAD 1320 driver)

 

I Have problem with system notification sounds which does not work! but other sounds are OK. it's Alienware 17 and certainly has dolby powered by Klipsch . i should tell you that since while (windows 10 1803) Dolby app does not install on windows i should separately do that,but in 8703 driver i made some edited line for setup (configuration settings ) then it's OK now and Dolby app works fine.

I have tried all possible way to fix problem with system sounds of windows but still no sounds it's look like muted but it does not, early i posted a Quote here ,they suggested i am installing wrong driver!!!! which I am sure driver is all OK and FFOC is proper and right!

I am appreciate for replay,Thank you.

Share this post


Link to post
Share on other sites
jvidal

8750 WHQL for win7 as well. just installed it.

Share this post


Link to post
Share on other sites
Romagnolo1973
On 6/27/2019 at 3:51 AM, erp-ster7n said:

I also forgot to mention last time that Dolby Atmos has issues/problems working with latest Win10 version 1903😞

this issue has not yet been resolved on Microsoft's end or MS has not yet updated their Known Issues for 1903 page as to whether or not the problem is resolved and it is already near the end of June. (perhaps Dolby themselves have to tell Microsoft if they have published updated versions of Dolby Atmos from the MS store)

 

Issue with Dolby Atmos Headphones and Home Theatre fixed

https://mspoweruser.com/microsoft-fixes-more-issues-with-the-windows-10-may-2019-update/

 

Share this post


Link to post
Share on other sites
erp-ster7n
10 hours ago, Romagnolo1973 said:

Issue with Dolby Atmos Headphones and Home Theatre fixed

https://mspoweruser.com/microsoft-fixes-more-issues-with-the-windows-10-may-2019-update/

 

MS updated their Resolved issues for 1903 page on July 11 but did not say "how" they resolved the Dolby Atmos problem.

On 7/12/2019 at 2:25 AM, bdyekita said:

I Have problem with system notification sounds which does not work! but other sounds are OK. it's Alienware 17 and certainly has dolby powered by Klipsch . i should tell you that since while (windows 10 1803) Dolby app does not install on windows i should separately do that,but in 8703 driver i made some edited line for setup (configuration settings ) then it's OK now and Dolby app works fine.

I have tried all possible way to fix problem with system sounds of windows but still no sounds it's look like muted but it does not, early i posted a Quote here ,they suggested i am installing wrong driver!!!! which I am sure driver is all OK and FFOC is proper and right!

I am appreciate for replay,Thank you.

be more specific with the Dell Alienware 17 model, bdyekita as there are several versions of Alienware 17s (17, 17 R2, 17 R3, 17 R4 & 17 R5)

and which Dolby app are you trying to install as there are so many versions of Dolby? (my bro's Sony Vaio VPCEB laptop came with Dolby Home Theater V3 [PCEE3] noted in the screenshot & running Win7 Home Premium - gonna try installing the 8750 FF00 driver on there)

 

dolby-htv3-cpl.jpg

 

edit: also what do you mean by "made some edited line for setup (configuration settings )"?  did you mod/edited the Realtek driver or edited an INF file?

Edit 2: Try using 8703.1 FF10 instead of 8703.1 FF0C, bdyekita.  HDXSGAW.inf file from FF10 installs & registers Creative files along with the Dolby files

 

Share this post


Link to post
Share on other sites
Diablix

Hello everyone, can someone help me with installing latest Realtek UAD with Third party software - probably with proper Xperi driver/addon/extension, since DTS in under Xperi?

My M/B is Asrock X470 Taichi and one of the advertised features of this M/B is DTS Connect support, that should be able to compress 5.1 audio through digital optical S/PDIF connection. On other end is YAMAHA HTR-6030 that supports DTS Digital Surround.

However, no matter what I try, I can't find way to make it work. I tried both Realtek Driver 8470 that is no more on site that wasn't digitally signed, and the newest driver 8668 with Realtek Audio Console, tried uninstalling End-point in Device Manager, tried all combinations of formats, nothing works.

In Control Panel->Sound->Playback->Realtek Digital Output->Supported Formats I can test both DTS Audio & Dolby Digital and both correctly work on 5.1, and either in Control Panel->Sound->Playback->Realtek Digital Output->Advanced->Default Format or in Realtek aplication (one with old GUI) with Driver 8470 I could set DTS Interactive (5.1), but with driver 8668 I have just 2 channel options and I have to set DTS Interactive (5.1) in Realtek Audio Console. When I have turned on DTS Interactive (5.1), I can also turn on DTS Connect; with driver 8470 I could set in either in Control Panel, or in Realtek aplication, with driver 8668 I can set DTS Connect in Realtek Audio Console.

After a lot of troubleshooting, I made it work on VLC Media Player with DTS content, but common PCM 5.1 content and games with 5.1 support doesn't seem to work.

I found few articles from 2015 where it was stated, that DTS Connect was not working on Win 10 with cracked audio drivers, but I guess with supported M/B there shouldn't be a problem. There was other articles, that have offered new cracked drivers for Win 10, but I would like to make it work without potentionally unsecure drivers.

I hope support for DTS Connect is not made-up, since it is one of the reasons that I bought this M/B.

I am thankful for all help.

Share this post


Link to post
Share on other sites
bdyekita
On 7/13/2019 at 8:52 PM, erp-ster7n said:

MS updated their Resolved issues for 1903 page on July 11 but did not say "how" they resolved the Dolby Atmos problem.

be more specific with the Dell Alienware 17 model, bdyekita as there are several versions of Alienware 17s (17, 17 R2, 17 R3, 17 R4 & 17 R5)

and which Dolby app are you trying to install as there are so many versions of Dolby? (my bro's Sony Vaio VPCEB laptop came with Dolby Home Theater V3 [PCEE3] noted in the screenshot & running Win7 Home Premium - gonna try installing the 8750 FF00 driver on there)

 

dolby-htv3-cpl.jpg

 

edit: also what do you mean by "made some edited line for setup (configuration settings )"?  did you mod/edited the Realtek driver or edited an INF file?

Edit 2: Try using 8703.1 FF10 instead of 8703.1 FF0C, bdyekita.  HDXSGAW.inf file from FF10 installs & registers Creative files along with the Dolby files

 

sorry, I can send you my Alienware service tag: Alienware M17x BDPSD12 , Dell supports are crap, the latest driver for Audio is wrong with MaxxAudio! 

It must be Dolby Digital Plus Home Theatre version Dolby Digital Plus 7.6.3.1 or 7.6.5.1 (I use 7.6.3.1)

Attach the edited setting info file here.

Before I used very simple way to install Dolby Digital Plus Home Theatre with latest drivers, simply copy the folder of DS1 into the drivers folder, but now even if I do that does not install it, I should install Dolby Digital Plus Home Theatre after driver!

 

 

setup.ini

Share this post


Link to post
Share on other sites
erp-ster7n
On 7/18/2019 at 3:04 AM, bdyekita said:

sorry, I can send you my Alienware service tag: Alienware M17x BDPSD12 , Dell supports are crap, the latest driver for Audio is wrong with MaxxAudio! 

It must be Dolby Digital Plus Home Theatre version Dolby Digital Plus 7.6.3.1 or 7.6.5.1 (I use 7.6.3.1)

Attach the edited setting info file here.

Before I used very simple way to install Dolby Digital Plus Home Theatre with latest drivers, simply copy the folder of DS1 into the drivers folder, but now even if I do that does not install it, I should install Dolby Digital Plus Home Theatre after driver!

 

 

setup.ini 5.68 kB · 0 downloads

yup.  it seems Dell packaged the "wrong" audio enhancement software for your Alienware M17x laptop with Dell's Realtek 6.0.1.7525 A00 HDA drivers - I really got confused for days as to why Dell put the Maxxaudio app instead of the Dolby DS1 and PCEE4 apps in the newer Realtek HDA drivers.  the older 7260, 7055 & 6876 driver packs have the Dolby DS1 & PCEE4 apps.

no worries - just install the Dolby Digital Plus HT app manually afterwards after installing the Realtek HDA driver (I save a copy of the DolbyDigitalPlusHT.msi file in a different folder outside of the Realtek drivers folder and manually run it and do a "custom" install).   sometimes the Dolby Digital Plus HT app does not automatically get installed, even on certain Lenovo PCs that have that app bundled in the Realtek audio driver packs from Lenovo.

Edit 7/22: I just realized that the DolbyDigitalPlusAA.msi & DolbyDigitalPlusHT.msi files are stored in the \DS1\x86\ and \DS1\x64\ folders and not "exactly" the DS1 folder.  those MSI files come in both 32bit and 64bit versions.  use the 64bit version of DolbyDigitalPlusHT.msi file to install the Dolby Digital Plus x64 app.

 

 

 

Share this post


Link to post
Share on other sites
erp-ster7n
On 7/15/2019 at 9:07 AM, Diablix said:

Hello everyone, can someone help me with installing latest Realtek UAD with Third party software - probably with proper Xperi driver/addon/extension, since DTS in under Xperi?

My M/B is Asrock X470 Taichi and one of the advertised features of this M/B is DTS Connect support, that should be able to compress 5.1 audio through digital optical S/PDIF connection. On other end is YAMAHA HTR-6030 that supports DTS Digital Surround.

However, no matter what I try, I can't find way to make it work. I tried both Realtek Driver 8470 that is no more on site that wasn't digitally signed, and the newest driver 8668 with Realtek Audio Console, tried uninstalling End-point in Device Manager, tried all combinations of formats, nothing works.

In Control Panel->Sound->Playback->Realtek Digital Output->Supported Formats I can test both DTS Audio & Dolby Digital and both correctly work on 5.1, and either in Control Panel->Sound->Playback->Realtek Digital Output->Advanced->Default Format or in Realtek aplication (one with old GUI) with Driver 8470 I could set DTS Interactive (5.1), but with driver 8668 I have just 2 channel options and I have to set DTS Interactive (5.1) in Realtek Audio Console. When I have turned on DTS Interactive (5.1), I can also turn on DTS Connect; with driver 8470 I could set in either in Control Panel, or in Realtek aplication, with driver 8668 I can set DTS Connect in Realtek Audio Console.

After a lot of troubleshooting, I made it work on VLC Media Player with DTS content, but common PCM 5.1 content and games with 5.1 support doesn't seem to work.

I found few articles from 2015 where it was stated, that DTS Connect was not working on Win 10 with cracked audio drivers, but I guess with supported M/B there shouldn't be a problem. There was other articles, that have offered new cracked drivers for Win 10, but I would like to make it work without potentionally unsecure drivers.

I hope support for DTS Connect is not made-up, since it is one of the reasons that I bought this M/B.

I am thankful for all help.

 

Hi Diablix.   there is an 8710 UAD WHQL DTS driver from ASRock that you can try out on your ASRock X470 Taichi board.  the 8710 UAD driver is listed for X570 Taichi but may work for the X470.

 

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.8757.1 WHQL

8757_FF00

Win 7,10  x32/64
PackageVersion = PG473
DriverVer=07/17/2019, 6.0.8757.1

Share this post


Link to post
Share on other sites
stasio
On 7/11/2019 at 6:43 AM, bdyekita said:

stasio how about FFOC plz?

Latest FF0C WHQL is 8703.1

Share this post


Link to post
Share on other sites
erp-ster7n

since there are no new FF10 and FF0C WHQL based Realtek HDA drivers higher than 8703.1, I've obtained this 8756 HDA test driver a few days ago and installed them on my aunt's Dell Inspiron 580 desktop PC.  this 8756 HDA PG473 driver pack has conexant/fortemedia/nahimic/creative/maxxaudio integration files included similar to the old R2.82 package but since 8756 is signed by Realtek and not by MS, it's non-whql.  I'm content in using this one only on the Dell 580 machine

Share this post


Link to post
Share on other sites
alanfox2000

File 8757_FF00_PG473_Win10_RS3_RS4_RS5_19H1_Win7_WHQL.zip (WHQL Date 19/7/2019) remove from their server and replace with new same version and with Win10 RS1 RS2 support

Realtek HD Audio Driver 6.0.8757.1 WHQL Date 25/7/2019

8757_FF00

Win 7,10 RS1 RS2 RS3 RS4 RS5 19H1 x32/64
PackageVersion = PG473
DriverVer=07/17/2019, 6.0.8757.1

Edited by alanfox2000

Share this post


Link to post
Share on other sites
erp-ster7n

thanks alanfox for the updated 8757 FF00 HDA driver.

here's the link to the 8757 UAD Gigabyte driver since you don't have that one listed on your github page

now it has been about 2 years since Realtek released R2.82 HDA on their web site back on July 26, 2017

Share this post


Link to post
Share on other sites
erp-ster7n

6.0.8761.1 drivers (07/23/2019) for ASUS

HDA FF03 ASUS Nahimic  [WHQL for Win10 RS5/19H1 only; cannot install on Win7/8.x/Vista]

UAD ASUS "resell"  [WHQL for Win10 RS3 to 19H1 only]

 

 

Share this post


Link to post
Share on other sites
stasio
On 8/3/2019 at 2:28 AM, erp-ster7n said:

6.0.8761.1 drivers (07/23/2019) for ASUS

HDA FF03 ASUS Nahimic  [WHQL for Win10 RS5/19H1 only; cannot install on Win7/8.x/Vista]

UAD ASUS "resell"  [WHQL for Win10 RS3 to 19H1 only]

 

Asus had newer UAD WHQL driver.....LINK

Share this post


Link to post
Share on other sites
stasio

Got some latest UAD WHQL 8765 drivers for various brands....

LINK

Win 10 x64
PackageVersion = PG473
DriverVer=07/30/2019, 6.0.8765.1

 

Still no HDA yet.

 

Share this post


Link to post
Share on other sites
erp-ster7n

v6.0.8750.1 UAD (older version) from ASUS (includes RtkUWP app v1.3.185.0) [uses dism.exe to install Realtek Audio Console offline w/ no internet connection]

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.8773.1 WHQL

8773_FF00

Win 7,10 x32/64
PackageVersion = PG473
DriverVer= 08/06/2019, 6.0.8773.1

Share this post


Link to post
Share on other sites
erp-ster7n

8773 UAD Gigabyte XPERI/DTS driver (preliminary XPERI/DTS uwp support for SUBSYSTEM IDs 1458A0D2, 1458A0D3 & 1458A0D4 - no actual Xperi/DTS UWP integration included yet but has HDX_GigabyteExt_XPERI4_RTK.inf extension INF file)

 

On 7/1/2019 at 11:07 PM, DmiTrah said:

hello HDAUDIO\FUNC_01&VEN_10EC&DEV_0298&SUBSYS_1D721701&REV_1001 

 

I'm sorry DmiTrah I can not fulfill your request for a customized UAD driver for your machine since I did not respond for a long time - HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0298&SUBSYS_1D721701" only listed/supported for HDA drivers; only non-UWP (win32/desktop) Dolby integration is available for SUBSYS ID "1D721701"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...