Jump to content
LaptopVideo2Go Forums

Can't activate PhysX with drivers newer than 185.68 (Windows 7 RC1 64Bit; 9600GT Green Edition)


Guest ghost_zero

Recommended Posts

Guest ghost_zero

Hi,

actually the topic title already says it. Up to 185.68 I was perfectly able to activate PhysX over the nVidia control panel.

HOWEVER, with all newer drivers (I even tried the 190.15 Beta and your modified .inf file - otherwise I wouldn't have been able to install them - from your site) the PhysX option is completely missing from the nVidia control panel and if I open PhysX settings only the nVidia control panel pops up. The PhysX version is reported correctly by the control panel though.

I tried to edit "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Ageia Technologies\HwSelection" value to GPU but that also doesn't get it to work (tried PhysX FluidMark).

Is there some workaround here? Like maybe combining the old control panel with the newer driver?

I am especially asking because the performance speed of PhysX with 185.68 under Windows 7 RC1 is terrible. I hoped that this might have changed with newer versions.

For example: The PhysX Fluidmark Minimum FPS are about one third (about 13-15 FPS) of what I got under XP x64 (about 43-45 FPS) with the same driver version (I am not to sure anymore but I believe newer driver versions also didn't give me the PhysX option under XP x64).

Link to comment
Share on other sites

Have you tried installing physx separately? It is available in the physx section of this forum

Link to comment
Share on other sites

  • 2 weeks later...
Guest ghost_zero

OK. It seem to be related to the point that I only want to use the 9600GT as PhysX card but have an ATi card as main card because once I disable (in the device manager) the ATi card, the PhysX option appears in the control panel but once I re-enable it, the option is gone again.

I wonder if this was done on purpose and if there is something I can do against it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...