Jump to content
LaptopVideo2Go Forums

Geforce Go 6600 on windows 7


vjkid137

Recommended Posts

I have the card in the title on my 4 yr old ibuypower notebook. I just recently upgraded from XP to Vista to Windows 7. I tried the 186.82 i think it was but my monitor shows nothing past the "starting windows" screen so i know it still works. the only way i am typing this now is by using my lcd tv as my monitor. anyone know what could be wrong?

update: uninstalling the video drviers lets me use the monitor but only in a crappy resolution. i just tried Dox's drivers from another thread but get the same thing as before, no picture past the "starting windows" screen.

Edited by vjkid137
Link to comment
Share on other sites

i have with no luck. this is the message i get after uninstalling the driver.

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

Link to comment
Share on other sites

  • 1 month later...
Guest Charlie

I have the card in the title on my 4 yr old ibuypower notebook. I just recently upgraded from XP to Vista to Windows 7. I tried the 186.82 i think it was but my monitor shows nothing past the "starting windows" screen so i know it still works. the only way i am typing this now is by using my lcd tv as my monitor. anyone know what could be wrong?

update: uninstalling the video drviers lets me use the monitor but only in a crappy resolution. i just tried Dox's drivers from another thread but get the same thing as before, no picture past the "starting windows" screen.

hi... you fix the problem ?? i have the same problen with a nvidia 6600 in my alienware... please help...

Link to comment
Share on other sites

  • 2 weeks later...
Guest Callahan

Is there a driver for Windows 7 for my 6800 Go? Or arent they really supported? My device id: PCI\VEN_10DE&DEV_00C8&SUBSYS_107C1734

I have tried both drivers for Vista with modded inf:s and tried to change the inf-file in Windows 7 drivers. I have tried old Win Xp drivers as well and often games and all runs very well but i cant set up multi monitors on my laptop, like running my TV as secondary display. Is it because of Windows 7 or bad driver support?

It feels like i tiny thing for me but, could you guys fix this problem? Do i need a special modified inf to get this card in my laptop rocking again? Is it just possible for me to modify an inf-file by my self just by adding the line PCI\VEN_10DE&DEV_00C8&SUBSYS_107C1734 on the right place? Alot of questions but just 1 problem.

Link to comment
Share on other sites

  • 2 years later...
Guest ashford

Hi, Please Help!

My Laptop a SAMSUNG M70 has a GeForce Go 6600 128MB in it,

Running Windows 7 Ultimate 32 Bit, using the standard VGA driver as cannot find an suitable driver that works!

Some from this site install but will give me a black screen past windows Startup.

I have to remove the driver in safe mode and revert to standard VGA to get to work again.

The Samsung support site only lists Vista and XP drivers, Tried these - No Good. -No support from the Nvidea site.

Please can someone write me and all the other people with the same card a Driver.

ASH Many Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...