Jump to content
LaptopVideo2Go Forums
Dox

Forceware 195.62

Recommended Posts

Guest Natas

Problem with this method is that there are new files and registry settings that will be installed due to the existing files and INF entries. That is the reason for the INF edits and new INF.

You can either download the new patch here or rename the .tvp files in the old patch to .vp in x64_patch directory and then do a manual install. Very important to do a manual install if setup.exe wont work. This should work. I don't mean to be bypassing your awesome installer Dox sorry.

So detailed instructions:

1.) Run Dox Installer (195.62_Win7x64 1.1.exe)

2.) Wait for it to extract drivers to the desktop ("Win7x64" folder on desktop)

3.) Close Dox Installer (Sorry Dox) :)

4.) Extract Dox195.62_Fix_W7x64.exe to the "Win7x64" folder on desktop replacing the existing INF (You should now have a "x64_patch" folder inside the "Win7x64" folder to go along with the INF that was replaced)

5.) Open Device Manager and do a manual install. (On Vaio Z make sure the switch is set to Speed. You should only really need to update the Nvidia drivers as both should install at the same time.)

6.)Enjoy. (Don't forget to make sure testmode is enabled and sign the drivers.)

This works with Asus UL80VT. Brigthness Fn keys are broken and there is no option for PhysX though.

Share this post


Link to post
Share on other sites
Guest Natas

This works with Asus UL80VT. Brigthness Fn keys are broken and there is no option for PhysX though.

And when you select power saving mode and enable the integrated graphics, the geforce stays on in the background and keeps on sucking the battery's juice...

Share this post


Link to post
Share on other sites
Nautis1100

This works with Asus UL80VT. Brigthness Fn keys are broken and there is no option for PhysX though.

Hey I said working... I didn't say fully. :)

Let me look at a couple of things and I will edit this post. I think I know the physx fix.

EDIT: PhysX

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]

"PhysXShowUI"=dword:00000001

Glad it is working for ya btw, at least partially.

And when you select power saving mode and enable the integrated graphics, the geforce stays on in the background and keeps on sucking the battery's juice...

Hmm... can you give me a link to the official drivers for your Asus? EDIT: Nevermind found it 186.88?

And can you switch back to Nvidia from Intel?

Share this post


Link to post
Share on other sites
Guest Natas

Hey I said working... I didn't say fully. :)

Let me look at a couple of things and I will edit this post. I think I know the physx fix.

Glad it is working for ya btw.

Hmm... can you give me a link to the official drivers for your Asus? EDIT: Nevermind found it 186.88?

And can you switch back to Nvidia from Intel?

I can switch from Nvidia to Intel and vice versa with the tray icon. 186.88 seems rights.

Share this post


Link to post
Share on other sites
Guest tastier

It's working here, followed instructions with last patch(Dox195.62_Fix_W7x64.exe", on first attempt only the intel driver installed but after a reboot into testing mode and a second manual install it worked. Yes, I can switch between intel and nVidia just fine with the tray icon, switching between GPUs via power profiles isn't there though.

UL30VT

X64 Windows 7 Ultimate

G210M with nVidia 195.62 driver

Working with 195.62_Win7x64 1.1.exe patched with Dox195.62_Fix_W7x64.exe and installed manually via device manager in testing mode(dseo13b.exe).

Signed files(dseo13b.exe):

C:\Windows\System32\drivers\nvlddmkm.sys

C:\Windows\System32\drivers\igdkmd64.sys

This is great, very happy here, thanks guys.

Share this post


Link to post
Share on other sites
Guest tastier

Just to be verbose and for clarity, I realised that one needs to be in testing mode even if the drivers have been signed, I probably should have gathered that if I'd read previous instructions more carefully. Permanently in testing mode here now, with watermarks turned off, I wonder if there are any implications to running in testing mode like this?

Btw, these new drivers are like a hardware upgrade, can't thank you guys enough.

Cheers

Share this post


Link to post
Share on other sites
Dox

wohoo shall update the first post!

Thanks Nautis!

Share this post


Link to post
Share on other sites
HMoo

So detailed instructions:

1.) Run Dox Installer (195.62_Win7x64 1.1.exe)

2.) Wait for it to extract drivers to the desktop ("Win7x64" folder on desktop)

3.) Close Dox Installer (Sorry Dox) :)

4.) Extract Dox195.62_Fix_W7x64.exe to the "Win7x64" folder on desktop replacing the existing INF (You should now have a "x64_patch" folder inside the "Win7x64" folder to go along with the INF that was replaced)

5.) Open Device Manager and do a manual install. (On Vaio Z make sure the switch is set to Speed. You should only really need to update the Nvidia drivers as both should install at the same time.)

6.)Enjoy. (Don't forget to make sure testmode is enabled and sign the drivers.)

It work for me; s42 win 7 x64.

thanks.

Share this post


Link to post
Share on other sites
Guest Natas

Just to be verbose and for clarity, I realised that one needs to be in testing mode even if the drivers have been signed, I probably should have gathered that if I'd read previous instructions more carefully. Permanently in testing mode here now, with watermarks turned off, I wonder if there are any implications to running in testing mode like this?

Btw, these new drivers are like a hardware upgrade, can't thank you guys enough.

Cheers

Did you notice that when you run with integrated graphics the nvidia card stays on? normally, it should go to sleep within 2 minutes after the switch to integrated (it disappears from the device manager).

Share this post


Link to post
Share on other sites
Darmach

Did you notice that when you run with integrated graphics the nvidia card stays on? normally, it should go to sleep within 2 minutes after the switch to integrated (it disappears from the device manager).

Thats definitely not a good thing - u could have bought "normal" one graphic adapter notebook if u wouldn't care about battery runtime :)

For me - this driver bumped my 3D mark score from 3300 to 3420 points, but games performance didn't move at all....

I have some saves for testing purposes only - and bioshock framerate stays the same, borderlands an cod4 same or even 1 fps lower - but this can be a mistake.

OFC thank you guys for your work anyway :) u are the only hope for asus users, since asus doesn't care enough for supporting their software...

Edited by Darmach

Share this post


Link to post
Share on other sites
Guest tastier

Rather unscientific but this is what I've found so far until I find a utility to measure load, drain and battery stuff.

On Intel, wait for it to settle, 4hrs 47min remaining. It stayed at 4:47 a while and increased to 4:54 after a few min.

On nVidia, wait for it to settle, falls to 3hrs 52min and keeps declining, but not as fast as I would expect. I think the lack of load and the new adaptive power mode in these drivers are keeping the G210Ms drain low but there definitely seems to be a distinct difference switching between the two GPUs load wise. No, the nVidia card is not dropping from the device manager with these drivers, I have checked the power options which are set for 2 minutes.

Settle period was around 10mins, have now switched back to intel, now reads 4:30.

Share this post


Link to post
Share on other sites
Guest tastier

About game performance, played a little oblivion, that seemed pretty much the same(old). Mass Effect 2 on the other hand is running subjectively better as I haven't made any measurements but it definitely feels smoother now, guess with the new driver there is less software emulations of certain graphics functions freeing up some CPU?

Hey, as I was writing this the G210M disabled itself in device manager while on intel! so much for the 2 min. setting.

Share this post


Link to post
Share on other sites
Guest Natas

About game performance, played a little oblivion, that seemed pretty much the same(old). Mass Effect 2 on the other hand is running subjectively better as I haven't made any measurements but it definitely feels smoother now, guess with the new driver there is less software emulations of certain graphics functions freeing up some CPU?

Hey, as I was writing this the G210M disabled itself in device manager while on intel! so much for the 2 min. setting.

How long did it take after the switch to disable itself?

Share this post


Link to post
Share on other sites
Nautis1100

I am going to continue working on these to see if I can fix the problems you guys are having. Glad the fix is at least functioning somewhat.

Hybrid Graphics can be very unpredictable since we never know how how well the Intel and Nvidia drivers will interact. To top it off we are trying something completely new here in packaging drivers that work for most/all Hybrid Graphics notebooks.

Remember that these are experimental at this point.

EDIT: First thing for us to try is to see if the problems are just a settings issue. Give me a little time and I will have either a registry import or a new INF for you UL30VT users to try (maybe everyone else too).

Share this post


Link to post
Share on other sites
MingZ

Thanks Dox and Nautis1100 it is working on my BenQ S42 ^_^

(Working with 195.62_Win7x64 1.1.exe patched with Dox195.62_Fix_W7x64.exe and installed manually)

Share this post


Link to post
Share on other sites
Nautis1100

UL30VT users try this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"PhysXShowUI"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\Hybrid]
"SkipIntelUmdCapella"=dword:00000001

This should get you PhysX in the control panel and maybe fix both GPUs running together. If you don't know how to regedit you can copy everything in the box above and paste it into notepad, then save it as UL30VT.reg and run it.

Those non-UL30VT users just wanting PhysX in the control panel:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"PhysXShowUI"=dword:00000001

NOTE: You will need to reboot after importing in order for these settings to be applied. Make sure the PhysX drivers are installed also.

WARNING: PHYSX COULD CAUSE YOUR GPU TO BECOME EXTREMELY HOT! (Depending on the GPU)

Share this post


Link to post
Share on other sites
Darmach

I am having trouble installing those drivers. (Yes i am doing this for second time :)

When i try to manually install them i get "windows cannot find files" message....

EDIT:

oh nevermind that - it just fixed itself someway o_0

EDIT:

I did "SkipIntelUmdCapella" registry "mod" and it looks like i can switch graphics adapters both way - until i'm on intel and nvidia goes asleep -- when i try to switch to GF then - i get black screen...

another one EDIT:

Hmmm.. Without "SkipIntelUmdCapella" registry value - i get the same effect ---> black screen when switching from intel to disabled nvidia.

Edited by Darmach

Share this post


Link to post
Share on other sites
Guest Natas

UL30VT users try this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"PhysXShowUI"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\Hybrid]
"SkipIntelUmdCapella"=dword:00000001

This should get you PhysX in the control panel and maybe fix both GPUs running together. If you don't know how to regedit you can copy everything in the box above and paste it into notepad, then save it as UL30VT.reg and run it.

Those non-UL30VT users just wanting PhysX in the control panel:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"PhysXShowUI"=dword:00000001

NOTE: You will need to reboot after importing in order for these settings to be applied. Make sure the PhysX drivers are installed also.

WARNING: PHYSX COULD CAUSE YOUR GPU TO BECOME EXTREMELY HOT! (Depending on the GPU)

The GeForce stays on when switched to integrated graphics after I loaded the .reg file and rebooted (PhysX works though, thanks!).

Share this post


Link to post
Share on other sites
Darmach

Did u wait? I mean - like 10 mins

(yes - its about 10 mins to disable gforce :) but with or without this registry valuse ^^ it doesn't matter :))

Share this post


Link to post
Share on other sites
Darmach

I am having trouble installing those drivers. (Yes i am doing this for second time :)

When i try to manually install them i get "windows cannot find files" message....

EDIT:

oh nevermind that - it just fixed itself someway o_0

EDIT:

I did "SkipIntelUmdCapella" registry "mod" and it looks like i can switch graphics adapters both way - until i'm on intel and nvidia goes asleep -- when i try to switch to GF then - i get black screen...

another one EDIT:

Hmmm.. Without "SkipIntelUmdCapella" registry value - i get the same effect ---> black screen when switching from intel to disabled nvidia.

Hmmm.. It looks like this behaviour is random.. Before i get it every time - i tried about 10 times... On 11th - it switched back from intel to disabled nvidia without problems.....

Share this post


Link to post
Share on other sites
Guest Natas

Did u wait? I mean - like 10 mins

(yes - its about 10 mins to disable gforce :) but with or without this registry valuse ^^ it doesn't matter :))

I waited about 5 minutes. With the official Asus driver it takes 2 minutes to switch off the Nvidia. So I thought, if it's working as intended it should take 2 minutes :P

Share this post


Link to post
Share on other sites
Guest tastier

Some rough tests with Batterybar discharge rates.

With bundled Asus driver:

nvidia 9000-10000 mW

intel 6500-7500 mW

With Dox patched 195.62 driver. (before g210m auto disabled)

nvidia 8500-9500 mW

intel 7500-8500 mW

Not much difference between the intel and nvidia, especially in the second case, of course this is idling and I'm sure the intel uses far less power under load. Subjectively battery does seem to be draining faster with the Dox release but can't be sure yet.

Strangely, at boot with intel the initial discharge rate was around 13000 mW but becomes what's expected after switching back a forth between nvidia and intel. I think this may be because of the larger discharge during boot causing a higher initial average in Batterybar.

Just noticed another strange aberration, screen flickered and now I see the discharge rate is up to around 12300 mW, can even hear the fan went up a notch, have done nothing extra, g210m still looks disabled in device manager. When the screen flickered there was also a pop on the speakers, seem to recall having heard these before with the Dox driver, seems that perhaps the nvidia hardware is turning back on after a while, not off. whew, now I'm confused.

Note, don't read too much into the mW values above as I have X25 G2 and replaced Wifi 5Ghz mini-pcie.

I've have also applied these recommended registry entries.

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]

"PhysXShowUI"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\Hybrid]

"SkipIntelUmdCapella"=dword:00000001

In summary, it seems hybrid switching is still broken in the Dox 195.62 driver with patches, still seeing a discharge rate of +-13000 mW since that screen flicker and other anomalous discharges:), this is when I wish Windows had dmesg.

Share this post


Link to post
Share on other sites
Nautis1100

Ok let me redo the INF and see if it helps. Thanks for all the great info everyone it helps alot.

Share this post


Link to post
Share on other sites
Guest DrIGGI

Can't play BF BC2 with this Driver :)

It won't start, no error message

Using a 9650m GS @ win7 64bit

Share this post


Link to post
Share on other sites
Darmach

Maybe u know - what does "BacklightControlPolicy" registry entry control?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...