Jump to content
LaptopVideo2Go Forums

BF bad company 2 PC beta issue


Guest ALo

Recommended Posts

hi guys

i got a problem running the beta and i believe its cus of the hardware, whenever i try to connect a server , while its loading the map , the game crashes to desktop, somtimes m about to select the kit and it CTD,

any suggestions like running some sort of commands to force it to work, i have tried adding +fullproc to shortcut, turnoff firewall, update the drivers, but still alas!...

some other guys have the same issue runnin the game on the same system, i.e. m1710, i belive it cud be the dual core or sound card, but i have seen ppl runnin it on single cores, any help wud be highly appreciated.

thx

i got a XPS1710 notebook

vista 32

dual core

2gb ram

7950gtx

Link to comment
Share on other sites

Guest soulmist

I am having the same difficulty. I am also running a Dell XPS M1710, w/ a Nvidia Geforce 7950 GTX 512mb

My cpu is a core2duo T7600 overclocked to 2.83 ghz w/ 4 gig of ram on windows 7 32bit.

Same exact problem as you, it crashes right after I connect to a map.

I came here to try out other drivers and see if it a driver issue.

I'm currently using a modded inf w/ driver version 181.22

Although I get some distortion when I minimize and maximize windows, it is the best driver I found to support running GTA4 on this system, so I hesitate to change...

However, I want to know if Battlefield Bad Company 2 will work so I can know if I should cancel my preorder or not.

I'll try to post back here when I have tested a few other driver versions.

Please let me know if you find a solution to our problem, I'd appreciate it greatly!

Link to comment
Share on other sites

Well, this is a beta so lapses in functionality like these are to be expected. I don't have a fix and because of the nature of the problem the only probable one is to wait for an update to the beta or wait for the full version to be released.

Link to comment
Share on other sites

Guest Komsomol

I have the exact same setup as you and was having the exact same issue.

I solved the issue and im now playing away no problem at all :)

I updated my video card drivers to the latest official drivers from the nvidia website but was still having the issue.

How did i solve it you ask? Well i simply downloaded the latest drivers from this amazing website, 196.34 and then downloaded the modified inf file in the same page so it works with my geforce go 7950 gtx. Simply install the drivers to your desktop or anywhere on your computer, then copy and paste the modified inf file into that folder where you installed the drivers. Then run the setup.exe in the folder, reboot when prompted and viola! Issue solved! (for me atleast)

Working so far on 1024x768 on low, havn't tried yet on any other settings as i wanted to share the good news :)

Link to comment
Share on other sites

I have the exact same setup as you and was having the exact same issue.

I solved the issue and im now playing away no problem at all :)

I updated my video card drivers to the latest official drivers from the nvidia website but was still having the issue.

How did i solve it you ask? Well i simply downloaded the latest drivers from this amazing website, 196.34 and then downloaded the modified inf file in the same page so it works with my geforce go 7950 gtx. Simply install the drivers to your desktop or anywhere on your computer, then copy and paste the modified inf file into that folder where you installed the drivers. Then run the setup.exe in the folder, reboot when prompted and viola! Issue solved! (for me atleast)

Working so far on 1024x768 on low, havn't tried yet on any other settings as i wanted to share the good news :)

dude i get an error of invalid app for win32....anyone help plzzz..thx

Link to comment
Share on other sites

Guest Komsomol

dude i get an error of invalid app for win32....anyone help plzzz..thx

Might have been a good idea to post that error in your original post then...

Up to you if you want to try my fix or not!

Link to comment
Share on other sites

Might have been a good idea to post that error in your original post then...

Up to you if you want to try my fix or not!

i mean it doesnt let me install the driver 196.34, incompatibility error shows up , or just ecountered an error will come up,,

how did u install it? r u using a notebook cuz i am , M1710

thx

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...