Jump to content
LaptopVideo2Go Forums

Hybrid Graphics Master Set Drivers


Recommended Posts

I had been waiting for an official GPU driver update from ASUS for my ASUS UL50VT for a long time...

Obviously, ASUS aren't releasing any since after so many years have passed....

I thought I can live with the ancient GPU driver that shipped with the ASUS UL50VT even though the stock driver keeps causing my laptop to reboot (BSOD) from time to time, now I finally realized that I can't stand it any longer...

Why? because I am a Firefox user and have been experiencing very slow performance on the last few major revisions, i.e. Firefox 5, 6, 7. I have been wondering what the problem was until I was wondering if my Firefox has hardware acceleration enabled or not... As soon as I run the check, I suddenly realized why my Firefox keeps lagging so much, consumes ridiculous amount of ram and cpu. (FYI, Chrome was able to utilize hardware acceleration even on the ancient GPU driver...). This is because Firefox needs 257 or newer GPU driver in order to enable hardware acceleration.

Then, I quickly proceed to search the internet and find the latest driver mod for it (I knew a driver mod was available ages ago but I just didn't bother to go through the trouble to try it.). However, I downloaded all the hybrid drivers from this forum, tried every single one of them but none of them worked.....(this took me the entire day...sigh..)

This does not make sense because others have quoted the driver working on my laptop, ASUS UL50VT.

So, I resort to test the driver on a fresh installation of Windows 7 64 bit ultimate with SP1 . Here is my results

Asus UL50VT, running a freah installation of Windows 7 64 bit ultimate with SP1

265.90 - Can install but after reboot, the screen is black, can't see anything.

260.63 - Working perfectly (on the 2nd try, 1st try did't work for some odd reason, Windows says some driver component cannot be loaded/found or similar). I can switch the Nvidia GPU on and off with this driver by clicking on the icon at the taskbar, great.

258.96 - cannot install

258.49 - cannot install

197 (from an earlier thread) - seems to work fine, can switch the Nvidia GPU on and off. However, this is still too old to enable Firefox hardware acceleration.

As mentioned by someone in this thread, it is actually easiest to press F8 and select disable driver signature check when testing new driver rather than using the Driver Signature Enforcement Overrider software.

Finally, if you also have a similar issue with very slow Firefox running on Nvidia + Intel Hybrid graphics card. Check and see if your Firefox's hardware acceleration is enabled or not (google how to do this). If not, your only option is to upgrade to a newer driver or switch to Chrome if you can't be bothered or don't have the skill to install non-official drivers.

From this forum, I see that Optimus driver doesn't allow the system to switch off the Nvidia GPU. Hence, I think I would stick with 260.63 for the time being.....

Thanks you Nautis for making this driver available to us all. I know it is a very tedious and time consuming process to test as well as modify the driver. I nearly gave up when the driver fail to work after I have tried it all day on Windows 7 I was running, until I decide to try it with a fresh installation as well. Thank you for continuing to help everyone using the hybrid graphics card...

I hope this new driver will also solve (or at least reduce) the BSOD problem I have been having since the first day I brought this laptop.... ASUS support isn't helping and the BSOD problem is almost impossible to reproduce.... it is so random and can sometimes run perfectly for days.... (I will come back and comment or maybe try the Optimus driver if I experienced further BSOD. So far, zero BSOD though....)

Btw, there is a newer version of Power4Gear Hybrid V1.1.48 and Wireless console V3.0.24, which I have installed and works fine on the UL50VT at the time this is posted.

I also waited for some time. Now I have followed your tips and updated with 260.63 | 2020 driver. The 2020 driver I have updated with VGA_Intel_GMA_Win7_64_z815102202 (2202) to have Firefox's hardware acceleration during low power mode. This driver is also signed!

Edit: bummer! If I update to 2202, I cannot switch cards anymore! Looks like not so easy...

Edited by nlmobile
Link to post
Share on other sites
  • Replies 561
  • Created
  • Last Reply

Top Posters In This Topic

  • Nautis1100

    79

  • Freak

    77

  • narniaforever

    15

Sod it, gonna sell my laptop. Optimus Graphics is the worst idea ever, especially when there is no BIOS to either disable or select just one primary card.

Who cares if XP is old, it does everything Windows 7, does only faster.

Link to post
Share on other sites
  • 2 weeks later...

installing latest VERDE drivers 285.62 whql over asus video driver works perfectly!!! nothing to do, just activate the G210m via the switch, launch nvidia verde driver install, reboot and VOILA!

driver link http://www.nvidia.fr...-driver-fr.html

Edited by asphalt
Link to post
Share on other sites

Besides having abismal power management, memory management, and resource usage, XP is a virus haven, so the only people who have a valid excuse to use it are offices and such. And to correct the guest above, Windows 7 does everything XP does, only better and safer.

Link to post
Share on other sites
  • 1 month later...

Hi there ! can anyone install nvidia 310m ? i have asus a52j and i can't install nvidia 310m. i see yellow triangle with excalation.i tried this driver too.. no look

Link to post
Share on other sites

no. how i can download that file. ? you can help me tribaljet? i already opened one topic with my problem . please visit that topic for more info or problem codes. thank you TRIBALJET .

http://forums.laptopvideo2go.com/forum/161-nautis1100-hybrid-and-optimus-drivers/

Link to post
Share on other sites
  • 1 month later...

Hello,

I installed the hybrid drivers for my vaio z48 NB with Nvidia 9300M GS video card.

I wonder if there is a way to update the drivers with the latest Nvidia / Intel Driver?

My hardware ID is following:

PCI\VEN_10DE&DEV_06E5&SUBSYS_9025104D&REV_A1

PCI\VEN_10DE&DEV_06E5&SUBSYS_9025104D

PCI\VEN_10DE&DEV_06E5&CC_030000

PCI\VEN_10DE&DEV_06E5&CC_0300

Please contact me at Shigeru_go@hotmail.com if any additional information is needed.

p.s.

I could do it on my own for future update version of drivers if there is a instruction on how i can package my own video driver for my vaio z.

Thank you.

Edited by Shigeru Go
Link to post
Share on other sites

Hi, I'm new in here and I need help with this GT 130M driver problem. I'd tried all the drivers and inf modified that avalaible on this forum as well as Hybrid driver + Driver signing program which gimme black screen after "sign system file" things.

On my device manager only shows 1 display adpater Mobile Intel

dn1bj.jpg

and somtimes shows 2 display adapters however both still Mobile Intel

dn2h.jpg

My notebook is Acer Aspire 5935G, Nvidia GT 130M, and GT 130M never shows up as a display manager sinced I install windows 7

Please whoever success with the installation of the driver with same notebook and graphic card, would u mind to send me step by step instruction to my email edosusanto1978@yahoo.com or via PM. Thanks in advance

pardon for my bad english

Link to post
Share on other sites
victor.indrajit

please add acer aspire 5745G

I am using windows 7 ultimate 64 Bit

I have a hybrid graphics card

its nvidia Geforce GT 330M

hardware ids are

PCI\VEN_10DE&DEV_0A29&SUBSYS_035B1025&REV_A2

PCI\VEN_10DE&DEV_0A29&SUBSYS_035B1025

PCI\VEN_10DE&DEV_0A29&CC_030000

PCI\VEN_10DE&DEV_0A29&CC_0300

email id : victor.indrajit.1@gmail.com

victor.indrajit@gmail.com

Edited by victor.indrajit
Link to post
Share on other sites
  • 2 weeks later...

(from Poland :)

Dears,

1.
does it exist driver for nVidia GeForce GT 520MX (in notebook: Samsung NP300V5A-S0APL, hybrid graphics: GForce & Intel) but for 32-bit Windows XP...? (for Intel exists).

2.
or maybe... to disconnect Intel video card & get any compatible driver (but which?) for GT 520MX as singly.

btw:
I have seen it: http://forums.nvidia.com/index.php?showtopic=181300
but what is the definitiv answer?

thx & best regards

 

 

11.06.2013:       nobody knows? :(

Edited by covo
Link to post
Share on other sites
  • 2 weeks later...

Running Hybrid Graphics Master Set for Win Vista/7 64bit [Nvidia: 191.97 | Intel: 1994] but the auto detector (that automatically switches from power saving to discreet) isn't working.. Also when I use the top left key to try to cycle through the video cards, they don't switch... Is this suppose to work?

Also i can't adjust the brightness fi

Edited by numus
Link to post
Share on other sites

no. how i can download that file. ? you can help me tribaljet? i already opened one topic with my problem . please visit that topic for more info or problem codes. thank you TRIBALJET .

http://forums.laptop...ptimus-drivers/

Well, your GPU is new enough that you should be able to just download a WHQL driver like 296.10 or 301.42, download the modified .inf that's available on each specific driver version topic, replace the .inf that comes with the driver with the modified .inf, and it should enable you to install the driver.

Link to post
Share on other sites
  • 2 weeks later...
Namesdontmatter

I managed to install the newest package I found in this thread (260.63/2020), I couldn't do a clean install in my laptop (UL30vt) because I don't have a flash drive available at the moment..

Deleting the original Intel drivers is needed, because every time you uninstall them, windows install them automatically, even when you have set the automatic installs to "never"..

What I had to do, is delete the intel drivers from C:\Windows\System32\DriverStore\FileRepository. First you find the name of the driver, in Device Manager > Intel Device > Properties > Driver Detail.. then you search the driver name in the FileRepository folder, and delete them.. Probably you will need to take ownership of the file, to do so, save the following as something.reg (note the extension), and run it.. then you can do right button > take ownership on any file and delete it without problem.. after that, the new driver will install flawlessly..

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"

Or for lazy users just use Unlocker.

I think I have a better way to uninstall intel drivers. Try using the Asus VGA Patch, it removes intel drivers one click on asus. I think if you swap the hardware ID in the batch file, it just could work.

Part1_VGA_Patch.zip

or grab from asus website http://www.asus.com/Notebooks/Superior_Mobility/UL50Vt/#download under VGA --> VGA Patch

Edited by Namesdontmatter
Link to post
Share on other sites
  • 1 month later...

installing latest VERDE drivers 285.62 whql over asus video driver works perfectly!!! nothing to do, just activate the G210m via the switch, launch nvidia verde driver install, reboot and VOILA!

driver link http://www.nvidia.fr...-driver-fr.html

English version: http://www.nvidia.com/object/notebook-win7-winvista-64bit-285.62-whql-driver.html

I'll have to give this a try.

Link to post
Share on other sites

English version: http://www.nvidia.co...hql-driver.html

I'll have to give this a try.

I'll also give it a try, but do you suggest always uninstall the previous drivers first, and then install the new ones?

Thanks!

Link to post
Share on other sites

I'll also give it a try, but do you suggest always uninstall the previous drivers first, and then install the new ones?

Thanks!

Any Luck getting it to work? I didn't have any. I think I'm going to run a test OS that I can easily reset to stock to play with this. But I had issues getting the drivers even to isntall with the inf files. It looks like the structures are different?

Link to post
Share on other sites

Any Luck getting it to work? I didn't have any. I think I'm going to run a test OS that I can easily reset to stock to play with this. But I had issues getting the drivers even to isntall with the inf files. It looks like the structures are different?

Hi there...

Yes, I get lucky. I've installed the 285.62 without uninstall the 280 first, and the 285 runs ok, and even make the SLI works as I want.

I hope you could get the same results.

Regards!

Link to post
Share on other sites

Hi there...

Yes, I get lucky. I've installed the 285.62 without uninstall the 280 first, and the 285 runs ok, and even make the SLI works as I want.

I hope you could get the same results.

Regards!

Awesome! Thanks for the info.

I have a few questions though:

A. How did you go about modifying the INF file if at all?

B. Also could you try these newer verde drivers as well: http://www.nvidia.co...hql-driver.html ?

C. Does switching work too? Like will intel drivers actually activate? Or does it stay stuck in nvidia discrete mode?

Edited by Namesdontmatter
Link to post
Share on other sites

hi, i have a Dell Vostro3500 with a gpu geforce 310M ( PCI\VEN_10DE&DEV_0A75&SUBSYS_044E1028&REV_A2 ). this laptop setup has a gpu switchable suit (hybrid) where it changes between the dedicated to the discrete gpus. there is no option to turn it this off via the BIOS (i tried everything, even downgrading the BIOS version), the only way is to install a dell version of the nvidia driver (189.something) where it install the driver and the hybrid switch. i was able to update the drivers with the infs mods until the 285.62 version, cause it didn't remove the hybrid switch. but after that version, all newer ones (like 301.42) remove the hybrid switch, so when the computer restarts only the intel dedicated gpu works, while the nvidia geforce isn't accessible (it says 'no driver is connected to VGA card'. i have been trying to work around this for days now, tried changing every inf in the driver update, but no success, plz help me out or give me some tips. tnk u

Link to post
Share on other sites

There is no driver after 285.62 that will work with hybrid no matter what you do. I don't know if it works because I never had hybrid but... try disabling intel gpu from device manager and reboot to use nvidia card. If that works and you want to change gpu you will need to reboot everytime if you want newer drivers. Has anyone with hybrid tried that?

Link to post
Share on other sites

sry for the spamming Beyond, ill stop it now. I tried what u just suggested, but no luck. when i reboot no video card is found, and it end up with a 800x600 resolution.

i wonder if there is a software that does the same thing as the hybrid graphics does, since its all software and nothing to do with bios as i stated above.

Link to post
Share on other sites

I believe you will have to stick with 285.62 then :\

I'm sorry that no one with more hybrid experience can answer you because I don't really know if there is any workaround to get nvidia card running instead of intel using drivers without hybrid support.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...



×
×
  • Create New...