Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
Nautis1100

Toshiba Qosmio - Triple Hybrid SLI

Recommended Posts

Andrew08

Hello! I am new to this forum but I have a qosmio x300-14x with dual 9800m sli and a single 9400m. I dont have any problems with overheating. I have some problem with the modified driver. Although my windows experience raised graphics from 6,7 to 7,1 with this driver need for speed shift is operating strangely with black screen and crashing problems as well as artifacts. My gpu's stay at 80c max ( I am using the nzxt lx cryo cooler). So can you fix this problem? Thanks in advance. Is there a way to know if the drivers are working correctly as they should? Thanks in advance.

Toshiba driver need some mods...

i am not sure where is the main key yet but this happened to my Qosmio G30

Share this post


Link to post
Share on other sites
Guest judgment

Toshiba driver need some mods...

i am not sure where is the main key yet but this happened to my Qosmio G30

I am using the 190.73 from nvidia and is currently working perfectly. It installed without any modifications in the inf file. And up to now I didn't have any problems except of the starcraft 2 game which also have problem with 186.42 which is the latest driver from toshiba.. Furthermore with this driver my temps stay below 75c which is better than 80c that I had before. The only downside is that it doesn't support opencl. I would really like to find a good display driver for this qosmio x300-14x but toshiba stoped supporting it and they call it a gaming laptop. It was a bad decision buying it in the first place but now I am stuck with it so I try to get the best out of it. Next time I won't go sli on a laptop.

Share this post


Link to post
Share on other sites
Nautis1100

I am using the 190.73 from nvidia and is currently working perfectly. It installed without any modifications in the inf file. And up to now I didn't have any problems except of the starcraft 2 game which also have problem with 186.42 which is the latest driver from toshiba.. Furthermore with this driver my temps stay below 75c which is better than 80c that I had before. The only downside is that it doesn't support opencl. I would really like to find a good display driver for this qosmio x300-14x but toshiba stoped supporting it and they call it a gaming laptop. It was a bad decision buying it in the first place but now I am stuck with it so I try to get the best out of it. Next time I won't go sli on a laptop.

I will take a look at 190.73 and see if I can figure out some of the additional settings they use. I don't have a Qosmio so there is a lot of trial and error. I have a hunch about some missing settings that might help.

Share this post


Link to post
Share on other sites
Guest judgment

I will take a look at 190.73 and see if I can figure out some of the additional settings they use. I don't have a Qosmio so there is a lot of trial and error. I have a hunch about some missing settings that might help.

hm ok! Thanks for helping us with the drivers.. Let me know if you need any more info.

Share this post


Link to post
Share on other sites
Guest judgment

Hello again. I have a problem with starcraft 2. While playing I get black lines in the game. I believe it is due to SLI (9800m GTS SLI) since when I run the game with the 9400m g runs with no problems (only thing is that it is too poor in fps). Do you know any way to fix this? There is no way to disable the SLI in this system since the cards are 2 in 1. It is not 2 cards connected with an SLI cable. It's 1 card which includes 2 9800m GTS in sli. If you know any tip I'd be very pleased...

Share this post


Link to post
Share on other sites
Guest judgment

I have found a fix for starcraft 2 but it makes no sense. I noticed that when the laptop was running on battery even when I had the high performance setting (which enables the 2 sli cards 9800m GTS) sc2 didn't have any problems. When I plugged it back to ac adaptor I had the same black lines. So I went into power management to see what difference is there. So I changed the pci express link state power management to maximum power savings. This made my sc2 game work fine. If you know y and what that does please let me know!!

Share this post


Link to post
Share on other sites
Guest judgment

I am testing it now with pci express link state power management to off and I get a lot more fps and no black lines. Can anyone explain to me what is this pci express link state power management? Thanks! I was using windows xp and recently went to win 7 since qosmio x300 doesnt support xp so I dont have a clue..

Share this post


Link to post
Share on other sites
Nautis1100

Interesting find Judgement.

PCI Express (PCIe) devices must support Active State Power Management (ASPM). ASPM lets the system incrementally reduce power to serial links in a PCIe fabric as the link becomes less active.

Windows 7 enables or disables ASPM for a link based on the overall system power policy, the hardware capabilities of the link, and the latency of the link. Windows 7 configures the PCIe fabric to enable the maximum power savings.

Because most devices that comply only with PCI Express Base Specification 1.0 did not implement ASPM correctly, Microsoft selected PCI Express Base Specification 1.1 as the required level of support to enable ASPM. Therefore, some devices must opt out of ASPM because of compatibility problems.

The drivers have Active State Power Management Opt In by default as defined by the following settings in the INF:

[section00#.HW]

Include = machine.inf

Needs = PciASPMOptIn

If we remove those sections in the INF we get the INF attached. (Uninstall, driversweeper if you wish, install using this INF.)

NVCO.INF

Note for me: There is also a RMDisableGpuASPMFlags that we may want to try.

You may also want to try PowerMizer Manager - http://somemorebytes.com/wp/index.php/software/nvpmmanager/ and adjust out the PowerMizer settings to see if any of it helps.

Share this post


Link to post
Share on other sites
DemonikPanther

I am testing it now with pci express link state power management to off and I get a lot more fps and no black lines. Can anyone explain to me what is this pci express link state power management? Thanks! I was using windows xp and recently went to win 7 since qosmio x300 doesnt support xp so I dont have a clue..

Judgement My laptop does the same thing x305-q706. except mine will eventually lock up and i have to reboot it, but when it is on battery power it runs just fine. I tried the fix that you listed but it still does the same thing. where exactly did you go to set this setting. I went into power options and did it for the performance setting and the plugged in setting. You have any other things you have tried for your laptop.

Share this post


Link to post
Share on other sites
Guest judgment

Judgement My laptop does the same thing x305-q706. except mine will eventually lock up and i have to reboot it, but when it is on battery power it runs just fine. I tried the fix that you listed but it still does the same thing. where exactly did you go to set this setting. I went into power options and did it for the performance setting and the plugged in setting. You have any other things you have tried for your laptop.

Hello. The only problem I had was with Starcraft 2 (black lines) and Batman arkham asylum (freezes but when I press ctrl alt delete it went to task manager). I am not using the toshiba driver any more (186.42). I am using the 190.73 (which supports our laptop without any modification in the inf file). The overheat protection is provided through bios so it doesnt matter which driver u use. After installing this driver all of my games got additional frames and I had no crashes at all. But the starcraft 2 game remained with its black line bugs. In the beginning I thought it was due to SLI since sc2 doesn't utilize it but finally when our electricity went down and I ran the game on battery (even though I was using the dual 9800m GTS SLI config) there was no black lines. After that I went to power plan options then selected balanced. From there I selected the option change plan settings. After that change advanced power settings.under the pci express option\link state power management I seelected for the plugged in to Off. That did the trick! I now play sc2 with no problems! (The way I found this trick was by seing the on battery setting which was maximum power setting. After that I tested all three options and the off did the trick). I hope this post helps you and the others. The only problem with driver 190.73 is that there is no opencl.It enables direct compute 4 and cuda though which the toshiba drivers (186.42) don't support. So have fun and enjoy sc2 on your qosmio!! :)

Share this post


Link to post
Share on other sites
Guest judgment

I forgot to mention that I am using nzxt cryo cooler lx so I don't have any over heating issues. Idle temps without the fan 39-41. Idle temps with fan 38-40 (not a big deal). Under full load no cooler it goes 85-100. With cooler it stays up to 75.( A big deal!!). This temps were recorded with the nvidia drivers 190.73 . When I was using toshiba's drivers (186.42) I had the same idle temps but under load no fan I had 90-105 and with fan 75-85. Buying the nzxt cryo coolr lx since I couldn't find it in UK (were I am studying) nor in my Country I paid about 80euros. At first I was considering buying it but the results talk for themselves! nzxt cryo cooler is an essential tool for qosmio x300!!

Share this post


Link to post
Share on other sites
Guest judgment

Hello. The only problem I had was with Starcraft 2 (black lines) and Batman arkham asylum (freezes but when I press ctrl alt delete it went to task manager). I am not using the toshiba driver any more (186.42). I am using the 190.73 (which supports our laptop without any modification in the inf file). The overheat protection is provided through bios so it doesnt matter which driver u use. After installing this driver all of my games got additional frames and I had no crashes at all. But the starcraft 2 game remained with its black line bugs. In the beginning I thought it was due to SLI since sc2 doesn't utilize it but finally when our electricity went down and I ran the game on battery (even though I was using the dual 9800m GTS SLI config) there was no black lines. After that I went to power plan options then selected balanced. From there I selected the option change plan settings. After that change advanced power settings.under the pci express option\link state power management I seelected for the plugged in to Off. That did the trick! I now play sc2 with no problems! (The way I found this trick was by seing the on battery setting which was maximum power setting. After that I tested all three options and the off did the trick). I hope this post helps you and the others. The only problem with driver 190.73 is that there is no opencl.It enables direct compute 4 and cuda though which the toshiba drivers (186.42) don't support. So have fun and enjoy sc2 on your qosmio!! :)

Hello again. After testing sc2 for several hours I still got some black lines when the setting is in off mode. If you want no bugs in sc2 you have to set the pci link state power management to maximum power saving. This is strange since it provides less power the the pci express so less performance but from my view it migh limit the sli config to one 9800m gts so the game runs fine. For the other games the best option is off as you get more fps. In sc2 you lose 3-4 fps but you get to play it with no bugs at all! Enjoy.

Share this post


Link to post
Share on other sites
Guest judgment

Hello. The full fix for starcraft 2 for the qosmio x300 with the dual nvidia sli 9800m GTS is the following:

Go to the power options and change:

1)Pci express\link state power management\plugged in:maximum power savings

2)wireless adapter settings\power saving mode\plugged in:medium power saving

3)multimedia settings\when playing video\plugged in: Balanced

I have been testing the game for over 2hours and it seems to work fine. What I have done is I changed the high performance settings to this so that when I want to play sc2 I select high performance option and don't need to manually change the balanced mode settings.

The problem with the game I think is that it makes the laptop need more power than the power supply can supply to it. Or so it seems since when you lower the power saving settings it works fine. If someone more educated than me can explain why this settings work with sc2 without losing any fps please be my guest! I have been wondering all day why by reducing power consumption sc 2 seems to be working fine in our qosmio x300. Anws I hope I have helped you! Please let me know of your results. Btw sc2 is a cpu stressing game so if you are not using the core 2 extreme (x9100) you should lower ur settings a little.

Share this post


Link to post
Share on other sites
Guest judgment

Hello. The full fix for starcraft 2 for the qosmio x300 with the dual nvidia sli 9800m GTS is the following:

Go to the power options and change:

1)Pci express\link state power management\plugged in:maximum power savings

2)wireless adapter settings\power saving mode\plugged in:medium power saving

3)multimedia settings\when playing video\plugged in: Balanced

I have been testing the game for over 2hours and it seems to work fine. What I have done is I changed the high performance settings to this so that when I want to play sc2 I select high performance option and don't need to manually change the balanced mode settings.

The problem with the game I think is that it makes the laptop need more power than the power supply can supply to it. Or so it seems since when you lower the power saving settings it works fine. If someone more educated than me can explain why this settings work with sc2 without losing any fps please be my guest! I have been wondering all day why by reducing power consumption sc 2 seems to be working fine in our qosmio x300. Anws I hope I have helped you! Please let me know of your results. Btw sc2 is a cpu stressing game so if you are not using the core 2 extreme (x9100) you should lower ur settings a little.

I forgot to mention that you have to exit the chicony web cam software

Share this post


Link to post
Share on other sites
DemonikPanther

Hello. The full fix for starcraft 2 for the qosmio x300 with the dual nvidia sli 9800m GTS is the following:

Go to the power options and change:

1)Pci express\link state power management\plugged in:maximum power savings

2)wireless adapter settings\power saving mode\plugged in:medium power saving

3)multimedia settings\when playing video\plugged in: Balanced

I have been testing the game for over 2hours and it seems to work fine. What I have done is I changed the high performance settings to this so that when I want to play sc2 I select high performance option and don't need to manually change the balanced mode settings.

The problem with the game I think is that it makes the laptop need more power than the power supply can supply to it. Or so it seems since when you lower the power saving settings it works fine. If someone more educated than me can explain why this settings work with sc2 without losing any fps please be my guest! I have been wondering all day why by reducing power consumption sc 2 seems to be working fine in our qosmio x300. Anws I hope I have helped you! Please let me know of your results. Btw sc2 is a cpu stressing game so if you are not using the core 2 extreme (x9100) you should lower ur settings a little.

Judgement This still did not work. I am using the newest drivers on here that nautis put out though. Do you have any other issues with other games. that may require the newer drivers? I have been reading that windows 7 doesn't like the hybrid setup. I don't know if you have win7 installed or not. I am thinking of trying vista to see if that fixes the problems. I just want to know what about the hybrid does windows 7 not like. Microsoft said they were not going to support hybrid power in win 7. Any thoughts?

Share this post


Link to post
Share on other sites
Nautis1100

Judgement This still did not work. I am using the newest drivers on here that nautis put out though. Do you have any other issues with other games. that may require the newer drivers? I have been reading that windows 7 doesn't like the hybrid setup. I don't know if you have win7 installed or not. I am thinking of trying vista to see if that fixes the problems. I just want to know what about the hybrid does windows 7 not like. Microsoft said they were not going to support hybrid power in win 7. Any thoughts?

Something to remember is that statement was released before Windows 7 and there has continued to be a lot of Hybrid/Multiple GPU systems released after it. Microsoft doesn't like hybrid systems because they are not as elegant of a solution as a single GPU. When it comes down to it a single GPU system is easy for consumers and that is what Microsoft wants. Multiple GPU are complex and can be confusing for the consumer. John Q public who thinks IE is the internet will have no clue about a multiple GPU system, switching, or the overhead that comes with it.

Share this post


Link to post
Share on other sites
Guest judgment

Something to remember is that statement was released before Windows 7 and there has continued to be a lot of Hybrid/Multiple GPU systems released after it. Microsoft doesn't like hybrid systems because they are not as elegant of a solution as a single GPU. When it comes down to it a single GPU system is easy for consumers and that is what Microsoft wants. Multiple GPU are complex and can be confusing for the consumer. John Q public who thinks IE is the internet will have no clue about a multiple GPU system, switching, or the overhead that comes with it.

Hello again. I am using windows 7 home premium 64bit edition. I couldn't work with vista on this laptop. They were very laggy. I have tried to use nautius drivers but I had a lot of crashes in games such as need for speed shift, sc2 and batman arkham asylum. Those were the only games I tried and they all crashed after 20-60min of use. The laptop was not overheating as my max temp was 80 for gpu and 70 for cpu. So nautius drivers are still buggy all though they have opencl support so I prefer nvidia's drivers which are working fine up to now! I had issues with toshiba's drivers as well in sc2 and batman arkham asylum. I never tried the fix with toshiba's drivers for sc2 but the nvidia drivers I am using now have never crashed my system and gave me a 7,1 score in windows experience. Toshiba's drivers only gave me 6,6 or 6,7 depending. Nautius drivers gave me the same score of 7,1 but I had crashes in all 3 games I tried and they were not because of overheating. I don't know what nautius modified drivers have but they keep my gpu cool at 75c but not stable under gaming. With nvidia drivers (190.73) which I use I had never any problems. The only problem I had was with sc2 which now works perfectly! Try using those drivers and let me know. If you can't find the link to download the driver I can give it to you through e-mail. When you try the drivers let me know if ur problem persist! Let's hope nautius can fix the new drivers so we can get the opencl support.

Share this post


Link to post
Share on other sites
DemonikPanther

Hello again. I am using windows 7 home premium 64bit edition. I couldn't work with vista on this laptop. They were very laggy. I have tried to use nautius drivers but I had a lot of crashes in games such as need for speed shift, sc2 and batman arkham asylum. Those were the only games I tried and they all crashed after 20-60min of use. The laptop was not overheating as my max temp was 80 for gpu and 70 for cpu. So nautius drivers are still buggy all though they have opencl support so I prefer nvidia's drivers which are working fine up to now! I had issues with toshiba's drivers as well in sc2 and batman arkham asylum. I never tried the fix with toshiba's drivers for sc2 but the nvidia drivers I am using now have never crashed my system and gave me a 7,1 score in windows experience. Toshiba's drivers only gave me 6,6 or 6,7 depending. Nautius drivers gave me the same score of 7,1 but I had crashes in all 3 games I tried and they were not because of overheating. I don't know what nautius modified drivers have but they keep my gpu cool at 75c but not stable under gaming. With nvidia drivers (190.73) which I use I had never any problems. The only problem I had was with sc2 which now works perfectly! Try using those drivers and let me know. If you can't find the link to download the driver I can give it to you through e-mail. When you try the drivers let me know if ur problem persist! Let's hope nautius can fix the new drivers so we can get the opencl support.

yeah that link would be great. I do not have the link to the drivers from nvidia. The only ones I can find are the ones on here.

Share this post


Link to post
Share on other sites
Guest judgment

yeah that link would be great. I do not have the link to the drivers from nvidia. The only ones I can find are the ones on here.

I don't know if I can post the link so can u give me ur e-mail so I can e-mail it 2 u?

Share this post


Link to post
Share on other sites
Guest judgment

(windows7/vista 64bit)

(windows7/vista 32bit)

It's the link for the 190.73 drivers.

Try the drivers and let me know if they work as good as they do for me. Only downside is that they don't support opencl. Btw you don't need to download any modified inf file since they install as they are.

Share this post


Link to post
Share on other sites
Guest judgment

Hello. I have found another fix for the sc2 game. I connected my qosmio x300 to my 32 inch lcd full hd 1080p monitor through hdmi in my living room and tested sc2. The game played smooth on ultra settings with no bugs. I have no clue why the black lines don't appear when playing on my external monitor but I am glad to be able to play it with no slow downs. I only set the texture quality to high since our graphics card dedicated memory is 512mb. (SlI doesn't mean that you have doubled the memory 2x512mb is not equal to a 1024mb card. The memory bandwidth remains 512mb)

Share this post


Link to post
Share on other sites
Guest judgment

Hello. I have found another fix for the sc2 game. I connected my qosmio x300 to my 32 inch lcd full hd 1080p monitor through hdmi in my living room and tested sc2. The game played smooth on ultra settings with no bugs. I have no clue why the black lines don't appear when playing on my external monitor but I am glad to be able to play it with no slow downs. I only set the texture quality to high since our graphics card dedicated memory is 512mb. (SlI doesn't mean that you have doubled the memory 2x512mb is not equal to a 1024mb card. The memory bandwidth remains 512mb)

After lots of testing with all the settings in starcraft 2 even messing with the variables (since I thought it was an sli problem) I finally found a way to play sc2 with no bugs on our beloved qosmio x300 with the dual 9800m GTS. I have all the settings set to ultra except of the texture quality which I have in high resolution since our dedicated memory is 512mb. After gaming I had black lines in the game. When in battery mode I realized that the black lines had disappeared. So I tried changing my settings for plugged in as my battery settings when using the sli config. It worked for most of the time but the black lines came back finally. Today I connected my qosmio to my large lcd screen which is full hd 1080p. Our display is only 1050p so when I opened sc2 the game started in 1080 instead of the 1050. I played for 2 hours and I had no black lines. So I thought it was a sound driver related problem.I chose to get sound from the speakers to see if the black lines come back. To my surprise there were no black lines. So I just posted that u can play starcraft 2 fine through hdmi. Now that I went online again and I played with our 1050 screen I realised that without messing up with the power settings (that I mentioned before) I still didn't have any bugs, slow downs, or black lines. So I went into the settings and found out the secret! My settings for display mode went automotically to windowed (Fullscreen) since my external lcd screen had a different resolution. I switched it back to fullscreen with resolution 1680x1050 and the black lines and slow downs came back. So if you want to play sc2 set ur desktop resolution to 1680x1050 and then play the game in windowed mode(fullscreen). I haven't tried the texture quality any higher than high but I would not recommend it as our vram is less than 1gb. Keep in mind that I am using the x9100 processor which is 3,06ghz on stock. (sc2 utilizes only 2 cores so the more ghz u have on the 2 cores the better). Finally we can play sc2!! :) yay!!! I am waiting for ur results!! Btw I am using drivers 190.73 which I have given links to them on my last post.

Share this post


Link to post
Share on other sites
Nautis1100

Nice job Judgement. I am sure this info will be very helpful to Qosmio users.

Share this post


Link to post
Share on other sites
Guest DemonikPanther

Judge I could not get those drivers to install on my laptop for some reason. I did use the the newest drivers from toshiba for win 7 x64 and they work fine running sc2 in windowed mode. I am downloading the new drivers from nvidia now the 260 to see if they will install on our laptop and I will get back to you. Hopefully nautis can get us a modified INF if they don't. Nautis if you need anything on doing the modified INF file let me know. I would love to learn how to do it so I can modify them myself. To maybe start doing them since I own one of this big paper weights.

Share this post


Link to post
Share on other sites
Nautis1100

Well it is always most useful if an actual owner of a notebook mods as you can figure out bugs and fixes much easier than I could. The modding I initially did for the Qosmio was a pretty straight forward general mod. When I have a bit more time I will try to break it down here in detail for you. I am sure there are probably more/better settings that may fix some of the issues you guys are running into. If I don't start posting about it in the next couple of days feel free to start nagging me about it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...