Jump to content
LaptopVideo2Go Forums

Michael's NEW IDT/Sigmatel Modded Driver


Michael Marley

Recommended Posts

  • Replies 513
  • Created
  • Last Reply

Top Posters In This Topic

  • Michael Marley

    156

  • samozen

    28

  • erp-ster7n

    33

  • coolguy16

    26

Top Posters In This Topic

Posted Images

Michael, the new package installs and works as expected, thanks.

Download also works without any corruption problems.

On a side note, thanks for the changelog, very useful

Link to comment
Share on other sites

Michael, any news on my code 10/ subsys-id / cmajor

You said you had an HP dv9x? Your SUBSYS isn't supported right now.

I did some more research on your SUBSYS ID, and it would seem that the audio chip in your PC is actually an AC97, not HD Audio. All of the dv9xxx systems listed on HP's website use either Conexant or Realtek audio.

Link to comment
Share on other sites

Guest ~BlackStone

Michael, no I said I also HAD (past tense) a dv9x :)

The one I said I had was a Dell D810, and its possible its AC97 because its so old, which sucks...

And on tat note, since this I guess is an HD only driver, you know where I can find one for Win7? the Vista one I was able to find doesnt work properly... :)

Thanks again!

Link to comment
Share on other sites

Michael, no I said I also HAD (past tense) a dv9x :)

The one I said I had was a Dell D810, and its possible its AC97 because its so old, which sucks...

And on tat note, since this I guess is an HD only driver, you know where I can find one for Win7? the Vista one I was able to find doesnt work properly... :)

Thanks again!

Latitude D810, right? According to Dell Support, that laptop has an AC97 codec and therefore can't be supported by this driver. Sorry :P

Link to comment
Share on other sites

Latitude D810, right? According to Dell Support, that laptop has an AC97 codec and therefore can't be supported by this driver. Sorry :)

Probably better off with the Microsoft driver that is built into Windows 7. It's probably newer than anything Sigmatel/IDT has released.

I see that Dell doesn't even provide Vista drivers for the D810...

Link to comment
Share on other sites

Probably better off with the Microsoft driver that is built into Windows 7. It's probably newer than anything Sigmatel/IDT has released.

I see that Dell doesn't even provide Vista drivers for the D810...

As far as I know, there isn't a Microsoft driver for AC97 chips.

Link to comment
Share on other sites

As far as I know, there isn't a Microsoft driver for AC97 chips.

Bummer.

Some people on the Dell forum are having luck getting XP drivers to work in Win7, so that might be worth a try as a last resort.

Edit - here's a Vista one that might work: http://en.community....lled%207%20AC97

Edited by HunterZ0
Link to comment
Share on other sites

If you give me the SUBSYS ID of your audio chip, I can troubleshoot your problem.

My driver is significantly better than the Microsoft default HDA driver. Its advantages over the stock IDT driver are that it is lighter weight and supports many cards from many manufacturers in one driver.

is this what you need?

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_1028043A&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_1028043A

Link to comment
Share on other sites

is this what you need?

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_1028043A&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_1028043A

Yep. Could you try this INI?

dell_W92HDM68.INI.txt

Link to comment
Share on other sites

Guest Joel Mansford

I am getting a Code 10 on a Dell Precision M2300 (practically a Latitude D630)

FUNC_01&VEN_8384&DEV_76A0&SUBSYS_1028024A

I can see the entry in Dell_WRT_M4-3.INI - what do you change to stop the Code 10?

Link to comment
Share on other sites

Dear Macheal

I tried to install your driver but it doesn't work. Please help. It's for my Alienware M15x

HDAUDIO\FUNC_01&VEN_111D&DEV_7604&SUBSYS_102802A2&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_7604&SUBSYS_102802A2

Thank you

Link to comment
Share on other sites

I am getting a Code 10 on a Dell Precision M2300 (practically a Latitude D630)

FUNC_01&VEN_8384&DEV_76A0&SUBSYS_1028024A

I can see the entry in Dell_WRT_M4-3.INI - what do you change to stop the Code 10?

Can you try this INI?

Dear Macheal

I tried to install your driver but it doesn't work. Please help. It's for my Alienware M15x

HDAUDIO\FUNC_01&VEN_111D&DEV_7604&SUBSYS_102802A2&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_7604&SUBSYS_102802A2

Thank you

Can you try this INI? (dell_W92HDM82.INI.txt)

dell_WRT_M4-3.INI.txt

dell_W92HDM82.INI.txt

Link to comment
Share on other sites

So last time I was here, i tried that driver package from Mrx in

And got sound if headphones were plugged in on the headphones, but wasnt able to get any sound from the internal laptop speakers. Any ideas?

Link to comment
Share on other sites

Guest Joel Mansford

Can you try this INI?

Can you try this INI? (dell_W92HDM82.INI.txt)

I still got the same Code 10 - incidentally I had already made the same change to the INI having DIFF'd ones you'd done for other people. Would it help if you had a stock INI?

Link to comment
Share on other sites

Guest Trebormint

To the wonderful human being that is Michael Marley, I just want to say how grateful I am that you provided this driver. I have a 9400/e1705 with a sub woofer that's not been operational for years and after trying driver after driver having no luck but this beauty worked straight out of the box, exactly what I desired thanks!!

windows 7 64bit

sig 92xx chip

Link to comment
Share on other sites

Michael, do you have any idea about the "CD Audio" device in recording devices? I have it in my Vaio FZ. It has a level meter, but doesn't seem to respond to audio CD music, when set as the default recording device.

There is no jack information available from the device properties.

The original OEM Sigmatel driver didn't show this device. Only the latest IDT drivers expose this "CD Audio" device.

Link to comment
Share on other sites

I tried the package listed in the 1st post and I have no audio.

Dell Studio 17 1737 running Windows 7 Ult x64

I have 2x Headphone Jacks, 1x Microphone & HDMI, the headphone jacks don't work and I have no way to test the HDMI.

Device manager lists two audio devices:

High Definition Audio Device

and

IDT High Definition Audio CODEC

When I try to install the driver pack listed here on the High Definition Audio Device I get a Code 10. The other installed fine but I get no audio.

Hardware ID's are:

High Definition Audio Device

HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101&REV_1000

HDAUDIO\FUNC_01&VEN_8086&DEV_2802&SUBSYS_80860101

IDT High Definition Audio CODEC

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_102802A0&REV_1001

HDAUDIO\FUNC_01&VEN_111D&DEV_7675&SUBSYS_102802A0

Edited by DevilTenchi
Link to comment
Share on other sites

Guest Patrick

Hello, I have a Clevo X7200 and I'm getting a Code 10.

Info:

HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_15587200&REV_1002

HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_15587200

I wanted to try this on my system since our audio driver is really not that good [Realtek].

Link to comment
Share on other sites

  • 2 weeks later...

I am receiving the same "Code 10" error as Guest_HNKNTa_* in the forum and Guest_Patrick_* in this one. My SUBSYS ID is below. Do you have any ideas? Can I provide you with any more information? Thanks.

Bob

HDAUDIO\FUNC_01&VEN_8384&DEV_7618&SUBSYS_10280215&REV_1002

HDAUDIO\FUNC_01&VEN_8384&DEV_7618&SUBSYS_10280215

Link to comment
Share on other sites

Guest cdrdealer

Hi Michael,

I'm receiving "Code 10" error as Bob above when using IDT 6324 driver you modded.

My system is an Inspiron 1440 with IDT 92HD81 chip.

My SUBSYS_ID are :

HDAUDIO\FUNC_01&VEN_331D&DEV_7605&SUBSYS_22000000&REV_1004

HDAUDIO\FUNC_01&VEN_331D&DEV_7605&SUBSYS_22000000

Appreciate your help in solving the error above

Link to comment
Share on other sites

I'm really sorry, but I think I am going to have to put this project on hold for awhile. School has me really busy, and I switched back to Linux again. I should be able to push out new driver versions when IDT releases them, but don't necessarily expect fixes for cards not working.

Link to comment
Share on other sites

Hi Michael,

First of all, thanks for your continuous effort on this project, much appreciated.

Obviously, life comes first, but in case you manage to find some free time, version 6325 is available here -

All the best, Adam.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...