Jump to content
LaptopVideo2Go Forums

Help! refresh rate supported by Geforce4 420 go?


Guest winter

Recommended Posts

Hi,

I am using Toshiba TE2100, video chip geforce4 420 go 16M, VBIOS 4.17.00.41.C7.

My OS is Win2K, the best driver I can use is 45.23 with Teraphy's inf. (perfect, no black bar, thanks!).

I set dualview in standard mode and output the screen to my CRT only. I found in this driver/inf, the highest refresh rate in 1024*768 is 85Hz.

I need 1024*768 to be refreshed at 100Hz or above (to play 3d stereo feature), so I check the inf, I found the limitation of the refresh rate is set in here:

HKR,, NV_Modes, %REG_MULTI_SZ%, "{*}S 640x400=1F;320x200 320x240 400x300 480x360 512x384=F;SHV 640x480 720x480 768x576 800x600 1024x768 1152x864 1280x854 1280x960 1280x1024 1400x1050 1600x1200=1F;800x600=801E;"

Then I modified the SHV mode refresh rate limitation from "=1F" to "=FF" (based on Nvidia's definition, "FF" can up to 140Hz), removed the driver then installed again with above modified inf. But still I got only 85Hz.... >_<

(I use "regedit" tool and confirmed the setting is "=FF" in my TE2100)

Is there other setting in the inf which override the setting of refresh rate?

Please help... I do want to try 3d stereo to play RPG game..... Thank you.

Link to comment
Share on other sites

Winter,

Even though it summer here I can still help you :)

Remove:

HKR,, NV_Modes, %REG_MULTI_SZ%, "{*}S 640x400=1F;320x200 320x240 400x300 480x360 512x384=F;SHV 640x480 720x480 768x576 800x600 1024x768 1152x864 1280x854 1280x960 1280x1024 1400x1050 1600x1200=1F;800x600=801E;"
and anything below with Addreg bla bla bla and more settings.

Then replace with this:

HKR,, NV_Modes, %REG_MULTI_SZ%,  "{*}S 320x200 320x240 400x300 480x360 512x384 640x400=1FFF;SHV 640x480 720x480 768x576 800x600 1024x768 1152x864 1280x720 1280x768 1280x800 1280x854 1280x960 1280x1024 1360x768 1400x1050 1440x900 1600x900 1600x1000 1600x1024 1600x1200 1680x1050 1920x1200 1920x1440 2048x1536x8,16,32=1FFF"

Now you have all the known laptop resolutions and refresh rates up to 240hz and everything in between.

The above is what I have in my INFs as of version 20.03+

Enjoy your new refresh rates.

Pieter

Link to comment
Share on other sites

Thank you Pieter,

I will try "1FFF", just one thing confused me.... Why I use "1FF" did not work? Why it must be "1FFF"? @_@ I do think there is some other setting in the inf override the refresh rate....

I will post later if "1FFF" works.

And thank you Boris, I know LCM only support 60Hz. Above modification is for my CRT. ^_^

Link to comment
Share on other sites

Winter,

The one thing I forgot, try reinstalling driver with the change.

This will ensure that the registry gets updated properly.

Remove old version first, so the new table gets placed in properly.

If it still goes to 85hz it could be because it's the default refresh of the monitor (EDID) for any video card.

You need to get into the display properties of the Monitor (not LCD) then go down to change resolotutions, in here you can choose all the refresh rates that the monitor can handle for that monitor (you may even be able to go higher)

Hope this helps,

Pieter.

Link to comment
Share on other sites

In some cases the video modes won't work because the EDID is read from the external monitor. In this case there must be an override. I haven't tried an external with the newer drivers but I'm surprised the "change resolution" page doesn't show up. You can add custom refreshes there.

In any case maybe I haven't tweaked my settings enough. Does anyone still have the "change resolution" page anymore?

Link to comment
Share on other sites

Yes, I still have it on my homemade inf. I think the following line enables it:

HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplResolutionMenu, %REG_DWORD%, 1

Link to comment
Share on other sites

Hi Pieter,

Yes, I always uninstall old driver first, reboot, use "regedit" to check registry, then reinstall other driver.

By using Teraphy's 45.23 inf, I followed your instruction to use your string (but did not remove "anything below with Addreg bla bla bla and more settings" because I am not sure which one to be removed is safe), still I got only 85Hz....

What I said 85Hz is to open display properties control panel > setting > advanced > adaptor > list all support mode, and I can see all video mode supported by the video card, in here it should be no relevant to monitor type. (I think....)

So may be it was override by some other strings/settings in the inf, but not the EDID?

Anyway, I will try all of your and Teraphy's inf, record the supported mode, and post here later. Hope it will be useful for your furture tweaking.

Thank you (and Teraphy).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...