Jump to content
LaptopVideo2Go Forums
stolendiagram

Missing option from my Nvidia control panel

Recommended Posts

stolendiagram

Hey guys,

New to the forum, was advised to post here with my problem, and to be honest, it's my last hope.

In a nutshell, my nvidia control panel is missing the aforementioned option and I'm getting desperate for a way of 'persuading' it to appear. My nvidia card is the 525m which is built into my Dell XPS 15 L502X. I've downloaded the latest nvidia driver (275.33) but have googled the problem and from the very few solutions I've encountered, it appears I need a dell driver instead. Do I uninstall my nvidia driver first then apply the dell driver or can I install the dell driver from where I am now?

Also, which dell driver do I need - I've found this on dell's website http://support.euro.dell.com/support/downloads/download.aspx?c=uk&cs=ukdhs1&l=en&s=dhs&releaseid=R289307&SystemID=XPS_L502X&servicetag=&os=W764&osl=en&deviceid=26948&devlib=0&typecnt=0&vercnt=1&catid=27&impid=-1&formatcnt=0&libid=27&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=430699 is it what I'm after? I haven't the first idea of how to go about doing any of this unfortunately, so would greatly appreciate as little jargon as possible and points concise as you can make them.

Thanks for any help :)

Share this post


Link to post
Share on other sites
feigned-existence

to be honest you never mentioned the missing option and another thing the official drivers by your laptop manufacturer are the best route to go as long as they are up to date, this one you have linked is not the driver you need to update your graphics with try this one Dell Video Driver.

It is also good to uninstall the current one you have running first before installing this one as this will wipe most settings that may be affecting the option from showing.

Hope this helps ^_^.

Share this post


Link to post
Share on other sites
stolendiagram

to be honest you never mentioned the missing option and another thing the official drivers by your laptop manufacturer are the best route to go as long as they are up to date, this one you have linked is not the driver you need to update your graphics with try this one Dell Video Driver.

It is also good to uninstall the current one you have running first before installing this one as this will wipe most settings that may be affecting the option from showing.

Hope this helps ^_^.

Thanks for that, looks just the job.

How embarrassing that I forgot to mention in the title which option was missing (video scaling)

Is this one from dell a different sort of driver to the one I got through nvidia? Apparently the one I got through nvidia is newer.

Share this post


Link to post
Share on other sites
feigned-existence

Is this one from dell a different sort of driver to the one I got through nvidia? Apparently the one I got through nvidia is newer.

laptop manufacturers tweek drivers to suit the laptops, usually the nvidia driver works just fine but as in your case not always.

Share this post


Link to post
Share on other sites
stolendiagram

Right, well I uninstalled all the nvidia related driver stuff and applied the driver from dell before reinstalling the nvidia drivers.

Sadly my problem remains and the video scaling tab is still missing from my control panel :)

Anyone know what else I could try?

Share this post


Link to post
Share on other sites
feigned-existence

Right, well I uninstalled all the nvidia related driver stuff and applied the driver from dell before reinstalling the nvidia drivers.

Sadly my problem remains and the video scaling tab is still missing from my control panel :)

Anyone know what else I could try?

i just had a look inside my control panel have you tried going to Adjust Desktop Size and Position scaling is in there. Or is that what you mean by no tab inside this section.

Edited by feigned-existence

Share this post


Link to post
Share on other sites
stolendiagram

i just had a look inside my control panel have you tried going to Adjust Desktop Size and Position scaling is in there. Or is that what you mean by no tab inside this section.

Yeah, the adjust desktop size and position option doesn't appear anywhere in the nvidia control panel - it makes no sense to me, as far as I can tell nothing else is missing, only that. If I had even the slightest idea why I might be able to do something about it :)

Share this post


Link to post
Share on other sites
feigned-existence

Yeah, the adjust desktop size and position option doesn't appear anywhere in the nvidia control panel - it makes no sense to me, as far as I can tell nothing else is missing, only that. If I had even the slightest idea why I might be able to do something about it :)

sorry but i don't know how to help you any further except maybe downloading this http://www.nvidia.com/object/nvidia_system_tools_6.06.html this might unlock those settings dunno just guessing here.

Share this post


Link to post
Share on other sites
stolendiagram

Thought I would ask again, now that the website no longer seems to take an age to load, see if anyone knows of anything else I could try.

Share this post


Link to post
Share on other sites
zipper

It definitely works in 275.27 for me.

post-985-0-86927900-1308502540_thumb.jpg

Share this post


Link to post
Share on other sites
stolendiagram

It definitely works in 275.27 for me.

Just tried that one, still no option :)

Share this post


Link to post
Share on other sites
Dox

Hi,

your "problem" is not a problem at all but its the nature of your machine.

You have an "Optimus" system which means you have an intel graphics processor and an Nvidia (GT525m in this case).

You do not have the option in the Nvidia control panel since the intel driver / graphics processor is the default processor to handle video scaling.

Hence no option in the Nvidia control panel.

In the nvidia control panel you should only have 3D and video options.

The "display" options for which the scaling is located in the nvidia control panel is not needed since the intel driver handles that part.

So yeah yeah in a nutshell theres no problem.

Share this post


Link to post
Share on other sites
stolendiagram

Hi,

your "problem" is not a problem at all but its the nature of your machine.

You have an "Optimus" system which means you have an intel graphics processor and an Nvidia (GT525m in this case).

You do not have the option in the Nvidia control panel since the intel driver / graphics processor is the default processor to handle video scaling.

Hence no option in the Nvidia control panel.

In the nvidia control panel you should only have 3D and video options.

The "display" options for which the scaling is located in the nvidia control panel is not needed since the intel driver handles that part.

So yeah yeah in a nutshell theres no problem.

Ok, thanks for that - wish I'd known a week ago so I wouldn't have wasted fruitless hours google searching an answer :)

So in that case, can the intel processor be used with older games such as knights of the old republic which refuse to play in a widescreen resolution to stretch out the disgusting black bars on either side of the screen?

That's all I really wanted the video scaling option for. I know there's a widescreen mod for the game and others which refuse point blank to play in a widescreen resolution, but at my native screen resolution of 1366x768 it relies on video scaling :)

Share this post


Link to post
Share on other sites
Dox

yes you can...

A) Go to the nvidia control panel and select profile settings.

See if Knights of the old republic is in the detected games list.

if not you can add that it to the list by browsing to the knights og the old republic .exe

then under prefered graphic processor select intel.

OR

:) right click the .exe or shortcut to the knights of the old republic and select run with processor: intel.

Share this post


Link to post
Share on other sites
ion burst man

it didnot work on my xps 15 cs is running in half screen :cry1:  :please: HELP

Even after trying with intel graphics it did not run in fullscreen

Edited by ion burst man

Share this post


Link to post
Share on other sites
tribaljet

As Dox said, Optimus-enabled systems have limited options on the Nvidia control panel.

 

Scaling in Optimus systems is handled by the IGP itself rather than the GPU. The IGP handles the main output, including any changes to the image that aren't directly related to graphics options from within the software ran, so that makes up for a slightly inconvenient but perfectly doable scenario.

Using the Intel IGP rather than the Nvidia GPU is often not recommended for performance reasons. Months ago I was facing the same issue, namely playing with older titles that happened to have skewed scaling, and the solution I've discovered was to always run software with the GPU and use the IGP shortcuts to change scaling on the fly. Do note that switching scaling will have the desktop resolution lower than native whenever exiting the software, but it's easily fixable by setting the resolution from the OS settings themselves.

Share this post


Link to post
Share on other sites
MarcW

Hi,

your "problem" is not a problem at all but its the nature of your machine.

You have an "Optimus" system which means you have an intel graphics processor and an Nvidia (GT525m in this case).

You do not have the option in the Nvidia control panel since the intel driver / graphics processor is the default processor to handle video scaling.

Hence no option in the Nvidia control panel.

In the nvidia control panel you should only have 3D and video options.

The "display" options for which the scaling is located in the nvidia control panel is not needed since the intel driver handles that part.

So yeah yeah in a nutshell theres no problem.

[endquote, no idea why the quote box looks fine in the preview, but not when I post]

 

I have the same problem.  The "problem" is that without being able to get to the "Display" tab, I can't force output thought the NVIDIA card.  Why would I need to do that?  Because I want to use my HDMI/Displayport/DVI.  It's run through the NVIDIA GT 630 in my machine, but I can't find a way to force output through it.  Called Support, the first guy scheduled me for a video card replacement.  That didn't happen, and the next suggested a factory restore.  That did happen, still no output over anything other than the VGA port I don't want to use (managed by the "primary" Intel graphics).

 

So yeah, in a nutshell, there is a problem.

 

I can boot the computer with an extermal HDMI attached (provided I set the HDMI as primary dispaly in the BIOS), and that works fine.  It's only after entering Windows where I can no longer access the HDMI port.

Edited by MarcW

Share this post


Link to post
Share on other sites
arshikhan9

 There are multiple solutions to fix the Nvidia Control Panel Missing Error. You can follow the given solutions to get rid of this issue.
Method 1: Get help from Nvidia Support: You need to contact support center of Nvidia and told issue then which solution they suggest do to fix this issue.

Method 2: Restart Several Nvidia Services: To fix this issue you need to restart several Nvidia services. Write services.msc > Services tab > Find the Nvidia services > Right-click on the service and click on Properties > Startup type > set it to Automatic > Stop button in order to stop the service and wait for a minute. Click on Start after a few minutes.
You may see more solutions at https://appuals.com/fix-nvidia-control-panel-missing/.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×