Jump to content
LaptopVideo2Go Forums
mobilenvidia

SAS2108 (LSI 9260) based firmware files

Recommended Posts

mobilenvidia

The xxxx_yyy.rom

xxxx = version number

yyy = intended card vendor

my fav rom was 0079_sun.rom

As it could sleep drives

Pick what ever ROM you fancy, higher number = later version

Can't say I ever had any issue with any driver other than some versions switching of various OEM features

Share this post


Link to post
Share on other sites
mobilenvidia
20 hours ago, MartiniGM said:

Link to sas2108.zip file in first post doesn’t work.

Mirror? New link?

Thank you.

Working fine for me, check your settings for downloading

Share this post


Link to post
Share on other sites
frozenpine
On 8/4/2016 at 2:42 PM, mobilenvidia said:

Working fine for me, check your settings for downloading

I am having trouble as well.

http://files.laptopvideo2go.com/hdd/sas2108.zip Redirects to 404 page http://laptopvideo2go.com/404

If there is another download location or if you can email the file it would be greatly appreciated.

Share this post


Link to post
Share on other sites
mobilenvidia

Weird things going on

Press CTRL+F5 in your browser, reloads the page and it should work

Just tried it Chrome, where it worked first time I clicked but not 2nd or later
Reload the page clearing cookies worked

Must be a IPB Forums thing, don't know why or how to fix that

Share this post


Link to post
Share on other sites
pablocool

Hello @mobilenvidia may you check download link from first post? I receive 404 error. I d like to get firmware from SUN controller and test sleeping drives feature. What is model name of this controller?

I read somewhere that you were searching for SBR file of RS2BL080 Intel controller. I dont know if you found. Anyway catch:

https://www.dropbox.com/sh/v3al3zctwjma1nb/AAA0o31oAu1brd7iQWEZ3Xh-a?dl=0

Share this post


Link to post
Share on other sites
mobilenvidia

Read 3 posts up on how to DL, no longer play with Controllers juts too much other stuff happening
My IBM 5016 just plugs away 24/7 with my now ancient 6x 2TB drives in RAID6, can't believe how reliable its been no need to tinker with whats not broken :)

Share this post


Link to post
Share on other sites
pablocool

Tried CTRL+F5 on all browsers with same effect:


Not Found

Error: The requested address '/404' was not found on this server.

May I ask you for sending via mail pablocool86[att]gmal.com ?

What is the name of SUN alternative for LSI 9260-8i ?:)

I am building home SAN/NAS server using 9260-8i controller and HP SAS EXPANDER 12 x 3TB WD RED drives:)

I discovered last working fw on fujitsu/Intel/IBM controllers is LSI 167 fw. Above that I discovered weird behaviour of controllers. For example updating Intel and IBM from 167 to 205 or 239 results they do not see arrays created in 167. What is weird fujitsu is not issuing this fault. When I create array on ibm/intel or fujitsu in 205 or 239 fw it is seen on on all controllers. But if I import it once to fuijtsu it changes metadata of array or something. Then intel and IBM cannot import this array again. Intel and IBM can import array created in fw 205 or 239 one by one. But one import in fujitsu destroys sth.

 

Edited by pablocool

Share this post


Link to post
Share on other sites
mobilenvidia

Links should be all sorted

Share this post


Link to post
Share on other sites
a.dresner

Ki Ora, bet you never thought this thread would have this much life? 

I just got a Dell H700 from eBay to use in a Dell T20.  The Dell T20 is supposed to be compatible, according to other users but my BIOS will not see the card.  I put the H700 into my desktop computer (a home-brew ASUS based) and the BIOS and OS sees it, so it's not dead.  

I am hoping that updating the firmware on the H700 with Dell's latest will do the trick.  I tried to do this today using a DOS stick and MEGA but it didn't work.  Of course, when I run the windows based utility, it does not work..probably because I am not running it on a Dell.

Just to check, I put my 9265-8i into my T20 and the T20 sees it.. I would use it instead, but it's in production on another server.  

I do not have any Dell servers other than a few T20s.

Is there a way to upgrade the firmware on the H700 to the latest Dell H700 firmware if I don't have a Dell Server?  

Really appreciate the guidance on this..never done this before and after 2 days of pulling my hair out, I need to find some help

Best Regards

Share this post


Link to post
Share on other sites
mobilenvidia

Have you tried updating via MSM ?

Can't remember the key combo at boot up to get into the BIOS, LSI is CTRL+H, Dell is different
You can update via here
Should work on the Desktop as it can see the card

H700's aren't normally tied to Dell servers, if you can see it on your desktop you should be able to update it
You haven't mucked about with the SBR and turned it into a LSI ?
quote weird that the Dell doesn't see it but does the 9265

What have you tried in updating , Megarec, or CLI util ?

Share this post


Link to post
Share on other sites
a.dresner

Hi,

I ended up updating via the Dell Application on my Asus Desktop computer, it finally worked or maybe I just had the wrong software package to start with.

Opening MSM, the controller is locked 

Any idea how I can unlock it and use it on a non Dell?  I sorta gave up, and ordered 2 9265-8i, they are so cheap on eBay.  I would like to use the H700, if not .. going to ship it back to the seller.

Share this post


Link to post
Share on other sites
mobilenvidia

If you can, send it back, 9265 won't need any modding as its basically what it needs to be and what you are trying to get the H700 to

Share this post


Link to post
Share on other sites
a.dresner

Thank you, I will be sending it back

Share this post


Link to post
Share on other sites
mobilenvidia

I shoulda done same with my IBM M5016 (LSI 9266) not quite as hard to fiddle with as Dell cards but still OEM versions don't have all the LSI features

Share this post


Link to post
Share on other sites
jozdemir

Hey all,

Just need some quick advice if someone could point me in the right direction...

I've got an IBM M5015 that I want to enable CacheCade Pro 2.0 on, I couldn't for the life of me find the IBM branded Performance Accelerator Key for a decent price.

I grabbed one of these off Ebay: "LSI LSI00292 RAID CacheCade Pro 2.0 Software physical key for 9260/9280 Series"

http://www.ebay.com.au/itm/LSI-LSI00292-RAID-CacheCade-Pro-2-0-Software-physical-key-for-9260-9280-Series-/142180163303?hash=item211a991ee7:g:ikoAAOSwiDFYKx2p

I'm aware it may have been a bit of a long shot but I thought it was worth a try.

Before I muck about for hours, is there a certain version of firmware (LSI etc) to enable me to use that key for CacheCade? I've bought a stack of drives that turn up in the next week or so, so I wanted to try and have everything ready to go when they turn up.

Cheers everyone!

Share this post


Link to post
Share on other sites
mobilenvidia

It probably won't work, the LSI boards have NAND ROM that hold a code to enable features like Cachecade/Fastpath

If you want those features just get the LSI card to go with it, all the time wasted on trying to make it work and fail will be much better spent on looking for a 9260/9280 and then having it work.

IBM 5015 were great a few years back as a cheap 9260 alternative if you didn't mind not having the extra's

Share this post


Link to post
Share on other sites
jozdemir

Thanks mate.

Yeah that's what I was considering, I did have a look around at some 9260s. Basically these were leftover from some servers decomissioned at work, so I have two of them I got for nothing, I was just trying to make them work for my use case.

Appreciate the quick response!

What's the general 'modern' equivalent of these 9260s/M5015s that tend to be everyone's go to? I've been looking at the Dell H730s but nothing seems quite as cost effective.

Share this post


Link to post
Share on other sites
mobilenvidia

If you want LSI functionality get a LSI, all others you'll struggle to get anything like Cachecade keys to work

Keep an eye on 9265/6 these use the newer SOC
I'm running a IBM M5016 on my server it just goes but again no chance of Cachecade or fastpath, but has been working flawlessly for years as have the 2TB drives for that matter

Share this post


Link to post
Share on other sites
AndrewG

I'm trying to cross-flash an H700 card to IT-mode firmware, for use in a Dell R310 server.  I'm having some difficulties, and hopefully someone here can point me in the right direction.

After I realized that megarec hangs on Dell motherboards, I moved the card to a desktop box, and the flash procedure went smoothly.  However, after flashing, two problems have come up:

  1. trying to enter the H700 card's option-ROM during boot via Ctrl-R just hangs the box
  2. Linux (Ubuntu-14.04 64-bit) does not see any of the drives.  It does, however, see the enclosure as a SCSI device, which is an interesting wrinkle.

I've tried sbr9260.bin with 0079_sun.rom and with 0124_lsi.rom, as well as with smc2108.rom from SuperMicro's FTP site.  All of them resulted in the two problems above. I'm using the sas2108.zip bundle — thanks for posting this!

The card's option-ROM does indeed work when the card's in the desktop PC, and when booting in the Dell, the updated firmware version is visible (-0079, -0124).

I've heard tell on the 'net that the "storage slot" on the Dell servers can't be used for a cross-flashed card — is this true?  If so, this is a showstopper for me: the SAS cables in the Dell appear to be unique to the box (so they can't easily be swapped), and they don't reach the second slot (so it can't be used).

Am I missing something obvious?

Share this post


Link to post
Share on other sites
AndrewG

It appears it can do IT mode; I'm following the instructions at this link:

http://www.xtremesystems.org/forums/showthread.php?271922-LSI-2108-based-card-cross-flashing-(Dell-H700-LSI-9260-IBM-M5015-Intel-RS2BL080)

Quoting the original poster: "I have flashed a M5015 into a 9260 and then a H700 this way."

My understanding is that the 9260 is the original LSI product which runs IT firmware.  Or am I mistaken?

Share this post


Link to post
Share on other sites
mobilenvidia

My only advice here is, get an IT card, they are cheap as chips now, why risk ruining a RAID card

Share this post


Link to post
Share on other sites
fadilo

Hello, i would like to flash LSI 9261-i8 to Dell H700.

Unfortunately, I have flashed the SPD not the SBR!!!!

Now the Controller said:

RAID ADAPTER
unrecoverable Error
Please check the SDRAM connection
If problems persist contact Tech Support
Press any key to continue....

Can someone send me the SPD file from a LSI 9261-i8 controller to flashed it again?

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×