Jump to content
LaptopVideo2Go Forums

Acer 5520G with NVidia 9600M GT 512MB, DDR3, please HELP!


skaramanlis

Recommended Posts

Hi everyone and thanks for reading me...

I have bought a brand new nvidia 9600M GT 512MB DDR3 (MXM) to replace an nvidia 9200M GS, in an Acer 5520G.

The new card fits fine in the laptop, but when I am trying to boot, its displaying this message:

ERROR: MXM Structure not found or invalid. Reflash MXM ROM or add MXM structure and associated callbacks to SBIOS!

After 30 seconds the laptop is booting, but in windows 7, the card is runing in safe mode, and none of the drivers are working.

Can anyone help me PLEASE? :(

Link to comment
Share on other sites

Have you upgraded your bios to the latest one for your laptop?

Also can you tell which verdor this card was for? acer model, asus etc.

It might also be the case of buying an "ES" Engineering sample.

You might need to flash it with an acer compatible bios or use a bios editor(NiBitor) to fix these issues same as the FSC thread on this forum.

Checked this thead?

http://forum.noteboo...9600m-gt-4.html

Edited by myron
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...