Jump to content
LaptopVideo2Go Forums

Sony Vaio VGN-FZ485U with GeForce 8400M GT WIN 8 64bit Drivers/inf


vrklmpt

Recommended Posts

Hello and thank you very much in advance for your kind help.....I have been beating my head against the wall trying to get the nvidia drivers installed for my Sony Vaio laptop! I get windows 8 64 bit media center installed with no problems and it runs fantastically on the Vaio, however, this laptop has a blu ray drive and it will not play blu ray discs due to the nvidia graphics card driver for GeForce 8400M GT not being installed. Windows 8 simply installs a generic vanilla Microsoft graphics card driver upon installation. I have searched and read lots of info on this awesome laptopvideo2go site and i cannot seem to get the proper driver and inf files combination downloaded and installed. I have download both files and I have copied the inf file to the nvidia driver extracted folder and tried to install via the setup.exe method as well as the manual update driver and point to the downloaded inf file method. Install attempts keep giving error that it cannot find files it needs and installation halts. If some kind soul out there would show mercy and point me in the right direction as far as what nvidia driver set and the proper inf file for my Sony Vaio laptop, I would be forever grateful! Thanks so much!

Link to comment
Share on other sites

Hi, you need to disable driver signature enforcement on Windows 8 before installing a driver. It fails if you do not.

PC Settings > General > Advanced Setup > Restart Now > Troubleshoot > Advanced Options > Windows Startup Settings > Restart

And press "Disable Driver Signature Enforcement" option on keyboard when pc after reboot.

This video may be help:

Edited by fdeniz
Link to comment
Share on other sites

If you dont wanto to mess around with edited INF's and dont mind a older driver you can use 257.41 or 259.47 that have a nv_whql.inf that supports many neglected graphics cards including yours

Here is a =win7x64"]list of drivers that support your card

Link to comment
Share on other sites

  • 1 month later...

RE: Sony Vaio VGN21S/T - Windows 8 Pro 64 bit installation...(Nvidia Geforce 8400M GT)

Being a new member, I thought I'd pass on my own researches & experiences...(This took quite a while! ;-)...)

 

Installed Nvidia driver 302.80 with modified nvszc.inf file as available in several locations on this site provided by Coolguy16.

Requires disabling driver signature enforcement and a RESTART immediately after installation. NOTE: Contrast/Brightness control in W8 settings menu then work, but keyboard function buttons for this DO NOT as yet. Also, it is worth checking that the driver has actually been installed and working correctly in Device Manager as being the Nvidia Driver: 9.18.13.280.

 

Subsequently installed the following software in the order shown ... with a RESTART every time each item is installed...

(NOTE: it also helps to make sure the driver signing enforcement is turned off each time - it makes the whole process quite time consuming but the laptop seems to have behaved itself reasonably well thereafter...

1.)  Texas Instruments Memory Device Driver: TIPCI_xx21-xx12_03 - Sorts out the flash memory (Texas Instruments) card reader

2.)  Alps touchpad Driver: Touchpad_ALPS_8.100.2020.112_W8x64U_A (from a Gateway site)

3.)  Sony Firmware Extension Parser (SFEP): Sony_Firmware_Extension_Parser_Driver_8.0.1.2

4.)  Sony Shared Library: SONY_SHARED_LIBRARY_5.7.0.6070_201006090

5.)  Sony Settings Utility: SETTINGS_UTILITY_SERIES_5.4.0.12230

6.)  Vaio Event Service: VAIO_EVENT_SERVICE_5.4.0.12230

 

The ALS driver seems to work well and gestures and edge effects now work on the touch pad. Once the other Sony drivers/softwares are installed, the function key controls for contrast/brightness seem to function but the S1 and AV-Mode key do not....I don't use these. I've tried most of the interfaces and controls and they seem to now work as desired.

 

Hope this may help some others on the site...

Happy New Year!

Link to comment
Share on other sites

  • 4 weeks later...

I just uploaded a modified version of an old beta driver from Sony Japan (when Windows Vista x64 was still new) with updated DLL and SYS from 310.90 and it worked here on my Windows 8 Pro x64 (and it is retro compatible with W7 x64 as well) by manually updating the driver, without the need of disable driver signature enforcement.

 

Here you go: http://www.4shared.com/archive/ffnUZujB/Sony_NVIDIA_8400M_GT_-_Windows.html

Edited by ThigaZ
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...