Jump to content
LaptopVideo2Go Forums

780M Drivers Not Working//Detected


fuquan

Recommended Posts

Hi,

I just got an iBuyPower CZ-27(which is a modified MSI GT70 with ibuypower touches) laptop with a 780m today with all the drivers preinstalled. The first thing I did was to try and open the NVIDIA control panel to try to set some settings. A message box came up saying NVIDIA display settings weren't available. I'm like ok, maybe I need to be playing a game first so it switches graphics cards since its probably running on the Intel HD 4600 graphics right now. I open up Bioshock Infinite to see if it would fix the problem, but the control panel still wouldn't open. Not only that, it was still using the Intel HD 4600. I tested with League of Legends and I got 30 fps only on high settings with only the shadows being set to low.

I then open up my device manager and go to display adapters, while running a game, and I see the Intel HD Graphics 4600 along with GeForce GTX780m with a yellow warning sign. I tried tinkering further with it to no avail, and in the end I decided to reinstall windows 8 as a last resort.

Once I finished reinstalling windows 8, I tried reinstalling all the drivers that came on the cd. One driver couldn't install though, which were the NVIDIA ones. It kept saying that it couldn't detect the hardware so it wouldn't install. I went to device manager, and under display adapters, there was only Intel HD Graphics 4600 under it. I then tried to disable that to see if it would work; once I disabled it, a second thing came up which was Microsoft Basic Display Adapter with a the yellow exclamation warning. I tried to install the NVIDIA drivers after, and it worked. After restarting, I tried to open the NVIDIA control panel again, and a message box comes up saying NVIDIA display settings not available, You are not currently using a display attached to a NVIDIA gpu. I go to device manager and still see Microsoft Display Adapter. I disabled Windows Driver Signing. It changed to Geforce GTX 780M. I installed my drivers again and restarted, now it has disappeared from Display Adapters in my device manager.

This is the point I got up to and now I'm stuck with what to do next. Please help.

Edited by fuquan
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...