Jump to content
LaptopVideo2Go Forums

Solution! Installing new Nvidia drivers for mobile cards based on G96M chipsets. No bsod!


Raalph

Recommended Posts

Hi,

 

This solution I only checked on my Asus Geforce 9650m gt but I think it should also work on all cards based on G96m chip. For example: 9600m gt, 9600m gs, 9500m gs, 9700m gt and maybe more. If my sollution succeeds you will have no more bsods and random restarts after installing new Nvidia driver! This solution enables powermizer so it will help again to keep your laptop cold. This solution is based on informations that I found here:

http://en.community.dell.com/support-forums/laptop/f/3519/t/19448813.aspx?pi239031352=3

 

We will need to modify inf file to make that driver working 100% stable with your laptop.

Ok lets start:

 

1. You need to know exact hardware id of your graphic card, you will find it in device manager. Example: http://dellwindowsreinstallationguide.com/downloading-drivers-checking-hardware-ids-and-downloading-and-installing-dell-system-drivers-in-the-correct-order/checking-hardware-ids-in-the-device-manager/

2. Download driver 337.88 from here:

64bit version: http://us.download.nvidia.com/Windows/337.88/337.88-notebook-win8-win7-64bit-international-whql.exe

or 32bit version: http://us.download.nvidia.com/Windows/337.88/337.88-notebook-win8-win7-32bit-international-whql.exe

3. Now run setup.exe but DONT INSTALL your driver. Cancel it after it unpacks in c:\nvidia folder.

4. Go to c:\nvidia and find folder "Display.Driver" open it and here you will find inf files to mod your driver.

5. First find inf file that supports your exact hardware id of your geforce.

6. Second find inf file that supports DELL Quadro 770m. Hardware ID we are looking is: PCI\VEN_10DE&DEV_065C&SUBSYS_02501028. Should be in "nvdmi.inf" for driver 337.88. This is the inf file that we need to add support for our geforce card. How to do it example:  http://forums.guru3d.com/showthread.php?t=377158. Remember to make the same Section for your gpu as Dell quadro 770m already has.

7. This part is important because you need to delete support for your graphic card from old inf file because now two inf files supports the same card. Simply delete your hardware id from first inf file.

8. Now you can install your driver from c:\nvidia folder. If you install this driver on win8 please remember first to disable driver signature. I suggest to use custom installation and not installing geforce experience( you dont want to update your driver ).

9. Restart and enjoy.

 

Please write some feedback if this solution works on your laptop. Give us your exact Hardware id, model . That would help more people to have their laptops work and running with new drivers. :)

 

ps. after some testing it seems not so 100% stable, but its still better than before, getting from time to time random BSOD. Probably its because I have DDR2 type VRAM, on DDR3 should be ok. So for now no new drivers for me :cry2:

Edited by Raalph
Link to comment
Share on other sites

  • 4 weeks later...

Hello again,

 

I am not the person that gives up so easily and it seems that I found real solution! This fix is only for advanced users who know how to extract, modify and flash back their bios into graphic card. Remember you do everything on your own risk!

 

First you will need to download program “DPC Latency Checker V1.3.0” and check if you get from time to time red spikes like similar to the ones showed on picture. If yes that means you found the reason of your BSOD and random black screen. Your latency goes high when GPU clocks are changing! In my case the highest latency value was when changing from 2D mode clocks directly to EXTRA mode. That’s when random BSOD occurs. To fix this we need to permanently disable 2d mode directly in BIOS.  This fix should probably work on all geforce 8/9/100/200/300 series cards.

 

Ok lets start.

  1. Extract your VGA bios and open it using latest Nibitor 6.06                                                       IMPORTANT! Changing clocks on main page to 0/0/0 will not disable 2D mode and you will still get BSOD! Don’t change manually clocks!
  2. What we need to do is go to Tools/Perf.Table Entries/Show Entries
  3. We need to change Perf. table entry 1. Delete old entry and pass EXACTLY this one:

 

FFFF0000000064000000000000000000000000000000000000000000100F00FFFF000000000000000000FFFF000000000000000000FFFF000000000000000000FFFF000000000000000000FFFF000000000000000000FFFF000000000000000000FFFF000000000000000000FFFF0000000000000000

 

       Click apply. This will disable your 2d mode. If you did everything ok you should see three “0” in 2d mode on main page. Just like shown on pictures.

Save your new bios.

 

4. Reopen your new bios and check if you have Integrity: green circle. That means your bios is ok. Now you can flash back your modded bios and your 2d mode is disabled.

 

After flashing your bios again run DPC Latency v1.3.0. and check if you stopped getting red spikes. If yes that means no more BSOD and restarts! Your POWERMIZER is working again! The lowest clocks are now 275/550/250 and you got back POWERMIZER and its 100% ok.  Checked this on 340.72 driver and modded inf.

 

If you try this and it works or maybe not working? don’t forget to give some feedback :)

 

post-69629-0-58662000-1411150496_thumb.jpost-69629-0-78037600-1411150503_thumb.jpost-69629-0-33477400-1411150506_thumb.jpost-69629-0-04631800-1411150513_thumb.jpost-69629-0-39686500-1411150521_thumb.j

Edited by Raalph
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...