Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
acerz5710

GeForce G210M MXM, need more recent drivers

Recommended Posts

acerz5710

Hello,

 

we have a great Acer all in one z5710 at home and we are struggling with outdated gpu drivers.

It's an reasonably good GeForce g210m rev.2 0A74 SUBSYS 02971025.

 

Acer support has stopped, there is no windows 8,10 support. Latest gpu driver dates back to 2009.

 

It's a mobile pc and can be upgraded greatly! I plan on buying the fastest G240M compatible with the model, but not going if I have to stick to 2009 drivers.

 

Is there any more recent drivers we can use with the card? Help appreciated a lot!!

Share this post


Link to post
Share on other sites
zipper

G2xx series cards are supported upto Nvidia 341.xx drivers. 341.92 is the latest one.

Share this post


Link to post
Share on other sites
acerz5710

They may be, but we get the message everytime we try to put a driver through.

 

Please look at the message from below.

 

Help much appreciated!

 

bump.jpg

Share this post


Link to post
Share on other sites
zipper

We have lost the infs for 341.92 - try this from 341.21 in which I changed the version to 341.92. Probably we get the infs back some time.

Btw, which Windows version do you try? This is Win7/Win8/Win8.1 inf.

nv_dispwi.inf

Share this post


Link to post
Share on other sites
acerz5710

Yup, we've tried to install more than five packages, on Win7 x64, Windows 10 x64. Never tried them with Windows 8 ?!

 

Both are no go as they Return similar to the above.

 

Nowhere to overwrite... where to relocate nv_dispwi.inf ?

 

edit: Driver installs fine ... ?!? 

Edited by acerz5710

Share this post


Link to post
Share on other sites
zipper

Does it work?

Share this post


Link to post
Share on other sites
acerz5710

I don't know ?! Driver started to install, screen went low res, then restored, then went black. 

 

Waited a minute, restarted from the switch ?!

 

I haven't removed the onboard driver, tried to update, not clean install. Please advise ?!

 

edit : At the moment, no vga driver in Device Manager can be found. Running low res now.

 

edit: I am overwriting driver package 341.92. That's correct right?

Edited by acerz5710

Share this post


Link to post
Share on other sites
acerz5710

I have cleanly installed driver. Driver did install.

 

Reloaded windows, no native screen resolution, only low res. No entry for Display in Device Manager.

Help much appreciated!

 

edit: We have installed a modded 306.02.2 with success! This is great to see that our H56 chipset doesnt fight off the driver. 

 

Lets hope the driver lives up to the expectations. 

 

Best wishes, to user "Dox" the original author of the driver!

Edited by acerz5710

Share this post


Link to post
Share on other sites
logampe

Thanks for the share of these informations.

 

_________________________

etui galaxy s6 coque galaxy s6

Edited by logampe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...