Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
Infinity7

WINDOWS 10 INSIDER PREVIEW BUILD 17040

Recommended Posts

Infinity7

Win 10 Insider build 17040 is released to Insiders on the Fast Ring. Microsoft blog gives details: https://blogs.windows.com/windowsexperience/2017/11/16/announcing-windows-10-insider-preview-build-17040-pc/#L1CI6A69ii067yb1.97

Share this post


Link to post
Share on other sites
LSudlow

It seems good so far. Still a few issues, but I haven't run into anything I can't live with.

Share this post


Link to post
Share on other sites
mobilenvidia

Do I, don't I, that is the question

Share this post


Link to post
Share on other sites
mobilenvidia

OK, I did, had to go via 17035 first

17035 update took ages, then got stuck on 98%, had to force a shutdown, updated OK

17040 update took no time at all, also got stuck on 98%, had to force a shutdown, updated OK

Share this post


Link to post
Share on other sites
LSudlow
9 hours ago, mobilenvidia said:

OK, I did, had to go via 17035 first

17035 update took ages, then got stuck on 98%, had to force a shutdown, updated OK

17040 update took no time at all, also got stuck on 98%, had to force a shutdown, updated OK

So I wonder what happens at 98%...  :afro:

Share this post


Link to post
Share on other sites
mobilenvidia

Brought back memories of old Windows and Office installs where it spent 98% of the time at 98%

17040 came with GF388.10 and i4279 for me

Share this post


Link to post
Share on other sites
mobilenvidia

Hmmmm, getting GSODs all of a sudden, coming to you via Safemode
Hopefully can sort this or a fresh install might be happening

Share this post


Link to post
Share on other sites
mobilenvidia

Clean install to 17040, lot more to click on with fresh install

Share this post


Link to post
Share on other sites
LSudlow
7 hours ago, mobilenvidia said:

Clean install to 17040, lot more to click on with fresh install

Definitely - just hope it solves the GSODs.

Share this post


Link to post
Share on other sites
mobilenvidia

No it did not, I have a feeling that AVG is the cause of my issues
As I was installing it, BAMM! GSOD, went back a restore point and I'm back no GSOD since

Share this post


Link to post
Share on other sites
mobilenvidia

Trialing Bitdefender, was getting a little annoyed with AVG and constant popups

Share this post


Link to post
Share on other sites
LSudlow
1 hour ago, mobilenvidia said:

Trialing Bitdefender, was getting a little annoyed with AVG and constant popups

Let me know how you  like it. I used to use Avast, but dumped it for the same reason. I've just been using Windows Defender since I got this laptop and (I think) it's been fine so far. But I know it's near the bottom of the protection heap.

Share this post


Link to post
Share on other sites
mobilenvidia

So far so good, nothing popped up yet.
I've never really trusted MS AV, maybe I should give it ago

Share this post


Link to post
Share on other sites
hfm

Pretty much all AV is just another attack vector at this point.

Share this post


Link to post
Share on other sites
LSudlow

What I like about Windows Defender is it's light-weight and completely invisible unless it finds something that needs immediate attention. Just to be safe, I run a manual Malware Bytes scan every month or two, but it's never found anything that Windows Defender missed. I might want something stronger if I haunted XXX sites or whatever, but for now, WD seems to be fine.

Share this post


Link to post
Share on other sites
mobilenvidia

So far Bitdefender has not bugged me, I might be ready to bring MS into the fold should I get annoyed

Share this post


Link to post
Share on other sites
mobilenvidia

This build for me is broken, It won't update either WIndows or any drivers via auto update
Run run trouble shoot for windows update errors found in the Database it either fixes or not but either way after reboot its broken again 

I'll try a fresh install of 17025, last working build

Share this post


Link to post
Share on other sites
mobilenvidia

17025 also has update issue, going back further trying 16299 next

Share this post


Link to post
Share on other sites
mobilenvidia

While waiting on 16299 to download which took ages for some reason as 17025 came from same MS server and was fast, updates all of a sudden began working

I'll stay on 17025 a bit longer.

Share this post


Link to post
Share on other sites
mobilenvidia

Tried all the Fall releases with no luck
Went back to 17040, tried all sorts of combinations of 'Troubleshoot Widows update' took at first ages took ages and ages for each stage
But running it each time then skipping the previous error on next run seems to have sorted it as now I have a heap of updated to install (well drivers)

So there is some hope

Share this post


Link to post
Share on other sites
LSudlow

Good luck with it. It sounds like there's another build coming (maybe on Friday) so maybe that one will work for you.

Share this post


Link to post
Share on other sites
mobilenvidia

I can't get to 14046 yet, update is doing weird things right from a clean install, all broken again, at least I got all the devices clean install doesn't have built in
Was a pain with a long list of unknown devices

Share this post


Link to post
Share on other sites
mobilenvidia

Trialing stopping Windows update service
Delete C:\windows\sofwaredistribution\datastore contents
Restart service

Update is working again , even build 14046 now available

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×