Jump to content
LaptopVideo2Go Forums
Dat Verse

Macbook Pro Mid 2010 17in nVidia GeForce GT330M Windows 10 mod Driver

Recommended Posts

Dat Verse

Hi,

My Laptop is:

Macbook Pro Mid 2010 17in 

VGA Cards:

- Intel HD Graphics (Intel Core I5 M540)

- nVidia GeForece GT330M

I installed successful Windows 10 pro on this laptop with all drivers.

But VGA (Graphics) Drivers got issue:

(This device is not working properly because Windows cannot load the drivers required for this device. (Code 31))

(Windows has stopped this device because it has reported problems. (Code 43))

(Please view the attach files)

I try installed many driver version but still got issue and many problems.

Can you help me "mod" the nvidia driver for this macbook model with windows 10?

Thanks. :)

 

 

1.png

2.png

3.png

Share this post


Link to post
Share on other sites
StefanG3D

1.

download Intel driver 8.15.10.2900 from Microsoft

http://download.windowsupdate.com/msdownload/update/driver/drvs/2013/04/200000263_dcb0607954adad6f676a8ee3f8e57a10b239e9dd.cab

install driver via have disk method as described at:
https://www.windowscentral.com/how-install-intel-beta-graphics-drivers-surface (ignore prolog about MS surface, treat CAB like ZIP)

 

2.

latest NVIDIA driver for your legacy GPU is 342.01

http://www.nvidia.com/download/driverResults.aspx/112596/en-us

get modified INF here

https://forums.laptopvideo2go.com/topic/31728-geforce-34201-fujitsu/

disable driver signatures as described in our FAQ section

 

Share this post


Link to post
Share on other sites
Dat Verse

HI @StefanG3D,

So many thanks about your reply.

I trying with your help.

I will report about this. :D

Share this post


Link to post
Share on other sites
Dat Verse

HI @StefanG3D,

I try install  Intel driver 8.15.10.2900 as you recommendation.

But when install the laptop suddenly restart too many time and after that windows 10 try restore the old driver.

I think I will re-install the windows 10.

:D 

Share this post


Link to post
Share on other sites
Dat Verse

Hi,

My current issue is: "Can not install the intel HD Graphic driver".

When install this the Macbook Pro being suddenly restart. 

I am trying install new Windows 10 in this macbook and got same issue when install HD Graphic Driver.

Maybe the Issue is the CPU of my Macbook Pro not supported UEFI boot? I wondering about this.

Are you have any idea to help me. :D

Thanks.

Share this post


Link to post
Share on other sites
mobilenvidia

What about if you install the NV driver first then Intel

Also extract drivers, then use Device Manager to install the drivers, installer might be throwing a wobbly

Share this post


Link to post
Share on other sites
Dat Verse

Hi,

So many thank your reply.

I trying install the "mod" nVidia Driver as you recommend.

The Hardware Ids of nVidia GeForce GT330M is:

PCI\VEN_10DE&DEV_0A29&SUBSYS_00C8106B&REV_A2
PCI\VEN_10DE&DEV_0A29&SUBSYS_00C8106B
PCI\VEN_10DE&DEV_0A29&CC_030000
PCI\VEN_10DE&DEV_0A29&CC_0300

I add the code:

Quote

NVIDIA_DEV.0A29 = "NVIDIA GeForce GT 330M"

----

be viewed like this:

Quote

 

[Strings]
DiskID1 = "NVIDIA Windows Vista / 7 / 8 (64 bit) Driver Library Installation Disk 1"
NVIDIA = "NVIDIA"

;GPU's by www.laptopvideo2go.com
NVIDIA_DEV.0A29 = "NVIDIA GeForce GT 330M"
NVIDIA_DEV.06A0 = "NVIDIA GT214"
NVIDIA_DEV.06B0 = "NVIDIA GT214 "
NVIDIA_DEV.06C0 = "NVIDIA GeForce GTX 480"

 

But

When install I can see the "NVIDIA GeForce GT 330M" in Model list.

(Please view the attach files for more detail).

I send you the INF file too.

Please review it and help me.

So many thanks about your help :D

 

 

a83534b9e5a3aedcc77d96a48358690e.png

db7dc1a68eee2b41f575e5fc657f5efa.png

2defb038252951e1e932923bec83472e.png

NVFM.inf

Share this post


Link to post
Share on other sites
mobilenvidia

Try the attached, you forgot about the PCI\VEN_10DE&DEV_0A29 near beginning of INF, and thats why you see the above

NVFM.inf

Share this post


Link to post
Share on other sites
Dat Verse

Hi,

Thanks for your help.

But finally, my macbook pro and windows 10 require intel driver before install nvidia.

We can not install the mod nvidia driver first.

I think the core of problem is about cpu, intel vga and windows 10 os not support on this macbook pro.

So many thanks about your time and your help for my case.

I will re install windows 7 for this laptop.

I have many knowledge on this case.

Thanks :D

Share this post


Link to post
Share on other sites
Deathrave

Hi I recently?succeed to resolve this problem! and sharing it here

My system is mbp 6,2 (mid 2010 i5)/ nvidia gt330m/ osx highsierra, windows10 (efi?booting)

It may be? LVDS problem?(https://www.mail-archive.com/intel-gfx@lists.freedesktop.org/msg01337.html)

So I decided disable IntelHD Graphics when booting.

1. Install GRUB2 on EFI partition

1.1 SIP disable (single user mode : csrutil disable)

1.2 copy grub files to EFI partition from ubuntu live dvd (I could not found how to install grub2 to EFI using ubuntu live dvd so I manually install it)
/efi/boot/grubx64.efi > /efi/boot/grubx64.efi
/boot/grub/*.* > /boot/grub/*.*

1.3 add menu entry (/efi/grub/grub.cfg)
menuentry "Windows10" {

    setpci -s "00:01.0" 3e.b=8 #remap pci lane for intel vga
    setpci -s "01:00.0" 04.b=7 #remap pci lane for nvidia vga
    
    setpci -s 00:00.0 50.W=2 #disable intel vga (maybe)
    setpci -s 00:00.0 54.B=3 #set main vga to nvidia
    
    search -s root -f /EFI/Microsoft/Boot/BCD  #search microsoft boot bcd location and set root
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi #load efi boot file
}

2. Install reFind
https://sourceforge.net/projects/refind/

3. reboot select grub > select Windows10

this is how I disable IntelHD vga

helpful links
https://help.ubuntu.com/community/UEFIBooting
https://wiki.archlinux.org/index.php/MacBookPro8,1/8,2/8,3_(2011)

etc
Everything works greatly except lcd brightness controls

final.PNG.ecc21c6e162f756b1a956a8e31f9d94f.PNG

Edited by Deathrave

Share this post


Link to post
Share on other sites
kambala_decapitator
On 7/5/2018 at 4:50 AM, Deathrave said:

...

Just wanted to say thanks to the guy above, you're a genius! This helped me fix Nvidia issues in win10 as well on MacBookPro6,2!

But I went one step further and got rid of GRUB by translating the GRUB's setpci calls into EFI's mm calls, which are executed directly from rEFInd. Steps to do this:

  1. Download EFI 1.1 shell
  2. Install rEFInd https://sourceforge.net/projects/refind/
  3. Copy EFI shell file downloaded in 1) to /Volumes/EFI/EFI/tools/shell.efi (destination filename must be exactly shell.efi). If you're doing this not immediately after installing rEFInd in Recovery mode, you'll probably need to mount the EFI volume from Terminal first:
    sudo diskutil mount disk0s1
  4. Open /Volumes/EFI/EFI/refind/refind.conf with your favourite text editor and add a new menu entry in the bottom: 
    menuentry "Windows 10" {
        icon \EFI\refind\icons\os_win.png
        loader \EFI\tools\shell.efi
        options "fs0:\EFI\tools\launch_windows_disable_iGPU.nsh"
    }

     

  5. Use your favourite text editor again and create file /Volumes/EFI/EFI/tools/launch_windows_disable_iGPU.nsh with the following contents:
    mm 000001003e 1 ;PCI :8
    mm 0001000004 1 ;PCI :7
    mm 0000000050 2 ;PCI :2
    mm 0000000054 1 ;PCI :3
    
    fs0:\EFI\Microsoft\Boot\bootmgfw.efi
  6. You're done! Reboot now and select new menu entry "Windows 10" in rEFInd to boot Windows with the working Nvidia adapter.

 

Some details:

  • on step 4 you're telling rEFInd that you'd like to execute EFI shell script which you pass in the options parameter instead of direct booting to OS
  • launch_windows_disable_iGPU.nsh script contains the converted setpci calls from step 1.3 of the original guide, as well as starting Windows boot process
  • your main EFI volume is mapped to fs0: in EFI shell (in my setup I launch windows from USB HDD, hence my MS boot loader is located at its own EFI volume on the external disk, and I use fs8: in the script - you can find these mappings by launching EFI shell from rEFInd menu and entering `map -b fs*`)
  • for w/e reason, mm's command syntax is different when executing in the shell manually, which I add for the sake of completeness:
    mm 000001003e 8 -pci
    mm 0001000004 7 -pci
    mm 0000000050 2 -w 2 -pci
    mm 0000000054 3 -pci

     

Share this post


Link to post
Share on other sites
Deathrave

Nice job kambala_decapitator !!!

I will try it sooner or later

Thank you~

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...