Jump to content
LaptopVideo2Go Forums

Macbook Pro Mid 2010 17in nVidia GeForce GT330M Windows 10 mod Driver


Recommended Posts

  • 1 month later...

Hi, @kambala_decapitator your method works ok only one time.

If you enter to OS X system and then reboot and select the "new Windows 10 system", perfect.

If you power off, poweron and select "new Windows 10 system" , Windows freezes on Windows logo.

What can I do?

Link to post
Share on other sites
kambala_decapitator
1 minute ago, adgellida said:

Hi, @kambala_decapitator your method works ok only one time.

If you enter to OS X system and then reboot and select the "new Windows 10 system", perfect.

If you power off, poweron and select "new Windows 10 system" , Windows freezes on Windows logo.

What can I do?

no idea, try original method with GRUB

Link to post
Share on other sites

Hello, can you link me to the exact message where the method is explained? Is a Macbook 2010 year model with EFI. Thanks

Link to post
Share on other sites
kambala_decapitator
1 minute ago, adgellida said:

Hello, can you link me to the exact message where the method is explained? Is a Macbook 2010 year model with EFI. Thanks

it's quoted in my instructions. The thread isn't big, you could simply scroll through older posts.

Link to post
Share on other sites
  • 1 month later...
On 4/2/2020 at 3:05 PM, nick4jc said:

 

Thank you for the solution. However when I choose Windows 10 in rEFInd boot menu the shell terminal booted but does not boot windows. The script in step 5 was not executed and have to be done manually. Only by your method of manually key in the mm command in shell console then boot windows with command the windows is booted with Intel VGA disable. Any idea? 

 

Nick

 

Note that in the versions after 11.4 of rEFInd, the passing of parameter functionality to shell.efi has broken and you need to install version 11.4. Do not install the latest version.

Link to post
Share on other sites
  • 3 months later...
  • 1 month later...
On 3/15/2019 at 5:13 PM, kambala_decapitator said:

Just wanted to say thanks to the guy above, you're a genius! This helped me fix Nvidia issues in win10 as well on MacBookPro6,2!

But I went one step further and got rid of GRUB by translating the GRUB's setpci calls into EFI's mm calls, which are executed directly from rEFInd. Steps to do this:

  1. Download EFI 1.1 shell
  2. Install rEFInd https://sourceforge.net/projects/refind/
  3. Copy EFI shell file downloaded in 1) to /Volumes/EFI/EFI/tools/shell.efi (destination filename must be exactly shell.efi). If you're doing this not immediately after installing rEFInd in Recovery mode, you'll probably need to mount the EFI volume from Terminal first:
    
    
    sudo diskutil mount disk0s1
  4. Open /Volumes/EFI/EFI/refind/refind.conf with your favourite text editor and add a new menu entry in the bottom: 
    
    
    menuentry "Windows 10" {
        icon \EFI\refind\icons\os_win.png
        loader \EFI\tools\shell.efi
        options "fs0:\EFI\tools\launch_windows_disable_iGPU.nsh"
    }

     

  5. Use your favourite text editor again and create file /Volumes/EFI/EFI/tools/launch_windows_disable_iGPU.nsh with the following contents:
    
    
    mm 000001003e 1 ;PCI :8
    mm 0001000004 1 ;PCI :7
    mm 0000000050 2 ;PCI :2
    mm 0000000054 1 ;PCI :3
    
    fs0:\EFI\Microsoft\Boot\bootmgfw.efi
  6. You're done! Reboot now and select new menu entry "Windows 10" in rEFInd to boot Windows with the working Nvidia adapter.

 

Some details:

  • on step 4 you're telling rEFInd that you'd like to execute EFI shell script which you pass in the options parameter instead of direct booting to OS
  • launch_windows_disable_iGPU.nsh script contains the converted setpci calls from step 1.3 of the original guide, as well as starting Windows boot process
  • your main EFI volume is mapped to fs0: in EFI shell (in my setup I launch windows from USB HDD, hence my MS boot loader is located at its own EFI volume on the external disk, and I use fs8: in the script - you can find these mappings by launching EFI shell from rEFInd menu and entering `map -b fs*`)
  • for w/e reason, mm's command syntax is different when executing in the shell manually, which I add for the sake of completeness:
    
    
    mm 000001003e 8 -pci
    mm 0001000004 7 -pci
    mm 0000000050 2 -w 2 -pci
    mm 0000000054 3 -pci

     

Hello. I downloaded Shell.Full and replaced name shell.efi. I installed Refind 11.4. And I did other steps. 
 

After reboot and click Windows logo: 

fs0:\EFI\tools\launch_windows_disable_iGPU.nsh is not recognized as an internal or external command, operable program, or batch file

Press ESC in 5 seconds to skip startup.nsh, any other key to continue.

Shell>

I could not this step 😕

Edit: There is not bootmgfw.efi in my usb.  (Windows 10 files in Usb: Efi>Microsoft>boot>

I see these files: 

bcd, cdboot_noprompt.efi, cdboot.efi, efisys_nopromt.bin, efisys.bin, fonts, memtest.efi, resources, winsipolicy.p7b
 

Edited by smpro
Link to post
Share on other sites
kambala_decapitator
1 hour ago, smpro said:

After reboot and click Windows logo: 

fs0:\EFI\tools\launch_windows_disable_iGPU.nsh is not recognized as an internal or external command, operable program, or batch file

Press ESC in 5 seconds to skip startup.nsh, any other key to continue.

sounds like the script is placed on another volume, maybe this helps:

On 3/15/2019 at 5:13 PM, kambala_decapitator said:

your main EFI volume is mapped to fs0: in EFI shell (in my setup I launch windows from USB HDD, hence my MS boot loader is located at its own EFI volume on the external disk, and I use fs8: in the script - you can find these mappings by launching EFI shell from rEFInd menu and entering `map -b fs*`)

your Windows loader might be in another folder or named differently, you have to find it yourself.

Link to post
Share on other sites
16 hours ago, kambala_decapitator said:

sounds like the script is placed on another volume, maybe this helps:

your Windows loader might be in another folder or named differently, you have to find it yourself.

My usb loader fs6: and I manually write these commands: fs6: > dir > cd efi > dir > cd boot > dir > bootx64 in shell.

and Windows install started. But I didn’t install. Because launch windows disable file is not recognized as an internal or external command, operable program, or batch file... 

I dont understand why...

fs0: my internal hdd and refind files in here, fs6: my external usb windows bootable disk.

Edit: Efi \ microsoft \ boot \ bootmgfw.efi Should this file be in the Volumes Efi we mount?  Or should it be on the usb disk? If it must be in Volumes Efi,  Maybe I should set up a new refind.  Because there is no Microsoft folder in my Efi file.  There is an Apple folder.

 

 

Edited by smpro
Link to post
Share on other sites
kambala_decapitator
1 hour ago, smpro said:

My usb loader fs6: and I manually write these commands: fs6: > dir > cd efi > dir > cd boot > dir > bootx64 in shell.

and Windows install started. But I didn’t install. Because launch windows disable file is not recognized as an internal or external command, operable program, or batch file... 

I dont understand why...

fs0: my internal hdd and refind files in here, fs6: my external usb windows bootable disk.

Edit: Efi \ microsoft \ boot \ bootmgfw.efi Should this file be in the Volumes Efi we mount?  Or should it be on the usb disk? If it must be in Volumes Efi,  Maybe I should set up a new refind.  Because there is no Microsoft folder in my Efi file.  There is an Apple folder.

do I understand correctly that you don't have Windows installed yet, only USB stick with windows installer?

if yes, then you must install it first (you can boot the installer manually from the EFI shell just like you wrote) and only afterwards there'll be the Windows loader on some EFI volume (probably on fs0).

My instructions apply to an already installed Windows to boot it properly.

Link to post
Share on other sites
22 hours ago, kambala_decapitator said:

do I understand correctly that you don't have Windows installed yet, only USB stick with windows installer?

if yes, then you must install it first (you can boot the installer manually from the EFI shell just like you wrote) and only afterwards there'll be the Windows loader on some EFI volume (probably on fs0).

My instructions apply to an already installed Windows to boot it properly.

Ah...

Windows 10 is not installed.  I used the commands you said on mac os.  Well, I won't do anything after installing Windows.  I'll move on to the Mac Os section and use your commands there.  Did I get right?

Edit: I installed Windows 10. I installed refind 11.4... And I used your commands on macOS. I am seeing efi/microsoft/boot/bootmgfw.efi.

I did all steps and restart. But still the same error: fs0:\EFI\tools\launch_windows_disable_iGPU.nsh is not recognized as an internal or external command, operable program, or batch file

I found my mistake. I created launch... file in Textedit. But file’s is name ...nsh.rtf... I fixed it.

Now, I have new problems...

23D8980B-DE98-4332-A4E1-EA49F88C962C.thumb.jpeg.161c53afc91cf3ef6f048d544d135781.jpeg

I fixed all problems. Thank you for everything. Windows10 is working perfectly. 
 

Fixed: I copied and pasted codes to textedit and saved launch...* file. But is not working. Because font... How did I solve? I copied and pasted shell.efi to dashboard. I erased all text in shell.efi and manually writed mm codes. 

Edited by smpro
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...