Jump to content
LaptopVideo2Go Forums

Intel Wireless-AC 9260 + Netgear R7800 (X4S)


Recommended Posts

I had that 64GB stick in the r7000 for years, but this uses a Broadcom CPU, Qualcomm/Atheros CPU's might be different, then hard pressed to find <32GB USB HDD's

I'll know once the 128GB stick turns up to confirm that theory

Link to comment
Share on other sites

New 128GB stick works right away, I take it formatted to exFAT
Horse may have bolted with the r7800 and USB

Wifi to 128GB Sandisk USB3 stick on r7800
90MB/s down (read)
25Mb/s up (write)

Wifi to 4TB enterprise HDD on Satellite receiver
50MB/s downn (read)
45Mb/s up (write)

Wifi to 64GB USB3 stick on Satellite receiver (USB2 port)
24MB/s downn (read)
17Mb/s up (write)

Link to comment
Share on other sites

In laptop 128GB USB stick can do 158MB/s reads

Write is 70MB/s for first 900MB then 35MB/s there after

Not bad for a tiny device, no bigger than a Mouse transceiver

Metal sleeve that plugs into slot gets rather hot

Link to comment
Share on other sites

Looks like I should grab one of those. What brand is it?

EDIT: Never mind - I see its a Sandisk Ultra.  :danke:

Link to comment
Share on other sites

Sandisk Ultra Fit, bought as it was the cheapest 128GB USB3 stick around, and plus it was tiny, I may give to Nyree for her wee laptop, as I won't be running backup onto it anymore
Write performance quite odd with the aprox 900MB caching, I have USB stick set to Fast removal, behaves like a SSD
With disk caching on, it does the same possibly slightly faster write after caching stops but you wait longer in the end.

Quite a nice wee USB stick

Link to comment
Share on other sites

Currently trialling Voxel FW
Based on stock FW with using new compilers to make the most of the CPU/FPU in the r7800
Not really noticing any difference with transfer speeds
But he's enabled SSH and ability to run Entware, now to see if there is a sFTP version for Qualcomm CPU;s, then can backup server securely

Link to comment
Share on other sites

Finally got this mess sorted
Shifted router into office so it could be on the UPS to have Wifi in times of power cuts
All hell broke loose again with the r7800, could not get both ipv4 and ipv6 to work at once, router unreachable.....

After some more googling came across a similar issue at Small Net Builders, where they too couldn't get AP to work (it would loose the r7800 from network even setting an IP)
They went back to FW last FW where it worked then setup AP then go forward in FW
Tried this also and it works, hallelujah 

Does lower my opinion of Netgear even further, why such a fundamental function no longer works
Quite a few FW updates have been since 38, and even more time, surely they could fix it.
In future I'll look elsewhere first and come back to Netgear if all other options are closed.
Netgear only any good with 3rd party Firmware, pity DD-WRT has performance issues with 1.7Gbps connection or I'd be over there (probably also why Netgear don't bother with FW updates as thorough as they should as DD-WRT is probably what most would use)

Link to comment
Share on other sites

I'm glad it's sorted. What a pain!

Link to comment
Share on other sites

  • 4 weeks later...

Hey! I've got exactly this setup in my computer (Intel Ac 9260, Netgear 7800 or Nighthawk or whatever they're calling it). Can some people please tell which settings to tweak to get 980 Mbps speeds like some of the screenshots show? I'm seeing more like 720 Mbps maximum. I've got beamforming and HT 160 enabled, and I'm using band 36.


P.S. How am I supposed to know which company the site is least likely to support? ;) 


P.P.S Is there not a UHD display option? My screens actually 3840 by 2160. 

Link to comment
Share on other sites

Yeah some of the behind the scenes needs updating, its become a big mission to do that

Back to your speed issue
Make sure what ever you are transferring is not held up by what ever its coming off or going to
I used a SSD on the laptop and a 8x 2TB drive RAID6 Array at other end, 100+MBps (900+Mbps) no issue
If either end is coming off or going to a HDD that could be your issue

I'm also using bands 36-64 (using all 8 low channels on a US version of the R7800)
720Mbps is more like 80Mhz (4x channel) connection not 160Mhz, all 8x channels should show in advanced, admin, router status

Are you connected to the r7800 at 1.7Gbps ?

I'm also using just WPA2 for security, fastest like this

Link to comment
Share on other sites

Hi! Thanks for the help. I didn't see this, but I was able to get a little faster by using the 36 band : like 877 Mbps down and 879 up, although only with no walls between me and the router. It does show 8 channels, 36 through 64 inclusive. There shouldn't be any problems on the computer end: I'm running a 1 TB SSD RAID that gets about 3 GB/s write and 3 GB/s read, and my processor is hexacore 4.7 GHz.  What do you mean by "at other end," though? Are you talking about a local transfer from a drive connected to the router? I didn't try that, I just used Ookla to test the speed. Yes, I opted for 1.7 Gbps, the HT 160, and so forth. 

Link to comment
Share on other sites

Are you on 1Gbps+ internet connection ?
Or did you test from your computer to another device 

If your internet is supplied at 1Gbps (or faster) whats your speed with a LAN cable ?
Connection speeds to Fibre can be lower than 1Gbps with overheads (this will be tested with a cable connection)

Your computer is plenty powerful, am quite envious in that regards

1.7Gbps connection will only be that fast in same room, you move away and it will drop
But saying that I still got actual 720Mbps performance 20m and 3 walls
This is where the r7800 does really well with 4x radio amplifiers helping out

Basically test what ever is fastest, I did between laptop and another computer where the Gigabit LAN became bottle neck
Remember the r7800 is limited to 1Gbps at very max throughput there is no way round this

Link to comment
Share on other sites

Netgear has released a new FW for the r7800 here

Voxel has updated his to include above fixes here 

Link to comment
Share on other sites

So just below 900 isn't too bad to start worrying 
900Mbps = about 100MBps
1Gbps = about 110MBps
stuff of dreams that Wifi could now be faster than Gigabit LAN
If you want to go faster you need a Link Aggregation capable router so you can then max out the Wifi
You would also need a link aggregated device to send the data to/from
My switch can, my server can if I add a 2nd Intel NIC (I have 2x 10Gbe Nics), but am loath to spend big bucks on the Wifi router

You are getting better upload speed than me, I need to look into that

Link to comment
Share on other sites

Currently running OpenWRT, came here quite by accident
Wasn't liking stock Firmware and wanted to go Fresh Tomato
Something happened during flashing, for a minute (cold sweats) I thought I bricked it, but there was promise as TFTP wouldn't flash any firmware but LEDE or OpenWRT, as if all other FW were too large (they'd stop part way through upload)
I managed to get in to CLI via SSH, done some quick reading and learning
Neither FW comes with a GUI, downloaded LUCI and installed it
I'm quite liking it, not a FW for the squeamish, most power to setup via CLI
FW support 160Mhz channels but the i9260 doesn't see the router, but 80Mhz works fine and all that DD-WRT has in performance has anyway

Anyway OpenWRT (and LEDE) are small sized firmware, and seem to perform well
A lot of control

What will probably bug me is whether I can get back to full sized FW or if something is wrong with the Flash RAM
But at this point am happy

Link to comment
Share on other sites

Man, you live life on the edge!  😎

Link to comment
Share on other sites

Long winter nights to fill in 🙂

Ofcourse above was installing DD-WRT not FreshTomato (r7000) which I was playing with while R7800 was out of action

Link to comment
Share on other sites

Nights just keep getting longer and I just can't stop fiddling with router
I have moved onto OpenWRT v18.06 from a snapshot
Working very nicely, this came with LUCI making setup a breeze
Setup as a dumb AP, this is just what I need it to be
I like how you can stop and even delete software (ie Firewall) from machine thats not needed
I can live with 80Mhz channel for now, heopfully they can sort 160Mhz

I do think there might be an issue with the NAND partition, as before I went here I tried to go back to older Netgear FW, it flashed via TFTP but after reboot no GUI
Didn't do anything else, only curious

Quite happy now, I should be able to leave this now, move onto something else to play with

Link to comment
Share on other sites

It does sound good. I'm glad it's sorted!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...