Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
loud88gt

Help with installing K4100M in HP 8770w

Recommended Posts

loud88gt

Hello, I'm new here and need some help.  I've got an HP 8770w that came with the Firepro M4000 originally.  I bought a Nvidia K4100M and the corresponding heat sink as a replacement.  I've installed it but get a black screen at startup.  It almost seems like it tries to start and then the light on my mouse goes out and it tries again.  I was going to delete the old drivers and install the new ones after it started up.  Should I install drivers first or am I missing something else?  My system bios and everything else is up to date as far as I can tell.  I can easily do the disassembly/reassembly stuff but my knowledge is limited when it comes to software.  Any help you guys can give me is greatly appreciated!

Share this post


Link to post
Share on other sites
mobilenvidia

Do the drivers even install ?
Does the K4100M come with a HP 8770w as an option ?
FInd a HP driver that supports the K4100M and would have come with the 8770w
Start here

Share this post


Link to post
Share on other sites
zipper
8770W was delivered with one of these, so a modified inf is needed:
AMD FirePro M4000 with 1GB dedicated GDDR5 video memory
NVIDIA Quadro K3000M with 2GB dedicated GDDR5 video memory
NVIDIA Quadro K4000M with 4GB dedicated GDDR5 video memory
NVIDIA Quadro K5000M with 4GB dedicated GDDR5 video memory   
K4100M seems to exist on HP Zbook 17 G2 which is a newer model. https://ftp.hp.com/pub/softpaq/sp82001-82500/sp82357.exe has a Nvidia driver for it
and should have K4100M included. Perhaps it works....
OK, looked at HP, for Zbook 17 G2 and even 8770W the latest driver 09/25/2017, 22.21.13.8573 seems to support:
NVIDIA_DEV.11B7.190A.103C = "NVIDIA Quadro K4100M"
NVIDIA_DEV.11B7.197A.103C = "NVIDIA Quadro K4100M"
NVIDIA_DEV.11B7.2255.103C = "NVIDIA Quadro K4100M"
NVIDIA_DEV.11B7.2256.103C = "NVIDIA Quadro K4100M"

Share this post


Link to post
Share on other sites
loud88gt

I have the latest driver but never get the chance to load it.  I used DDU to remove all the old drivers, then install the new GPU and get a black screen.  I noticed the numlock light on the keyboard(which is normally on) cycles on and then off every few seconds.  The laptop will turn off instantly when I press the power button which leads me to believe Windows is not starting at all.

Share this post


Link to post
Share on other sites
mobilenvidia

There might be a whitelist for GPU's in the System BIOS, HP are renowned for this 
Or just an incompatibility

Try Ubuntu Live CD and boot from this, if this doesn't work then little hope
But if you get the black screen from bootup then there is really very little no driver will fix this

Share this post


Link to post
Share on other sites
S_C

Hi,

Had the same issue with K4100M .

Was a headache for a day until i find the right VBios

The one that is working perfectly with 8770w is a Dell VBios

this one: 80.04.E8.00.1D-Dell.rom

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...