Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
Andi_84

25.20.100.6373 - 8th, 7th and 6th generation (Coffee Lake, Kaby Lake, Skylake, Gemini Lake and Broxton (Apollo Lake)), Windows 10

Recommended Posts

Andi_84

Intel graphics drivers v25.20.100.6373 for 8th, 7th and 6th generation (Coffee Lake, Kaby Lake, Skylake, Gemini Lake and Broxton (Apollo Lake)) from Intel's download center.

Driver build date: 31st October 2018 (DriverVer=10/31/2018, 25.20.100.6373)

Download links:

 

From the readme.txt:

Quote

Release Version: Production Version
Intel(R) Graphics Driver: 25.20.100.6373
Intel(R) Display Audio Driver:  10.26.00.1
Package: 538725
Release Date: November 5, 2018

Operating System(s):   
    Microsoft Windows* 10-64 - Fall Creators Update
    Microsoft Windows* 10-64 - April 2018 Update
    Microsoft Windows* 10-64 - October 2018 Update

Platforms:
    6th Gen Intel(R) Core(TM) processor family (Codename Skylake)
    7th Gen Intel(R) Core(TM) processor family (Codename Kaby Lake)
    8th Gen Intel(R) Core(TM) processor family (Codename Kaby Lake-R, Coffee Lake, Coffee Lake-R)
    Apollo Lake
    Gemini Lake


I.  INSTALLATION INFORMATION
Supports Intel(R) UHD Graphics, Intel(R) HD Graphics and Intel(R) Iris(R) Plus Graphics on:
    6th Gen Intel(R) Core(TM) processor family (Codename Skylake)
    7th Gen Intel(R) Core(TM) processor family (Codename Kaby Lake)
    8th Gen Intel(R) Core(TM) processor family (Codename Kaby Lake-R, Coffee Lake, Coffee Lake-R)
    Apollo Lake
    Gemini Lake


Supported devices:
 

; SKL
iSKLULTGT1 = "Intel(R) HD Graphics 510"
iSKLULTGT2 = "Intel(R) HD Graphics 520"
iSKLULXGT2 = "Intel(R) HD Graphics 515"
iSKLDTGT2 = "Intel(R) HD Graphics 530"
iSKLULTGT2f = "Intel(R) HD Graphics 520"
iSKLULTGT3e = "Intel(R) Iris(R) Graphics 540"
iSKLULTGT3 = "Intel(R) HD Graphics 535"
iSKLULTGT328W = "Intel(R) Iris(R) Graphics 550"
iSKLDTGT1 = "Intel(R) HD Graphics 510"
iSKLHaloGT1 = "Intel(R) HD Graphics 510"
iSKLHaloGT4 = "Intel(R) Iris(R) Pro Graphics 580"
iSKLHaloGT3fe = "Intel(R) Iris(R) Graphics 555"
iSKLHaloGT2 = "Intel(R) HD Graphics 530"
iSKLSRVGT3e = "Intel(R) Iris(R) Graphics P555"
iSKLSRVGT4 = "Intel(R) Iris(R) Pro Graphics P580"
iSKLWSGT2 = "Intel(R) HD Graphics P530"
iSKLWSGT4 = "Intel(R) Iris(R) Pro Graphics P580"

; APL
iBXTGTP = "Intel(R) HD Graphics"
iBXTGTP12 = "Intel(R) HD Graphics"

; KBL
iKBLULTGT1 = "Intel(R) HD Graphics 610"
iKBLULTGT2 = "Intel(R) HD Graphics 620"
iKBLULTGT2R = "Intel(R) UHD Graphics 620"
iKBLULTGT2F = "Intel(R) HD Graphics 620"
iKBLULTGT3E15 = "Intel(R) Iris(R) Plus Graphics 640"
iKBLULTGT3E28 = "Intel(R) Iris(R) Plus Graphics 650"
iKBLULXGT2 = "Intel(R) HD Graphics 615"
iKBLDTGT1 = "Intel(R) HD Graphics 610"
iKBLDTGT2 = "Intel(R) HD Graphics 630"
iKBLHALOGT1 = "Intel(R) HD Graphics 610"
iKBLHALOGT2 = "Intel(R) HD Graphics 630"
iKBLWGT2 = "Intel(R) HD Graphics P630"

; CFL
iCFLDTGT1 = "Intel(R) UHD Graphics 610"
iCFLDTGT2 = "Intel(R) UHD Graphics 630"
iCFLDTWSGT2 = "Intel(R) UHD Graphics P630"
iCFLHALOGT2 = "Intel(R) UHD Graphics 630"
iCFLHALOWSGT2 = "Intel(R) UHD Graphics P630"
iCFLULTGT3W28EU42 = "Intel(R) Iris(R) Plus Graphics 655"
iCFLDTGT1W35 = "Intel(R) UHD Graphics 610"
iCFLDTGT2W35 = "Intel(R) UHD Graphics 630"
iCFLDTGT1S6S4S2F1F = "Intel(R) UHD Graphics 610"

; GLK
iGLKGT2E18 = "Intel(R) UHD Graphics 605"
iGLKGT2E12 = "Intel(R) UHD Graphics 600"


[IntelGfx.NTamd64.10.0...14393]
;=====================================================================
; Windows Redstone Install - DT Only Using Driver Store
;=====================================================================
; SKL
%iSKLULTGT1% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1906
%iSKLULTGT2% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1916
%iSKLULXGT2% = iSKLD_w10_DS, PCI\VEN_8086&DEV_191E
%iSKLDTGT2% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1912
%iSKLULTGT2f% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1921
%iSKLULTGT3e% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1926
%iSKLULTGT3% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1923
%iSKLULTGT328W% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1927
%iSKLDTGT1% = iSKLD_w10_DS, PCI\VEN_8086&DEV_1902
%iSKLHaloGT1% = iSKLD_w10_DS, PCI\VEN_8086&DEV_190B
%iSKLHaloGT4% = iSKLD_w10_DS, PCI\VEN_8086&DEV_193B
%iSKLHaloGT3fe% = iSKLD_w10_DS, PCI\VEN_8086&DEV_192B
%iSKLHaloGT2% = iSKLD_w10_DS, PCI\VEN_8086&DEV_191B
%iSKLSRVGT3e% = iSKLD_w10_DS, PCI\VEN_8086&DEV_192D
%iSKLSRVGT4% = iSKLD_w10_DS, PCI\VEN_8086&DEV_193A
%iSKLWSGT2% = iSKLD_w10_DS, PCI\VEN_8086&DEV_191D
%iSKLWSGT4% = iSKLD_w10_DS, PCI\VEN_8086&DEV_193D

; APL
%iBXTGTP% = iBXTD_w10_DS, PCI\VEN_8086&DEV_5A84
%iBXTGTP12% = iBXTD_w10_DS, PCI\VEN_8086&DEV_5A85

; KBL
%iKBLULTGT1% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5906
%iKBLULTGT2% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5916
%iKBLULTGT2F% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5921
%iKBLULTGT3E15% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5926
%iKBLULTGT3E28% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5927
%iKBLULXGT2% = iKBLD_w10_DS, PCI\VEN_8086&DEV_591E
%iKBLDTGT1% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5902
%iKBLDTGT2% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5912
%iKBLHALOGT1% = iKBLD_w10_DS, PCI\VEN_8086&DEV_590B
%iKBLHALOGT2% = iKBLD_w10_DS, PCI\VEN_8086&DEV_591B
%iKBLWGT2% = iKBLD_w10_DS, PCI\VEN_8086&DEV_591D
%iKBLULTGT2R% = iKBLD_w10_DS, PCI\VEN_8086&DEV_5917

; CFL
%iCFLDTGT1% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E90
%iCFLDTGT2% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E92
%iCFLDTWSGT2% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E96
%iCFLHALOGT2% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E9B
%iCFLHALOWSGT2% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E94
%iCFLULTGT3W28EU42% = iCFL_w10_DS, PCI\VEN_8086&DEV_3EA8
%iCFLDTGT1W35% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E93
%iCFLDTGT2W35% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E91
%iCFLDTGT1S6S4S2F1F% = iCFL_w10_DS, PCI\VEN_8086&DEV_3E99

; GLK
%iGLKGT2E18% = iGLKD_w10_DS, PCI\VEN_8086&DEV_3184
%iGLKGT2E12% = iGLKD_w10_DS, PCI\VEN_8086&DEV_3185

 

Best regards,
Andi

Share this post


Link to post
Share on other sites
Haikal_Muzafar

Does this driver fix the control panel not opening bug? Been itching to update my graphics driver

Share this post


Link to post
Share on other sites
mik

I don't have such issues, didn't have with previous drivers as well.

Share this post


Link to post
Share on other sites
Haikal_Muzafar
12 hours ago, mik said:

I don't have such issues, didn't have with previous drivers as well.

perhaps it is because my windows 10 is 1607?

Share this post


Link to post
Share on other sites
dealpapa
On 11/9/2018 at 4:40 AM, Haikal_Muzafar said:

perhaps it is because my windows 10 is 1607?

why? why you still have 1607? call intel to find out why? 

 

oh maybe your system is not supported.

 

Operating System(s):   
    Microsoft Windows* 10-64 - Fall Creators Update
    Microsoft Windows* 10-64 - April 2018 Update
    Microsoft Windows* 10-64 - October 2018 Update

Edited by dealpapa

Share this post


Link to post
Share on other sites
Haikal_Muzafar

I was planning to ask intel about this but from my experience, they will always tell you to download the driver from oem site. This is unacceptable, since it's always not updated making the performance not as good as intel's.

You ask why I use 1607? LTSB, that's why.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×