Jump to content
LaptopVideo2Go Forums
mobilenvidia

GeForce 430.53 Mobile OEM hotfix

Recommended Posts

mobilenvidia

 


GeForce Hotfix display driver version 430.53 is based on our latest Game Ready Driver 430.39.  This Hotfix driver addresses the following:
  • Fixes higher CPU usage by NVDisplay.Container.exe introduced in 430.39 driver
  • 3DMark Time Spy: Flickering observed when benchmark is launched
  • BeamNG: Application crashes when game is launched
  • Shadow of the Tomb Raider: Freezes when launched in SLI mode 
  • Desktop flickers when videos are played back on a secondary monitor
Click on the URL below to download the appropriate driver:

Share this post


Link to post
Share on other sites
Olegg

Hello, can you add NVIDIA GeForce GT 630M to Modded INF, please?
The latest supported driver was version 391.35 (23.21.13.9135)
https://raw.githubusercontent.com/CHEF-KOCH/nVidia-modded-Inf/master/Inf/Mobile/391.35/nv_dispi.inf

In this driver:
NVIDIA_DEV.0DE9 = "NVIDIA GeForce GT 630M"
%NVIDIA_DEV.0DE9% = win10amobile,       PCI\VEN_10DE&DEV_0DE9
%NVIDIA_DEV.0DE9% = win10mobile,       PCI\VEN_10DE&DEV_0DE9
This is Fermi (GF108).
Edited by Olegg

Share this post


Link to post
Share on other sites
mobilenvidia
28 minutes ago, Olegg said:

Hello, can you add NVIDIA GeForce GT 630M to Modded INF, please?
The latest supported driver was version 391.35 (23.21.13.9135)
https://raw.githubusercontent.com/CHEF-KOCH/nVidia-modded-Inf/master/Inf/Mobile/391.35/nv_dispi.inf


In this driver:
NVIDIA_DEV.0DE9 = "NVIDIA GeForce GT 630M"
%NVIDIA_DEV.0DE9% = win10amobile,       PCI\VEN_10DE&DEV_0DE9
%NVIDIA_DEV.0DE9% = win10mobile,       PCI\VEN_10DE&DEV_0DE9

Alas the 630m is Fermi based (400/500 series) and NV dropped support for it
There is simply no way support can be added as anything Fermi based and older will not work

Your best bet is to head on over to 390 series these are last supported drivers

Share this post


Link to post
Share on other sites
Olegg
10 minutes ago, mobilenvidia said:

Alas the 630m is Fermi based (400/500 series) and NV dropped support for it
There is simply no way support can be added as anything Fermi based and older will not work

Your best bet is to head on over to 390 series these are last supported drivers

I want to test 390-series driver at least (for example 399.24). How to do it? Please, help.
But in your 430.53 INF File I see string: NVIDIA_DEV.1140 = "NVIDIA GeForce GT 610M / GT 620M / GT 710M / GT 720M / 800M / GT 820M / Quadro NVS 5200M" What does it mean? GT 610M and 620M is Fermi too.

Edited by Olegg

Share this post


Link to post
Share on other sites
mobilenvidia

There is a good chance that those GPU's all based on the same Series won't work with 430series drivers
GT drivers are slightly different to your 630m
Been so long can't remember of the GT's are Kepler based (600/700)

With 390 series just DL driver, extract out, download modded INF and replace INF in 'Display.Driver' folder then install
But you have to turn off Driver signature enforcement first (google it) or modded INF drivers won't install

Share this post


Link to post
Share on other sites
zipper

Nope, it's a Fermi. So NVIDIA's last official driver with support for Fermi based GeForce GPUs will be the 391.35.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...