Jump to content
LaptopVideo2Go Forums

GeForce 465.12 CUDA on WSL


Recommended Posts

NVIDIA is happy to announce the release of the latest version of the preview driver with enhancements such as NVML support for single GPU systems and support for new NVIDIA Ampere GPU architecture based GA10x such as the GeForce RTX-30 series GPUs (RTX 3090, 3080 and 3070)

Interested participants register in both the NVIDIA Developer Program 4 and the Microsoft Windows Insider Program 5, and can then access the driver installers and documentation via the Downloads area on NVIDIA's CUDA on WSL 41 webpage. Developers can use NVIDIA's Forum for sharing their public preview feedback with the WSL community.

Leverage NVIDIA's developer blog to learn much more about how CUDA works with WSL, including how to get started with running applications, including deep learning containers.




The documentation is a bit outdated, i installed latest CUDA like this for my distro

sudo apt-key adv --fetch-keys http://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64/7fa2af80.pub
sudo sh -c 'echo "deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu2004/x86_64 /" > /etc/apt/sources.list.d/cuda.list'
sudo apt-get update
sudo apt-get install -y cuda-toolkit-11-1


Edited by StefanG3D
Link to comment
Share on other sites

Same on my laptop with rtx2080 super.

After reboot error 43 in device manager. 

But this must some internal driver error as you just need to disable the card and reenable and it works fine but after reboot once again error 43

Link to comment
Share on other sites


7 hours ago, Krzyslaw said:

Same on my laptop with rtx2080 super.

G-Sync or Optimus technology?

Double-checked with my old 840M Optimus rig, there the driver works fine after reboot.

Rechecked with 1060 G-Sync, issue also appears after waking up from sleep mode.


7 hours ago, Krzyslaw said:

 you just need to disable the card and reenable and it works fine

Good find. Instead of the device manager you can also use:
nvidiaInspector.exe -RestartDisplayDriver
nvflash.exe --check
Microsoft DevCon

The Windows button combo CTRL+SHIFT+WINDOWS+B does not help.



Link to comment
Share on other sites

I have MSI GE75 10SGS which is Optimus based and rtx2080super is giving me error 43

what is strange on my second "portable/office lap" MSI ps63 which is also Optimus but with gtx1050max everything is fine.

And I have exact same w10 20h2 build and exactly same configured.

I tried error 43 fix script from egpu forum but no luck, reverted back to 457.30 on RTX and back to normal

Sad as the dev driver gave me slightly better benches

I have SOLD my old gtx1060 lap so I cant check gtx1060 

Also tried force enabling pcie root port within hiden bios menu but this doesnt change anything 

Edited by Krzyslaw
Link to comment
Share on other sites

2 hours ago, Krzyslaw said:

I tried error 43 fix script from egpu forum but no luck

I'm aware of that script, it actually uses the aforementioned MS devcon.
Its registry patch "RM1774520" refers to a function in the kernel mode layer handler (nvlddmkm.sys)
With that obscure name i wonder how a 3rd party author knows about the content of that function?
For obvious reasons no company releases infos about Windows kernel drivers.


Anyway, yet another user reported the issue at the dev forum, so i replied there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...