Jump to content
LaptopVideo2Go Forums
mobilenvidia

Dis/enable the OpenGL perfomance page

Recommended Posts

mobilenvidia

Remember the good old days of the OpenGL performance page.

Well I have found the Reg setting that enables it.

Version 30.14 of my INFs has it enabled by default, the performance page behaves like before, Direct3D and OpenGL pages.

Click here to disable the OpenGL page and have the performance page with D3D and no OpenGL.

Click here to enable (as in INF v30.14+) OpenGL page and have the performance page with D3D and OpenGL.

Feed back encouraged, which should the INF use by default ?

These 2 registry tweaks can be used at any time (just restart Dispay properties after change which is immediate) so have a play and it up what's best for you.

Pieter.

Share this post


Link to post
Share on other sites
LSudlow

Nice to have those pages back again, Pieter, and great detective work on your part!

:)

The downside is that you lose the new tweaks (High Quality Image Settings, Force Bi/Tri filtering, Force Mipmaps, Trililnear Optimization, and Anisotropic Optimization). But I'm not sure how frequently those are used anyway.

Share this post


Link to post
Share on other sites
mobilenvidia

Yes you can have one or the other, not both at the same time.

But at least now you can switch between them both with minimal effort.

Pieter.

Share this post


Link to post
Share on other sites
Guest Korpowski

hello

well, it seems that it's not possible on a quadro4 card... I don't see any difference in the propreties... :-(

Share this post


Link to post
Share on other sites
Bill
hello

well, it seems that it's not possible on a quadro4 card... I don't see any difference in the propreties... :-(

They work for me, I will get pics of the exact page differences in a bit.

Share this post


Link to post
Share on other sites
mobilenvidia

Make sure that Display properties is closed or restart Properties after/during the reg edit tweak.

Pieter.

Share this post


Link to post
Share on other sites
Bill
hello

well, it seems that it's not possible on a quadro4 card... I don't see any difference in the propreties... :-(

They work for me, I will get pics of the exact page differences in a bit.

Make sure that Display properties is closed or restart Properties after/during the reg edit tweak.

Pieter.

First, listen to Pieter, he knows what he is talking about.

Second, time for a big post.

Third, here is what it looks like on the 61.71 drivers:

The first picture is without the OpenGL page.

Direct_3D_without_OpenGL.jpg

The second is with it.

Direct_3D_with_OpenGL.jpg

I hope that is right.

(And that it helps)

Share this post


Link to post
Share on other sites
Guest Korpowski

hmmm, it realy don't work for me, but I have also an other video board ;-)

But I must say, that I'm playing Far Cry with the highest settings (1024x786) on OpenGL without any problems... It seem's that a Quadro is realy good in OpenGL-Applications. So it could be that the driver don't allow to change this settings on my card... (for a professional user, CAD and so on, it would be creazy to change any quality settings).

Is here someone who uses a Quadro card and can enable this page?

Oooooops, I'm sorry, now I know what you mean...All this pages are ALLWAYS enabled on my card - I'm sorry again, I thought there should be an other one... (Thanks for the pictures)

Share this post


Link to post
Share on other sites
mobilenvidia

Korpowski, you should be able to pick and choose now which set of properties you want.

Anybody tried setting both, ie set one page then set the other, then check back to see if the first is the same ?

Pieter

Share this post


Link to post
Share on other sites
Guest Korpowski

What kind of properties do you mean? The possibility to

I added some screenshots as attachments...

post-3-10885009490_thumb.jpg

post-3-10885009491_thumb.jpg

post-3-10885009492_thumb.jpg

Share this post


Link to post
Share on other sites
Bill
Korpowski, you should be able to pick and choose now which set of properties you want.

Anybody tried setting both, ie set one page then set the other, then check back to see if the first is the same ?

Pieter

Since the drivers I'm on don't even have that registry setting. (they are old)

I can't test right now but will later.

I did switch back and forth numerous times and I got one OR the other but never both.

This is the exact reg tweak if anyone was interested,

you either get this...

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"NvCplEnableAppProfilePage"=dword:00000000

or this.

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"NvCplEnableAppProfilePage"=dword:00000001

Somebody should try setting it to 2 instead of 0 or 1 like this:

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak]
"NvCplEnableAppProfilePage"=dword:00000002

I guess I will try to see if that works when I reinstall some newer drivers.

I usaully dont keep 6x.xx installed because most are slow and have B&W TV out.

As for which one you think you should have in the newer INFs, I like being able to set the performace for individual applications with the OpenGL page disabled.(you really don't ever need to mess with the OpenGL settings anyway)

Edit: I tried changing the value to 2 but it was the same as setting it to 1.

Share this post


Link to post
Share on other sites
mobilenvidia

There seems to be no way to have both :)

Share this post


Link to post
Share on other sites
Guest Guest

Hey, does this tweak just enable the page? Or is it the ability to use OpenGL? My OpenGL does not seem to work (with 71.84 or 77.77, 64 bit) and I was wondering if enabling this page will allow me to use OpenGL.

Also where is the location of the inf you must tweak?

Share this post


Link to post
Share on other sites
Bill

This tweak just turns the page on and off, if you look in the bottem of the INF in the section with all the tweaks, search for NvCplEnableAppProfilePage and that should be the tweak, changing the value at the end of the line from 1 to 0 turns it on or off, zero turns the OpenGL page on.

You would of course have to re-install the driver for a change made in the INF to be applied. (that is what the links at the top are for)

OpenGL working or not should not depend on wheather or not you see the page in the driver properties, I would suggest uninstalling and re-installing your drivers first, then maybe running NERD and posting the logfile might help us.

Share this post


Link to post
Share on other sites
Guest Guest

I tried using this, but the openGL page doesn't come out, all it does is remove the Perf and Quality page. When I use NVTweak the Perf and Quality comes back, but only the Direct3D page shows. Please help I read that the cure for my Nalu slowdown is in that said openGL page. I'm on 77.77 drivers and XP SP1.

Share this post


Link to post
Share on other sites
LSudlow

You're right. NVidia removed the OGL page a while ago -- I think starting with either the 70.xx drivers or the 75.xx drivers. The settings on the Performance page now effect both OGL and D3D.

If you need to adjust something not included in the nvidia control panel, you need to use something like Riva Tuner.

Share this post


Link to post
Share on other sites
Bill

Please read the post above yours 42437374. (thats too complicated to type out)

Nvidia removed the page back in the 7x.xx drivers.

The important settings are now in the advanced application profile settings.

If the setting you wish to use is not there, use Riva Tuner liek Larry suggested.

Basically to sum this thread up, this thread is meaningless to you if you use 80+ series drivers (currently anyway)

Edited by Bill

Share this post


Link to post
Share on other sites
Bill

I don't think any of them can, go try the 7x series drivers if you want that.

In the 8x series, they should all have the OpenGL settings in the application performance page (advanced settings), if not use RivaTuner or check out the new nvidia control panel for the settings.

We will see it go mainstream very soon I think. (the new control panel)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×