Jump to content
LaptopVideo2Go Forums

Fix for Toshiba Users with Black Bar


Teraphy

Recommended Posts

  • 3 weeks later...
  • Replies 256
  • Created
  • Last Reply

Top Posters In This Topic

  • Teraphy

    54

  • Craig Corp

    10

  • ®®®

    19

Top Posters In This Topic

Posted Images

Guest Wraithguard

I have a Toshiba Satellite 5100-503. I repeatedly tried new versions of the nVidia refrence drivers, but usually some important function like TV Out wouldn't work and I had to revert back to the driver supplied by Toshiba. Since I play games on my desktop anyway, I could live with that.

However, when I recently bought myself a new TFT display with 1920x1200 resolution, I could not get its native resolution to work with the Toshiba drivers (the 1920x1200 would be squeezed into 1600x1200 on the analog output). SO I gave the latest WHQL-certified nVidia drivers a chance and was lucky. TV Out and the widescreen TFT work flawless. However, I stumbled upon the "black bar" bug and could not use the notebooks display as a secondary.

Thanks to the help in this forum, I modified the INF file myself using the EDID override supplied by Teraphy...

1600x1200

HKR,, OverrideEdidFlags0, %REG_BINARY%, 3A,C4,00,04,00,00,FF,FF,04,00,00,00,36,12,48,3F,40,30,62,B0,32,40,40,C0,13,00,31
E5,10,00,00,18
HKR,, OverrideEdidFlags1, %REG_BINARY%, 3A,C4,00,06,00,00,FF,FF,04,00,00,00,36,12,48,3F,40,30,62,B0,32,40,40,C0,13,00,31
E5,10,00,00,18
HKR,, OverrideEdidFlags2, %REG_BINARY%, 3A,C4,00,00,00,00,FF,FF,04,00,00,00,36,12,48,3F,40,30,62,B0,32,40,40,C0,13,00,31
E5,10,00,00,18

... and the secondary fix posted by Brandon Sneed:

[nv_SoftwareDeviceSettings]
; BKS
HKR,, DualViewAllow2ndViewAsPrimary, %REG_DWORD%,    1
HKR,, DualViewAllowNonDFPAsPrimary,%REG_DWORD%,    1
HKR,, DualViewHotKeyPolicy,          %REG_DWORD%,    1
HKR,, DualViewMobile,                %REG_DWORD%, 2
HKR,, DualViewPolicyID,            %REG_DWORD%,    2

[nv_ControlPanelSettings]
;BKS
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualViewAllowNonDFPAsPrimary, %REG_DWORD%, 1
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualviewMoveDesktopIcons,%REG_DWORD%, 1

Thanks alot!

:)

Link to comment
Share on other sites

  • 3 weeks later...
Guest Guest

Hi

I was wondering, if it's known which bios versions are working, and which not, and there are tools for changing the bios, why cant someone with a good bios extract and post it here, so that others just can upgrade theirs.

Or is it only possible to change settings of the bios with those tools, and not flash the whole bios? Or is there another reason why it's not possible to do this? It just would look strange to me that someone creates a videocard that can't get firware upgrades.

What am I missing?

btw, the reason that I'm asking this, is that I'm using linux, so the whole inf thing doesnt help me, in windows it's working with the changed INF files. I tried using the option IgnoreEDID option and it worked for the old drivers, but newer drivers give a very screwed up image when I use this (screen split in 2, with lots of bulls*** trough it) so I would like to fix it in the only right way: fixing the bios

Thanks

Link to comment
Share on other sites

I believe we covered the non-working firmware versions and one working one. Most users (if not all) with the issue had the 4.17.00.41.CX. While the 59.F9 was found to be good. There were 3 possible solutions to this puzzle and we took the easiest route. Modifying the INF was simple enough after discovering the registry value. The other two would be to simply take the CX version and modify it or take the 59.F9 version and install it.

Here are the issues with the latter two methods. We don't know exactly how compatible the card with the CX and the F9 are. Are there differences such as memory speed and settings involved? Is it safe? Alternatively it would be safer to modify the CX BIOS. Which is quite possible to do, though we felt NV might not like the idea of a modified floating BIOS for people to install. I don't think there are any problems with making BIOS editors since it's really for personal use.

Finally no one has truly demanded a BIOS edit and has been willing to attempt it -- it is risky business. :)

Link to comment
Share on other sites

  • 2 weeks later...
Guest julienfr

Hello,

First of all thank you for the tools, drivers and helps that you bring.

I have Geforce 420 Go 32 Mo with my Toshiba Satellite Pro 2100.

VideoBiosVersion 4.17.00.41.C7 (see attached file)

The original drivers are 28.46. I play recent games like Toca Race Driver 2 or GTR, and I think that I must update drivers. The original drivers are here:

http://support.toshiba-tro.de/tools/Satell...lay-xp-2846.zip

I tried to install the official 56.77_win2kxp.exe. I had the black bar.

Which drivers do you advise me to improve results in games ?

On enhancer.php, do I have to only enter "Driver Version" and "Toshiba Display" (1024x768)?

Thank you in advance

PS: For better performances, do you think that I must update the bios ?

Video Display info:

infogf420.txt

Link to comment
Share on other sites

Um, short answers.

Update to any driver that you see fits your needs and runs fine. Which means just give a few a try. I don't have a specific answer but you might browse around the forums for ideas.

Yes, version is all that is required and to fix the black bar a display is required.

Update the BIOS in extreme cases that you know there is an issue. Otherwise play it safe :)

Link to comment
Share on other sites

Guest julienfr

I am trying 76.50 : it works fine. I have installed with nv4_disp.inf and there is also the nVidia tray icon.

I didn't verify if the TV-out and Other-monitor-out works fine : I will try this week-end.

I didn't change "nVidia / Performance and Quality Settings" because I am afraid that video card is too hot.

Thank you for your help.

Link to comment
Share on other sites

  • 1 month later...
Guest f0rk

Hi, @all

blackbar problem, Toshiba Satellite Pro 2100

short question :

does anyone know a way to use the "OverrideEdidFlagX" stuff under win9x?

(all info i found seems to be win2k/xp only)

i spend some (to much) time to place the values in the registry, i found the correkt key anywhere under HKLM/*/Class/Display but it doesn't work...

i also tried to switch the EDID Value of the Display to a Value of an old (but working) driver -> nothing happend...

Link to comment
Share on other sites

Guest f0rk

ok, found it myself :

HKEY_LOCAL_MACHINE\Software\NVIDIA Corporation\Global\System

is the correckt key

1.) get the latest driver + inf from http://www.laptopvideo2go.com/pages/win9x.htm (71.84 )

2.) install the driver using the moded inf

3.) get the fixed inf from the enhancer-script

(this is 2k/Xp only i think -> does not work with 9x)

4.) build an reg-file from this inf, like this:

REGEDIT4



[HKEY_LOCAL_MACHINE\Software\NVIDIA Corporation\Global\System]

"OverrideEdidFlags0"=hex:3a,c4,00,00,00,00,ff,ff,04,00,00,00,36,12,64,19,00,40,\

 41,00,26,30,18,88,36,00,1e,d7,10,00,00,18

"OverrideEdidFlags1"=hex:3a,c4,00,02,00,00,ff,ff,04,00,00,00,36,12,64,19,00,40,\

 41,00,26,30,18,88,36,00,1e,d7,10,00,00,18

"DCBOverride0"=hex:04,25,00,22,18,20,10,01,00,02,b8,88,00,00,00,02,01,01,b8,88,\

 00,00,02,02,11,02,00,00,00,00,02,01,11,02,00,00,00,00,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,3f,3e,00,00,37,36,00,00,51,50,00,\

 00,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff

"DCBOverride1"=hex:04,25,00,23,09,20,10,01,00,02,b8,88,00,00,00,02,01,01,b8,88,\

 00,00,02,02,11,02,00,00,00,00,02,01,11,02,00,00,00,00,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,3f,3e,00,00,37,36,00,00,51,50,00,\

 00,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\

 ff,ff,ff

"DefaultSettings.XResolution"=dword:00000400

"DefaultSettings.YResolution"=dword:00000300

5.) reg it

6.) change the resolution _using the Nvidia systray prog_ ! not the displaysettings under the system control...

maybe, there is something wrong with it, because the blackbar is gone after the reg but the resolution is still incorrect until setting it with Nvidia tool...

using NV_MODES tweak setting is impossible, because no REG_MULTISZ under 9x...

thats all, sorry for the bad english, i hope it's at least a bit understandable... :)

and many thanks for this great site! :)

Link to comment
Share on other sites

:) :P

I wonder what your reason is for using Win9x :)

Anyways thanks for your contribution :(

Link to comment
Share on other sites

  • 2 weeks later...

Hi all,

This is my first post and I find your site very good. But I try to install v 76.50 and I had a blackbar, so I read this post. I tried to use php enhancer for .inf then installing again and I still have the blackbar even if I reboot.

I tried to use nerd but nvdirt did not worked for me :)

If someone could help I would really appreciate !

Link to comment
Share on other sites

Your problem description seems to me as if the driver is not installed properly or even there is no driver installed. Pls. download the driver again, replace the original INF with Pieter's mobile INF for that version and install it with the HaveDisk mthod via Device Manager. Before all of that Uninstall any driver with Add/Remove Software Control Panel.

Link to comment
Share on other sites

I would like to uninstall any driver but when I make it, it reboot with another one which was installed previously (perhaps the default one...)

I am trying to install it !

Link to comment
Share on other sites

No more black bar I finally got it !

Thank you all for support ! :)

Link to comment
Share on other sites

  • 1 month later...
:(   :P

I wonder what your reason is for using Win9x :)

Anyways thanks for your contribution  :)

you ask for the reasons? this may be a _little_ bit offtopic, but you should become an answer (in fact i have some additional info for the posting above) :(

----------- Offtopic -----------

ok, in fact there is no special reason to use win9x, except that I don't like the newer versions of windows .

in my first computer time, i've worked under MS-DOS an later started programming under win9x and enjoyed it. in the days windows xp comes out i was not happy about the new license politics and the need to "unlock" the software i legealy buyed. during my work as programer i've looked many times beside to the always growing linux community and one day i just changed the side... :P

if've a second harddisk with win98 on it, that i just use for some of this old games i like so much...

ok, i may use dosbox or wine to play this games but sometimes i wan't just a full working system with a native DOS on it (a little pervert, i know).

----------------------------------

after that some additional info for my posting above. in the case using some D3D applications in fullscreenmode there is still a problem using the above solution. the mode will be switched back to some wired resolution(960x600) and the blackbar is "back from hell" this affects only the application/game just started but you can't change it because the correct mode is not listed in the options. to fix this some additional registry- fixes :

REGEDIT4

[HKEY_LOCAL_MACHINE\Enum\MONITOR\NVD0000\PCI_VEN_10DE&DEV_0175&SUBSYS_00011179&REV_A3_000800]
"MaxResolution"="1024,768"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Display\0000\DEFAULT]
"Mode"="32,1024,768"

the first key have to be changed to the correkt pci-id etc. on the system. this it's just the key i have on my system, but it's diffrent if you have some over chip...

Link to comment
Share on other sites

  • 4 weeks later...
Guest st3rius

Hey Teraphy. I appreciate your work, and have been using driver version 61.77 for some time now. Curiosity got the better of me and I've been compelled to try out version 71.84.I have just some questions i hope you can help me out with.

I see that there are the standard modded INFs and the performance INFs for this version of the driver. I'm eager to try the performance ones, unfortunately it gives me the black bar problem (at the right side of the screen). Is there any chance that there might be blackbar-free performance INFs any time soon?

Also, I see that there are many more versions of drivers after 71.84. I've got a geforce 4 420 Go 32 MB with bios version 4.17.00.41.C7 (one of the bad ones right? :) ). Perhaps you could release a good performance INF for one of the latest drivers, perhaps the late 70s or the 80s series drivers?

Another problem i face is that I've been unable to get coolbits to work. I'd like to try and up the clock speed of my GPU, and i'm really getting frustrated. sigh....

I really hope you can help me on this. Perhaps I can get a better FPS in HL2 in the future :)

Link to comment
Share on other sites

I'd like to try and up the clock speed of my GPU
NV ControlPanel OverClocking Panel is not available at some GeForce 4 model (also my 460 Go is affected).
Link to comment
Share on other sites

If you get a regular mod INF, then download it, then the one with the black bar fix.

And then go download the performance one, you should be able to compare what was added in the black bar fix, and add that to the performance INF.

You can also add some of the performance tweaks to newer INFs if you want.

I hope what I just said made sense..... :) :) :P

Edited by Bill
Link to comment
Share on other sites

st3rius, at this time I'll add it to my list of things to work on but I can't guarantee anything or soon. I'll probably try out f0rk's suggestion and figure out adding Win9x support but other things are priority at the moment.

Link to comment
Share on other sites

I recently reinstalled Windows and am now suffering from the black bar (odd, because it wasn't there last time I downloaded SP2). I've been reading through this forum trying to determine what exactly I need to do to get rid of it, but I keep coming up against the fact that I don't know *how* one "installs the .inf file." I have attempted to do it through System > Hardware > Device Manager > Update driver, but it gets so far as asking me for the location of MANY files I do not have (nv4_mini.sys, nvsvc32.exe, many .dll files).

So now I turn to you. How exactly do I implement this fix?

Many thanks. Feel free to contact me offlist at kjmatthews@IHATESPAMgmail.SPAMISBADcom

Link to comment
Share on other sites

Guest st3rius

Hi guys,

Thanks for the replies. Sux having this 420 Go sometimes *sigh*. Anyway, I'll try out the suggestion by Bill. D/lded the performance and b/b modded INFs already and done a /bin/diff. Far as I can see, I need to add in the lines containing EDID values plus the hex code; am I on the right track?

I'll get to it in the morning...bout 1am now and just got back from work..

Cheerio all...

Link to comment
Share on other sites

Guest Kelvin

Hey guys, I have a problem with a Toshiba Satellite M40(04Y01F) that utilizises an Nvidia Geforce Go 6600 graphics card 128mb VRAM. I have 1 gig DDR ram onboard. However, when I play games such as Guild Wars and GTA San Andreas, graphical glitches occur.

These happen in the form of blotches or colour fragmentations but when I press print screen they seem to go away for a short while and reappear again. I am a complete computer newbie and don't exactly know what is going on, and why my games won't run properly. Sometimes it causes video files to crash too.

these are my settings:

ystem Manufacturer: TOSHIBA

System Model: Satellite M40

BIOS: Insyde Software MobilePRO BIOS Version 4.20.09

Processor: Intel® Pentium® M processor 1.73GHz

Memory: 1024MB RAM

Page File: 345MB used, 1348MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.2180 32bit Unicode

and my geforce version is:

Display Devices

---------------

Card name: NVIDIA GeForce Go 6600

Manufacturer: NVIDIA

Chip type: GeForce Go 6600

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_0148&SUBSYS_FF101179&REV_A2

Display Memory: 128.0 MB

Current Mode: 1280 x 800 (32 bit) (60Hz)

Monitor: Default Monitor

Monitor Max Res:

Driver Name: nv4_disp.dll

Driver Version: 6.14.0010.7170 (English)

DDI Version: 9 (or higher)

Driver Attributes: Final Retail

Driver Date/Size: 1/14/2005 08:36:00, 4043392 bytes

WHQL Logo'd: Yes

WHQL Date Stamp: n/a

VDD: n/a

Mini VDD: nv4_mini.sys

Mini VDD Date: 1/14/2005 08:36:00, 3394912 bytes

Device Identifier: {D7B71E3E-4208-11CF-CB6E-1ADF03C2CB35}

Vendor ID: 0x10DE

Device ID: 0x0148

SubSys ID: 0xFF101179

Revision ID: 0x00A2

Revision ID: 0x00A2

Video Accel: ModeMPEG2_A ModeMPEG2_B ModeMPEG2_C ModeMPEG2_D ModeWMV9_B ModeWMV9_A

Deinterlace Caps: {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

Registry: OK

DDraw Status: Enabled

D3D Status: Enabled

AGP Status: Enabled

DDraw Test Result: Not run

D3D7 Test Result: Not run

D3D8 Test Result: Not run

D3D9 Test Result: Not run

I checked to see if your drivers were compatible with my graphics card but they made no mention of toshiba Geforce go 6600s, I hope i am not annoying you with my request for help as i would like to get to the bottom of this as even Toshiba support centre have so far failed in their efforts to help me.

Many thanks,

Kelvin Sit

Link to comment
Share on other sites

  • 1 month later...

Ack. It's Pieter's fault. I swear :) heh. The INF dir structure was modified earlier thus the issue. Temporarily fixed.

Thanks for letting me know. A newer version will be out soon...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...