Jump to content
LaptopVideo2Go Forums

NVIDIA Control Panel doesn't save/forget "Fixed Aspect Ratio" setting


®®®

Recommended Posts

With the help of Teraphy and Larry we were able to solve this problem.

  • SYMPTOMS
  • affects widescreen LCD displays
  • If you set the nVIDIA Control Panel to have a centered output, so that it wouldn't stretch to lower resolutions when you play games, it goes back to display adapter scaling (stretched gameplay) EVERYTIME you reboot your Laptop, and you have to change it again.
  • It is resetting from centered output to scaling every restart.

  • CAUSE
  • This issue appeared first with the release of v66.00 and higher drivers.
    Previous drivers shouldn't need this fix.
  • With older drivers this option is saved.
  • nVIDIA apparently changed something that's wired into the driver itself.

  • SOLUTION
  • For drivers higher than v66.xx add the following line to the [nv_ControlPanelSettings] section of your INF:
    HKLM,"Software\Microsoft\Windows\CurrentVersion\Run", NvStartMode,,"rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA 3"
    rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA <mode #>
    Mode settings are as follows:
    0 : Default
    1 : Native
    2 : Scaling
    3 : Centered
    5 : Aspect
    NOTE: You might want to try Teraphy's "PHP INF enhancement" page to generate an INF customized to your aspect ratio needs

Link to comment
Share on other sites

I should also point out that you can toggle display adapter scaling with a hotkey through the nview desktop manager.

I have a nice pic of it that I was going to attach...

Since I can not attach it, I will just link to it.

Bill

P.S. Would be nice if one of you mods attached it for me so I do not have to waste photobucket space on it.

-

:) <wiggles his nose> Done!

post-9-11013611070_thumb.jpg

Edited by Teraphy
Link to comment
Share on other sites

  • 9 months later...
Guest schiko@schikos.de

rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA 5

doesn't work, when i put it in the registry. (?)

..But it works fine in a batch file, which i load at start up :)

GeForce Fx Go 5650, Driver:6.7.4.2, XP-Pro SP2

Thx

Schiko

Link to comment
Share on other sites

  • 6 months later...

I'm not sure if it is belong here or not. I have Dell C840 with NVIDIA GeForce4 440 Go 32mb video card and I have a small issue when Windows XP startup screen appears. It will stretch to use all screen space, then I can push FN+F7 to make it smaller, but when I reboot screen goes back to full screen.

Any help.

Thanks :) :)

Link to comment
Share on other sites

  • 3 weeks later...

Try searching for a setting which controls LCD output (stretched) in DELL's system BIOS.

Link to comment
Share on other sites

  • 1 month later...
With the help of Teraphy and Larry we were able to solve this problem.
  • SYMPTOMS
  • affects widescreen LCD displays
  • If you set the nVIDIA Control Panel to have a centered output, so that it wouldn't stretch to lower resolutions when you play games, it goes back to display adapter scaling (stretched gameplay) EVERYTIME you reboot your Laptop, and you have to change it again.
  • It is resetting from centered output to scaling every restart.

  • CAUSE
  • This issue appeared first with the release of v66.00 and higher drivers.
    Previous drivers shouldn't need this fix.
  • With older drivers this option is saved.
  • nVIDIA apparently changed something that's wired into the driver itself.

  • SOLUTION
  • For drivers higher than v66.xx add the following line to the [nv_ControlPanelSettings] section of your INF:
    HKLM,"Software\Microsoft\Windows\CurrentVersion\Run", NvStartMode,,"rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA 3"
    rundll32.exe NvCpl.dll,dtcfg setscaling 1 DA <mode #>
    Mode settings are as follows:
    0 : Default
    1 : Native
    2 : Scaling
    3 : Centered
    5 : Aspect
    NOTE: You might want to try Teraphy's "PHP INF enhancement" page to generate an INF customized to your aspect ratio needs

It worked! I tried for days to fix this problem, and after applying what you said, everything runs fine now.

Link to comment
Share on other sites

  • 2 years later...
It worked! I tried for days to fix this problem, and after applying what you said, everything runs fine now.

i did exactly these steps. do i need to restart for these to take effect? i use the new control panel, do i switch to fixed aspect ratio or what?

Link to comment
Share on other sites

  • 2 years later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...