Jump to content
LaptopVideo2Go Forums
Guest Brandon Sneed

let 2nd Display be Primary on Dual Display

Recommended Posts

Guest Brandon Sneed

You guys may know this already, so pardon me if its redundant.

I have a mod to your .inf file to allow Display 2 to be set to primary in the Settings tab of display properties. I was so annoyed that one couldn't do this with a laptop that i beat my head in trying things.

Here are my changes...

[nv_SoftwareDeviceSettings]
; BKS
HKR,, DualViewAllow2ndViewAsPrimary, %REG_DWORD%,    1
HKR,, DualViewAllowNonDFPAsPrimary,%REG_DWORD%,    1
HKR,, DualViewHotKeyPolicy,          %REG_DWORD%,    1
HKR,, DualViewMobile,                %REG_DWORD%, 2
HKR,, DualViewPolicyID,            %REG_DWORD%,    2

[nv_ControlPanelSettings]
;BKS
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualViewAllowNonDFPAsPrimary, %REG_DWORD%, 1
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualviewMoveDesktopIcons,%REG_DWORD%, 1

Share this post


Link to post
Share on other sites
LSudlow

Thanks, Brandon. I do use those in my custom inf for the Inspiron 5150 and 5160. I'm not sure if Pieter wants to include them in the standard inf, but maybe they could go into his performance inf, or could go into our FAQ section for those who want to enable it.

Nice job!

:)

Share this post


Link to post
Share on other sites
®®®

Thanks a lot Brendan, we actually need more poeple like you who try out settings and publish them here. Good Work. :)

Share this post


Link to post
Share on other sites
Bill

Am I lost or am I the only one that thought that you could set a secondary monitor as a primary with Pieter's INF?

I thought Dell's drivers were the only ones that wouldn't let you do that. (Another reason Dell's drivers never cut it for me.)

I will be sure to keep this info handy Brandon! :)

Share this post


Link to post
Share on other sites
®®®

The option is "gray"ed out in Pieter's INF (using 71.20 with 30.44) with intention i think because there were problems with that earlier, but i don't remember exactly what these were.

But what i like is that this guy put effort in finding out which of all the NVCXPL values really affect the "2nd as Primary" setting. :)

Share this post


Link to post
Share on other sites
Guest Brandon Sneed

No problem guys, glad I could help (if i did).

I recall looking for the info on google for a long time and only finding people complaining about not being able to do so as opposed to an actual solution.

ps. I haven't tested these settings with anything outside of the 66.93 drivers (the latest ver posted on nvidia's site). I would assume they work unless nvidia broke them on purpose in later builds since all the 2D stuff is pretty static, with regards to the driver code, by now i'd imagine.

Share this post


Link to post
Share on other sites
LSudlow

They work on all drivers, at least since the 4x.xx series. You found the right combination.

:)

Share this post


Link to post
Share on other sites
Guest Nathan Bales

Thank you, I was bashing my head in looking for this.

It didn't work perfectly, after a reboot support seems to have vanished in the nVidia control panel. :) But I can still get it right through the windows control panel. It's actually better this way because the nVidia tools confused my digitizer.

Thanks again. :)

Share this post


Link to post
Share on other sites
Guest Guest

Many thanks for this Brandon.

I have a laptop and an external LCD. Please correct me if I'm wrong, but after I have set my external LCD to be the primary, and then restart the laptop, will the display automatically go straight to the external LCD?

Bcoz at the moment its so stupid - every time i restart, the display automatically goes to the built-in laptop LCD. I really really really++ never want to use the built-in LCD. I always want to use the external LCD all the time, automatically, without having to change settings every single time i restart.

Does this code do that?

Share this post


Link to post
Share on other sites
Bill

This topic has some tweaks.

http://forums.laptopvideo2go.com/index....indpost&p=15253

One of the Dell tweaks mentioned should fix your problem I am guessing, you will have to do the experimintation though to find out which one(s).

Some of the tweaks in the post are the same tweaks listed in this thread, but one of the strange ones should fix the problem, I really don't know which one it is, but putting all those in fixed all the problems for me.

Bill

Share this post


Link to post
Share on other sites
Kamika007z

Just check out your request and the only line I'm missing is this:

HKR,, DualViewAllow2ndViewAsPrimary, %REG_DWORD%,    1

I will add it later on, because I'm not on my laptop as I write this :)

Share this post


Link to post
Share on other sites
Guest Guest

I tried to add these lines to my .inf-file and managed to set my external TFT to primary with the internal display on the laptop as secondary but it also resulted in problems when starting games (NFS: Underground and CS: Source) - problems meaning the games didn't work at all!

The graphics card is a GF go 66600 (on a laptop with a P M 1,73 GHz, 1024 MB).

I currently use the laptop as a desktop computer with all the standard "external" accesories; display, keyboard, mouse, speakers etc through a docking station and I'm only using the external display - I would really appreciate some help with this - how can I get the dual-view to work?? You guys seem to be the only ones who has the answer to my questions...

Sincerely

Jocke,

Sweden.

Share this post


Link to post
Share on other sites
mattman

Is there a way to modify these to do the opposite?

I've got an issue on 81.9* drivers where when i boot my lappie on the docking station, it loads the 2nd display as primary, but at some bizzare reso, I imagine the highest it can output (trying to output the 1400x1050 that my laptop uses but not actually capable).

There is a toshiba utility to swap the laptop screen to primary which is pretty simple, but it would be nice to get it so I don't have to do that at all since it still turns off the 2nd display and i have to go back in (again) to re-activate the 2nd display at the correct reso.

Edited by mattman

Share this post


Link to post
Share on other sites
Guest Jason T

Thanks for this.

I have a new Toshiba portege s100 and couldn't get the external as primary, this wrks like a charm!!!

You guys may know this already.....

Quote truncated to make thread shorter

Share this post


Link to post
Share on other sites
Guest Guest
You guys may know this already, so pardon me if its redundant.

I have a mod to your .inf file to allow Display 2 to be set to primary in the Settings tab of display properties. I was so annoyed that one couldn't do this with a laptop that i beat my head in trying things.

Here are my changes...

[nv_SoftwareDeviceSettings]
; BKS
HKR,, DualViewAllow2ndViewAsPrimary, %REG_DWORD%,	1
HKR,, DualViewAllowNonDFPAsPrimary,%REG_DWORD%,	1
HKR,, DualViewHotKeyPolicy,[tab][/tab][tab][/tab]%REG_DWORD%,	1
HKR,, DualViewMobile,[tab][/tab][tab][/tab][tab][/tab] %REG_DWORD%, 2
HKR,, DualViewPolicyID,[tab][/tab][tab][/tab]  %REG_DWORD%,	2

[nv_ControlPanelSettings]
;BKS
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualViewAllowNonDFPAsPrimary, %REG_DWORD%, 1
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualviewMoveDesktopIcons,%REG_DWORD%, 1

How do I apply this? I tried saving this as a .reg file and running it but it didn't work. Do I need to reinstall my video card driver?

What I am actually trying to do is get an external monitor working with my ITC 9300 laptop. I think it is also known as a Sager. It has a 6800 Go Ultra. Some time ago I updated the driver to version 6.14.10.7772 (file date is 15/6/2005). I think the drivers were from Omega.

Anyway, I just bought an external display for my laptop and the hotkey to get the laptop to display on the external monitor (Fn+F7) doesn't work. I've been playing around with the control panel display settings but nothing I do can get a picture on the external monitor. I know the monitor itself is fine (I've got it working on my new Dell 9400). I just can't get this laptop to output to the DVI. :)

Would installing this .ini file possibly fix the problem? Any help would be massively appreciated. I've been googling and reading for hours with no luck...

Share this post


Link to post
Share on other sites
Bill

You need to add/change those parts in the mod INF file.

Uninstall those omega drivers and get something new like 91.33.

http://www.laptopvideo2go.com/index.php?drivers

Download the driver, unzip it, replace with mod INF and makes sure those settings are in place, then install.

The HKR tweaks you have to re-install to take affect, the HKLM tweaks you can change instantly, such as coolbits, ect.

We need to get this put into enhancer. (can mod the INF for you)

http://www.laptopvideo2go.com/enhancer

Share this post


Link to post
Share on other sites
mtnman382
You guys may know this already, so pardon me if its redundant.

I have a mod to your .inf file to allow Display 2 to be set to primary in the Settings tab of display properties. I was so annoyed that one couldn't do this with a laptop that i beat my head in trying things.

Here are my changes...

[nv_SoftwareDeviceSettings]
; BKS
HKR,, DualViewAllow2ndViewAsPrimary, %REG_DWORD%,    1
HKR,, DualViewAllowNonDFPAsPrimary,%REG_DWORD%,    1
HKR,, DualViewHotKeyPolicy,          %REG_DWORD%,    1
HKR,, DualViewMobile,                %REG_DWORD%, 2
HKR,, DualViewPolicyID,            %REG_DWORD%,    2

[nv_ControlPanelSettings]
;BKS
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualViewAllowNonDFPAsPrimary, %REG_DWORD%, 1
HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualviewMoveDesktopIcons,%REG_DWORD%, 1

Excuse my ignorance, I am not familiar with how to implement these commands. I have a compaq presario r3000 with a nvidia ge force4 440 go 64m video card and would like my games to display on the 62" jvc. I have gotten my desktop to display on the tv, and the mouse will show up, so I am assuming that if I could get the second monitor to become primary in the display tab, my problem would be solved. Can you help a newbie get there?

Thank you

Dan

dlwear382@msn.com

Share this post


Link to post
Share on other sites
®®®

This needs to be set in our modded INF which you have to download seperately for each driver release.

Share this post


Link to post
Share on other sites
Guest Vasilij

Respect, Brandon,

worked just great for ASUS A8jc laptop with GeForce Go7300 video card.

Patch applied to the 86.28 (ASUS) WinXP 32-bit drivers downloaded from this site

Share this post


Link to post
Share on other sites
Guest kt

Can someone please explain how to implement this?

I have pasted these two sections into the appropriate section of nvac.inf in driver 179.48 (XP Pro downloaded from NVidia), and reinstalled but 'use this as primary' is still grayed out.

What am I missing?

I am totally guessing at which inf to edit, was that correct? (nvac.inf)?

I did just reinstall 179.48 on top of itself... I guess I should try uninstalling first.

Thanks,

Share this post


Link to post
Share on other sites
Guest kt

I did unintall, then reinstall. Also tried changing the NVAM.INF and installing by HAVE DISK and selecting that file. Still no workie! Any ideas please?

Share this post


Link to post
Share on other sites
Teraphy

kt,

If your card and system id are listed within the original support of driver 179.48 then you can add in the registry entries.

If not you will need to download the modified INF on the 179.48 page and make sure the changes are applied. Before installing make sure there is only that INF located within the directory.

For XP 32bit you can give enhancer a go: Enhancer for 179.48 and check the last option. Primary for Dual Display

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...