Jump to content
LaptopVideo2Go Forums

Desktop icons keep moving


Guest Alan

Recommended Posts

Hi.

I have recently installed v70.78 drivers and 30.51 hacked INF from this website onto my Toshiba laptop (Satellite 1410-S102 with built-in GeForce4 420 Go). I also used the Black Bar PHP Fixer. The installation was mostly successful but there are a few things for which I'd appreciate some advice...

A second display is usually connected (LCD panel via SVGA cable). nView is enabled, with a single "desktop" spanned across both displays.

(1)

Second Display flashes off/on several times on startup and whenever nVidia control panel is accessed. Although this is not a critical issue, it is extremely distracting. Is there a fix for this?

(2)

If the laptop is powered-up without the 2nd display connected, nView detects that the 2nd display is not connected and decides to ignore the previously selected Profile (single desktop spanned across 2 displays) and will neatly re-position all my carefully grouped desktop icons onto the left-hand side of the display. Earlier versions didn't do that - they left the desktop icons alone!!! Is there a setting which I can set to "fix" the desktop icons on display 1?

Hope someone has come across these issues and can help me work around them.

Thanks in advance,

Alan

Link to comment
Share on other sites

In the [nv_ControlPanelSettings] of your inf, add or change the following line:

HKLM,"Software\NVIDIA Corporation\Global\NVTweak", NvCplDualviewMoveDesktopIcons,%REG_DWORD%, 0

To reduce the flashing, find the "coolbits" line in the same section and set it to 1. This will remove the overclocking page, but will also reduce the flashing.

Link to comment
Share on other sites

Thanks for this info.

I made both changes and, sadly, they have made no difference. I even re-booted the PC to make sure, and also re-checked the Registry to make sure the changes were still there.

(1)

Both displays (but mostly Display 2) flicker many times upon login, when the nVidia control panel opens, and if any changes are made to the nVidia settings. Any further suggestions?

(2)

With regard to the desktop icons moving around: I've re-read my original message and it is slightly incorrect. Infact, the desktop icons only move when I manually switch from the "single monitor" mode which is automatically selected by the nVidia drivers when PC starts without display 2 connected - to my user-defined (dual view) Profile (once I have connected up display 2). I want my user-defined Profile to always be effective, regardless of how many displays are physically connected at any one time.

Perhaps there are two separate issues?:

(a) The v70.78 nVidia display driver appears to be deciding to ignore my default ("dual view") Profile in instances where I start up my laptop without display 2 connected (my previous driver wasn't "clever" like this!). Can nView be forced to load up my default (dual view) Profile regardless of whether or not both displays are physically connected?

(b) Also, can the driver be told to not move desktop icons when switching from the default "single monitor" mode to a user-defined "dual view" Profile?

Thanks again.

Alan

Link to comment
Share on other sites

what you need to add to the INF is this:

HKR,, DevicesConnected, %DWORD%, 0x10101

Insert this where the other HKR settings are.

This will force on both Monitor out and TV out (you can select which is active)

NO matter what you do it will think there is a monitor and TV connected.

You should no longer have the icons move.

You can boot with no monitor attached and the control panel will still show the monitor/TV as there.

The profile should also not go back to single display.

Hope this helps

Link to comment
Share on other sites

The flashing screens happen whenever nVidia tests the available modes for the connected devices and/or adjusts modes and clock speeds. Setting Coolbits to 0 or 1 will reduce the number of flashes by one, but won't eliminate them entirely.

I don't know of any way to have separate default profiles depending on the number of connected devices. Setting The DualViewMoveDesktopIcon switch to 0 should have at least fixed the manual switch to dual view. Maybe Teraphy or Pieter can jump in here on this one.

Link to comment
Share on other sites

Thanks LSudlow and Mobilenvidia.

I added the DevicesConnected key - this has fixed the problem whereby the disconnection of the 2nd display previously needed me to manually switch Profiles (and hence get all my desktop icons moved!) to get the 2nd display working again.

Interestingly, if I do decide to manually switch between two user-defined profiles (e.g. from one profile where hardware overlay is on display 1 to another where overlay is on display 2) then the desktop icons still get moved (grrr!).

***Hot off the press - I've found a way to stop the desktop icons moving... I re-saved each user-defined Profile but, within the Advanced section of the save button, I have de-selected "Save taskbar position". Now my icons don't move!!! (I guess that there's a non-designed "feature" here whereby desktop icon positions are saved along with the tasbar's position?!).

I've given up trying to solve the display flashing problem - really annoying - but not the end of the world!

Thanks, once again, for your help. I'm "happy" now.

Cheers,

Alan

Link to comment
Share on other sites

Thanks for the update... We'll remember that trick!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...