Jump to content
LaptopVideo2Go Forums
LSudlow

Larry's INFs for Dell 5150/5160

Recommended Posts

ChrisII

I've tried MPC, Zoom Player, VLC, WMP10, Nero Showtime. Every single one exhibits the same problems.

I've also tried FFDSHOW, but ultimately it ends up crashing. (I tried diffrent releases)

Share this post


Link to post
Share on other sites
LSudlow

Spike, OGL should work fine. You may be missing the OGL page you're used to seeing in the old drivers. Most of those settings are now combined with the D3D settings on the performance page, where each setting now affects both OGL and D3D. You can enable the old OGL page with the registry tweak found in this thread.

ChrisII, I'm stumped. If you aren't running some other software that would affect VMR, my guess is there's some kind of hardware problem. Maybe you can try to wrangle a new video card out of Dell.

I've just posted updated versions of my infs. I don't know if they will help, but it might be worth a try.

Share this post


Link to post
Share on other sites
LSudlow

January 1, 2006 update:

- Improved Mipmap performance in D3D games.

- Several updates to keep current with latest nvidia drivers.

Let me know if anything doesn't work as it should.

Share this post


Link to post
Share on other sites
Guest Spike

Okay, Opengl definitly isn't working on my Inspiron with 67.66 drivers. I've tried using the 67.66 drivers availible for download from this site and also the old official nvidia ones and replaced the nv4_disp file with the one linked to at the begging of this thread. When I try to run anything in opengl I get a report saying that opengl isn't supported by my hardware. This includes doom 3 and counter strike 1.6. I've Also tried installing the drivers without replacing the nv4_disp file, which hasn't made a difference at all with the drivers off this site, and wont let me install the original nvidia ones, which is what I expected. Anyone got any ideas why opengl doesn't work? Direct3d is fine. I've also recently formated my computer as well and the problem was there before. I am running XP, and have a geforcego 5200 with 64Mb. Thanks!

Share this post


Link to post
Share on other sites
LSudlow

I've just tried the Doom3 Demo with the newest drivers and still get that same error, but it's not a driver problem. The game is looking for some hardware capability the FX Go5200 doesn't have, like Shaders 3.0 or something. I wish the error messags was more specific.

Bummer. :)

Share this post


Link to post
Share on other sites
Bill

Run the game on low or medium settings. (select low or medium on menu, don't let game detect it or set it to high)

You could also search on google for commands for Doom3, one of those or this program could force 2.0 shaders, or in your case I would recomend 1.0 shaders.

Or just try a different driver.

Or you could just ignore me bacause I haven't been keeping up with this thread much anyway...

Edited by Bill

Share this post


Link to post
Share on other sites
Guest Spike

I don't think that is the case because all my opengl games don't work with 67.66 drivers, but they all do, including doom 3, on new drivers. I prefer the old drivers direct3d support though and also the fact they support the powermizer stuff. Is anyone else using 67.66 and having opengl problems???

Edit: Sorry, I was replying to LSudlow not the next guy. I don't know of the problem with the shader stuff

Share this post


Link to post
Share on other sites
LSudlow

Spike, it's possible nobody else has tried 67.66 with OGL. At least I can verify I get the same message as you.

There definitely are differences between driver versions. What version is the newer driver that works for you? (I tried a couple of the 81.xx drivers with no luck.)

If you want PowerMizer, give 72.14 a try and see if it works. I'm very interested in your results. Thanks!

Share this post


Link to post
Share on other sites
daonesteven

Hey Lsudlow, quick question, I use the 67.66 drivers with my 64mb version gf fx5200go on my i5150, and I just stumbled on this page...will using these modded infs catered especially to i5150 really improve framerates in games, such as WoW? (the game i play ><). Not sure the difference between these and the regular 67.66 drivers are. honestly, i dont have really much trouble in terms of fps or anything currently, but if i can squeeze more juice, why not? thanks a lot

Edited by daonesteven

Share this post


Link to post
Share on other sites
LSudlow

I don't know if it's a huge difference, but it's faster than the stock Dell driver and it enables many options that the Dell driver disables. I think you'll see a fairly good improvement.

Share this post


Link to post
Share on other sites
ChrisII

I've been poking around and decided to keep your drivers for the better 2 display support. Though I'm not a big gamer, I decided to pop in Call of Duty. This is an Open GL based app, and I also get an error message:

COD 1.3 build win-x86 Mar 2 2004

----- FS_Startup -----

Current language: english

Current search path:

C:\PROGRA~1\CALLOF~1\main\pak9.pk3 (149 files)

C:\PROGRA~1\CALLOF~1\main\pak8.pk3 (235 files)

C:\PROGRA~1\CALLOF~1\main\pak6.pk3 (3 files)

C:\PROGRA~1\CALLOF~1\main\pak5.pk3 (4858 files)

C:\PROGRA~1\CALLOF~1\main\pak4.pk3 (1668 files)

C:\PROGRA~1\CALLOF~1\main\pak3.pk3 (1992 files)

C:\PROGRA~1\CALLOF~1\main\pak2.pk3 (694 files)

C:\PROGRA~1\CALLOF~1\main\pak1.pk3 (2642 files)

C:\PROGRA~1\CALLOF~1\main\pak0.pk3 (12816 files)

C:\PROGRA~1\CALLOF~1/main

C:\PROGRA~1\CALLOF~1\main\localized_english_pak3.pk3 (7 files)

localized assets pak file for english

C:\PROGRA~1\CALLOF~1\main\localized_english_pak2.pk3 (9 files)

localized assets pak file for english

C:\PROGRA~1\CALLOF~1\main\localized_english_pak1.pk3 (3736 files)

localized assets pak file for english

C:\PROGRA~1\CALLOF~1\main\localized_english_pak0.pk3 (1204 files)

localized assets pak file for english

File Handles:

----------------------

30013 files in pk3 files

execing default.cfg

couldn't exec language.cfg

couldn't exec config.cfg

couldn't exec autoexec.cfg

========= autoconfigure

configure.csv: using configuration 2000 cpu MHz 512 sys MB 64 vid MB

execing configure.cfg

fs_basepath is write protected.

fs_homepath is write protected.

Hunk_Clear: reset the hunk ok

...detecting CPU, found Intel Pentium III

Measured CPU speed is 3.06 GHz

System memory is 512 MB (capped at 1 GB)

Video card memory is 64 MB

Streaming SIMD Extensions (SSE) supported

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

----- R_Init -----

Initializing OpenGL subsystem

...initializing QGL

...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded

...setting mode 4: 800 600 FS

...using colorbits of 32

...calling CDS: ok

...registered window class

...created window@0,0 (800x600)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 32, 24, 8 )

...35 PFDs found

...GLW_ChoosePFD failed

...GLW_ChoosePFD( 32, 24, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...failed to find an appropriate PIXELFORMAT

...restoring display settings

...WARNING: could not set the given mode (4)

...shutting down QGL

...unloading OpenGL DLL

Forcing 640x480 resolution to allow OpenGL to run in fullscreen

...initializing QGL

...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded

...setting mode 3: 640 480 FS

...using colorbits of 32

...calling CDS: ok

...created window@0,0 (640x480)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 32, 24, 8 )

...35 PFDs found

...GLW_ChoosePFD failed

...GLW_ChoosePFD( 32, 24, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...failed to find an appropriate PIXELFORMAT

...restoring display settings

...WARNING: could not set the given mode (3)

...shutting down QGL

...unloading OpenGL DLL

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

Hunk_Clear: reset the hunk ok

Could not load OpenGL. Make sure that you have the latest drivers for your video card from the manufacturer's web site.

Share this post


Link to post
Share on other sites
LSudlow

Spike and ChrisII, I've fixed the OGL problem. Unfortunately there's now a problem with the forum and I can't upload the repaired infs.

You can apply the fix yourselves by deleting the following line from the inf and reinstalling:

HKR,, CapabilityOverride, %REG_DWORD%, 8

You may first have to uninstall the driver via the Windows Control Panel's "Add/Remove Programs" to purge this setting from your system. Or you can search for "CapabilityOverride" in Regedit and delete it everywhere you find it.

Sorry about that, guys. I'll post the repaired infs as soon as we fix the forum. Thanks for alerting me to the problem!

:)

Share this post


Link to post
Share on other sites
mobilenvidia

I detect someone using a Vista tweak :)

Share this post


Link to post
Share on other sites
LSudlow

Yes... my attempt at a unified inf that would work with both Vista and XP. It occurred to me this might be the problem.

:)

Share this post


Link to post
Share on other sites
mobilenvidia

I do seem to remember some OEM's use this tweak with XP.

Good try, it is a nuisance that we can't attach files with the Forum permissions all wonky.

Share this post


Link to post
Share on other sites
LSudlow

January 6, 2006 update:

- Problem with OGL games is repaired with this version.

NOTE: You may first have to uninstall the driver via the Windows Control Panel's "Add/Remove Programs" to purge this setting from your system. Or you can search for "CapabilityOverride" in Regedit and delete it everywhere you find it.

Props to Spike and ChrisII for spotting the problem. Thanks, guys!

Let me know if there are any problems with this version.

Share this post


Link to post
Share on other sites
mozbius

I have the wakeup problem where the system wouldn't come back from standby and where the screen would stay black with my Dell Inspiron 5160.

Is the nv4_disp.inf with Dell's website driver version 67.42 will fix this?

---------------------------

Never mind. I found some firmware upgrade (I had version A02) around on the forum and installed it and since I had already installed version 67.42 + nv4_disp.inf everything works ok now.

Share this post


Link to post
Share on other sites
ChrisII

I also have the same problems as Mozbius, and it's worse as sometimes the screen doesn't power on at startup!

HOWEVER, I just tried plugging my laptop into my Infocus Screenplay 7205 HD projector, and I've never seen such a big widescreen desktop.

If you want, you could add 1280x720 as a widescreen resolution. This is the resolution for most DLP based TVs'.

Keep up your excellent work,

Chris

Share this post


Link to post
Share on other sites
LSudlow

Which driver are you using? I'll post a test inf with 1280x720 for you to try.

Share this post


Link to post
Share on other sites
ChrisII
Which driver are you using? I'll post a test inf with 1280x720 for you to try.

I WAS using 67.66, your original recommendation. However, I ran into a BIG PROBLEM. I was playing back video in VLC and opened another video, which opened a 2nd instance of VLC.

****BLUE SCREEN****

somthing to the effect of: Windows recovered from a fatal hardware error caused by nv4_disp. Then it went on with the error being somthing of an "infinite loop". (the error precisely identified nv4_disp and did say infinate loop).

The blue screen came just after the 2 videos were playing, then the screen shut off. I can't go on for now, but there is a serious problem with your latest set of infs.

That said, keep up the good work, but I'll stay away until you found out why peoples' screens go black. Like I said, the screen went black, then blue w/ error message, after playing 2 videos at once.

I am in overlay mode, VMR doesn't work for me (as we discussed in prior posts)

Share this post


Link to post
Share on other sites
LSudlow

I don't think it's the inf. As an experiment, I just opened five different videos simultaneously with no black screen or blue screen. Tried it in both overlay mode and VMR. I even tried different formats like WMV, Quicktime, DIVX, XVID, and DVD. You've got a VMR bug that other people aren't seeing, so maybe this is related.

:)

Have you tried the new inf that fixes the OGL problem? The switch that caused that problem may be creating other problems for you. You need to purge it from the registry to fix it. You can use Regedit to search for "CapabilityOverride" and delete it everywhere you find it.

Share this post


Link to post
Share on other sites
ChrisII
I don't think it's the inf. As an experiment, I just opened five different videos simultaneously with no black screen or blue screen. Tried it in both overlay mode and VMR. I even tried different formats like WMV, Quicktime, DIVX, XVID, and DVD. You've got a VMR bug that other people aren't seeing, so maybe this is related.

:)

Have you tried the new inf that fixes the OGL problem? The switch that caused that problem may be creating other problems for you. You need to purge it from the registry to fix it. You can use Regedit to search for "CapabilityOverride" and delete it everywhere you find it.

When you updated your INFs' to enable OGL, I uninstalled and reinstalled drivers, as you detail in this thread. I don't want to reinstall anything but it did specifically identify the INF as the source of the problem. I aknowledge of course that you provide these without guarantee, which is cool, I obviously wouldn't blame you if my computer fried!

I don't really need enhanced performance, but the better 2 display support was a plus for me. I looked for "CapabilityOverride" but playing around in the registry is a little beyond my capabilities. I know how, but just prefer not touching...

So I'll check back here and then and look forward to seeing why some peoples screens (mozbius) shut off... It does it to me too on startup, and wake up from standby.

Regards,

Chris

Share this post


Link to post
Share on other sites
LSudlow

A BIOS update fixed his problem. That might be worth checking for you, too.

Share this post


Link to post
Share on other sites
Kamika007z

Hey Larry, exactly what "Mipmap performance" enhancements did you make in the Jan 1st update? I'm curious. Thanks :)

Share this post


Link to post
Share on other sites
LSudlow

There used to be a slider on the old Performance\Direct3D Settings page that controlled Mipmap Detail Level and it used to have a pretty good impact on benchmark performance. I don't know why that slider was removed from the new Performance page, but you can do the same thing in the inf as follows:

Best Image Quality

HKR,, D3D_88481200, %REG_BINARY%, 00,00,00,00

High Image Quality

HKR,, D3D_88481200, %REG_BINARY%, 02,00,00,00

Blend

HKR,, D3D_88481200, %REG_BINARY%, 04,00,00,00

High Performance

HKR,, D3D_88481200, %REG_BINARY%, 08,00,00,00

Best Performance

HKR,, D3D_88481200, %REG_BINARY%, 0a,00,00,00

The default is "Best Image Quality" which is fairly cumbersome on the 5150/5160, due to the slow Go5200. I now use the "Blend" setting to boost performance a bit while still keeping good image quality.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×