Jump to content
LaptopVideo2Go Forums

Larry's INFs for Dell 5150/5160


Recommended Posts

  • Replies 682
  • Created
  • Last Reply

Top Posters In This Topic

  • LSudlow

    294

  • kane81

    68

  • halo_djk

    12

Top Posters In This Topic

Posted Images

Cheers I'll give it a go, I do like a bit of experimentation.... although I really should be doing 'proper' work! :) :)

I'm only running Vista on a partition at the mo because of other incompatibilities and its amazing how much difference one little driver can make..

Keep up the good work

Link to post
Share on other sites

oops excuse those links in the post!!

BTW - Does anyone know where I could find myself an SXGA+ screen for a reasonable price in the UK. I've had enough of scrolling around to see spreadsheets with the XGA.

Link to post
Share on other sites
Guest William Bell

Ok well tried 163.44 Vista Drivers with Pieter's INF version 3.215. System accepted drivers but on reboot I get the regular login screen for Vista but then after entering my password and when it should be showing the desktop it shows what I think is a somewhat distorted view of my wallpaper and the mouse cursor in the middle of the screen. I can move the mouse but can't bring up or open any windows. Seems odd but I write this post in Safe Mode and have to revert to the Standard VGA Driver. BTW I installed from a clean install only Standard VGA drivers loaded. And used Pieter's INF version 3.215 without your changes and with your changes and the result was the same. Any ideas?

Thanks

Dell 5150

Intel P4 2.8 HT

1GB Ram

120GB HDD

nVidia FX Go5200 64MB Video

Link to post
Share on other sites

Give 97.34 a go. I have tried a fair few of the combinations and this one seems to be ok. So far this is with pieters inf but would like to give Larry's suggestions a go shortly. Let me know if you have any luck with this.

Ideally I would like to get one to work with aero and the older control panel without crippling the machine. I tried another of the 9xxx and it worked but the lappy sounded as if it was going to take off and almost burned a whole through my desk! I think it was a 94 something - may have also been Vista RC2

Link to post
Share on other sites
Guest William Bell

Well Mitch seems as if 97.34 is working very good. I am using Pieter's INF version 31.95.

Aero works solid. All Aero effects are enabled and I am not seeing anything running sluggish.

I am posting the Windows Experience Details below. Have heard rumors in other forums that individuals are getting 3.0+ scores for the Graphics and Gaming performance numbers, while running the Go5200 on a 5150.

I am not a huge gamer, unless its MAME related. I was just trying to speed up Vista and its apps to run as effectivly as possible. I guess now that I have a stable build to fall back on I can see if I can use any different drivers and start tweaking infs as well.

It would be great for others to POST there Go5200 numbers as well, especially on a Dell 5150

Component Details Subscore Base score

Processor Mobile Intel® Pentium® 4 CPU 2.80GHz 4.1 2.0

Determined by lowest subscore

Memory (RAM) 1.25 GB 4.5

Graphics NVIDIA GeForce FX Go 5200 2.0

Gaming graphics 447 MB Total available graphics memory 2.5

Primary hard disk 84GB Free (120GB Total) 3.6

Windows Vista Ultimate

System

--------------------------------------------------------------------------------

Manufacturer Dell Computer Corporation

Model Inspiron 5150

Total amount of system memory 1.25 GB RAM

System type 32-bit operating system

Number of processor cores 1

64-bit capable No

Storage

--------------------------------------------------------------------------------

Total size of hard disk(s) 120 GB

Disk partition (C:) 84 GB Free (120 GB Total)

Media drive (D:) CD/DVD

Graphics

--------------------------------------------------------------------------------

Display adapter type NVIDIA GeForce FX Go 5200

Total available graphics memory 447 MB

Dedicated graphics memory 64 MB

Dedicated system memory 0 MB

Shared system memory 383 MB

Display adapter driver version 7.14.10.9686

Primary monitor resolution 1024x768

DirectX version DirectX 9.0 or better

Network

--------------------------------------------------------------------------------

Network Adapter Broadcom 802.11g Network Adapter

Network Adapter Broadcom 440x 10/100 Integrated Controller

Network Adapter Microsoft Tun Miniport Adapter

Link to post
Share on other sites

Heres mine for comparison, wierd how my processor scpres lower than yours, is it a Hyperthreading one? What Bios version are you running? Same with the RAM, Mines lower? I have a 1GB crucial DDR400 and 256mb DDR333 that was in the machine to start with.

I would be interested to find out if anyone has actually scored higher with the go5200 in a 5150?!

2.0 Determined by lowest subscore

Processor Mobile Intel® Pentium® 4 CPU 2.80GHz 3.9

Memory (RAM) 1.25 GB 4.2

Graphics NVIDIA GeForce FX Go 5200 2.0

Gaming graphics 447 MB Total available graphics memory 2.5

Primary hard disk 18GB Free (27GB Total) 4.0

Windows Vista Ultimate

System

--------------------------------------------------------------------------------

Manufacturer Dell Computer Corporation

Model Inspiron 5150

Total amount of system memory 1.25 GB RAM

System type 32-bit operating system

Number of processor cores 1

64-bit capable No

Storage

--------------------------------------------------------------------------------

Total size of hard disk(s) 56 GB

Disk partition (C:) 18 GB Free (27 GB Total)

Disk partition (D:) 5 GB Free (29 GB Total)

Media drive (E:) CD/DVD

Graphics

--------------------------------------------------------------------------------

Display adapter type NVIDIA GeForce FX Go 5200

Total available graphics memory 447 MB

Dedicated graphics memory 64 MB

Dedicated system memory 0 MB

Shared system memory 383 MB

Display adapter driver version 6.0.6000.16386

Primary monitor resolution 1024x768

DirectX version DirectX 9.0 or better

Network

--------------------------------------------------------------------------------

Network Adapter Broadcom 440x 10/100 Integrated Controller

Network Adapter Intel® PRO/Wireless 2915ABG Network Connection

Network Adapter Microsoft Tun Miniport Adapter

Link to post
Share on other sites

2.0 graphics is all I've been able to squeeze out of the 5150 (64MB VRAM) too, so we're all in the same ballpark.

Did you both include all the tweaks I listed? If they worked, I'll post something similar as a beta Vista driver for 5150/5160 users.

A big thanks to both of you for your work on this!

:)

Link to post
Share on other sites

I tried it both with and without the tweaks so can vouch they work.

The only trouble I have come across is that some of the control panel items seem to be missing. I get a 3d settings and dual view setting but I think there should be more options. I have to admit I'm not used to the new style control panel though!

Link to post
Share on other sites
Guest William Bell

Mitch - I have the HT Processor and I have the A038 or is it the A38 bios update from Dell. The system had 512 in it and I upgraded to 1GB by adding another Samsung 512MB module. One thing I do remember is that I was able to match both memory module with same exact chipsets. So I am not completely sure what has made the difference in making my processor score slightly higher but it could be one if not all three of those items.

Are you able to get all AERO glass effect with your Go5200?

FYI there is a great little free program I use to monitor my temps in the 5150. It is called SpeedFan and can be found at www.almico.com. Very low overhaed and you can control you fan speeds in the 5150. My temps went down considerably using this program average CPU temp for me is around 42-47 celsius I used to run around 55+ celsius. I also initially had the XGI XP5 video in here and have not noticed any difference in internal temps with the nVidia Go5200.

Larry - I did not see the area you were referring to in the inf for your MODs. I am using Pieter's INF version 31.95.

I would like to try your MODs but I am not exactly sure where to paste the MODs in the inf. If you could elaborate I would appreciate it, maybe I am just clueless and did not see it.

Link to post
Share on other sites

William - how come your vista scoring says you have 1.25GB?? My processor is the non HT and I have bios A34 because I didn't like the sound of the new thermal map dell introduced to stop the fan sucking up dust.

I use speed fan too my cpu sits around 45 most of the time. My hard drive is always the warmest at 53 on average prob because its close to the GPU.

Yes I can get full aero glass on the go5200 with the driver in question, although I have turned off the transparency setting.

Link to post
Share on other sites

Mitch, the new control panel doesn't have all the functions of the old one. You might need to use NVTweak or RivaTuner to get at some of the missing functions.

The 5150 tweaks should go in this section:

[nv_SoftwareDeviceSettings]

I've just had a look at that inf and you'll need to add all the tweaks since none of those keys are there already.

Note - I'm not at all sure all those keys work with Vista. Be prepared to boot into safe mode and uninstall if they don't work. If it does crash, then it's a question of trying the lines a few at a time to figure out what doesn't work. I'll be interested to hear what happens. Thanks!

Link to post
Share on other sites
Guest William Bell

Mitch - Humm good question. You list the same amount of RAM as 1.25 GB. I would guess then the reason for my memory and processor having slightly higher numbers is becuase of the Hyper Threading or maybe the BIOS also my processor has Speed Step too, but I am not sure if that might account for the slight differences.

Link to post
Share on other sites
Tad off topic/not

I'm trying out Vista and find that I cant wake the 5150 laptop from standby via usb devices such as mouse or mce remote (works in XP) however pressing the standby button wakes the pc.

Ive set the "allow this device to wake" and enable usb power to ports on standby, but no go. the mouse has a little power when in standby, but wont wake, just flicker red as if only half powered.

bump ... nobody has had standby issues in vista? All you guys are talking about vista.

ie. can set and wake vista from sleep using your mouse?

Link to post
Share on other sites

Sorry for the delay.. I've been moving house. Yes I can get vista to wake from a usb mouse tho.

On another subject.... Does anyone know whether a SXGA+ screen from a inspiron 8200 is the same as found in a 5150???

Will I need a different inverter if so?

Thanks!

Link to post
Share on other sites

^

Thanks for the reply, Ive done a clean install and standby is working again!

Amazing what a clean install can do, I spent hours trying to figure out the issue.

Link to post
Share on other sites

hmm,

I'm having issues again... I cant get any of the XP drivers to show 1366x768 in vista using the 5150 inf :)

However installing the vista driver using the inf provided by laptopvideo2go allows me to selected 1366x768.

The vista driver however seem very slow.... id like to use 67.66 or 84.98 or 94 drivers.

any ideas on how I can get Larry's 5150 inf outputting 1366x768 in Vista using xp drivers?

Link to post
Share on other sites
Ok well tried 163.44 Vista Drivers with Pieter's INF version 3.215. System accepted drivers but on reboot I get the regular login screen for Vista but then after entering my password and when it should be showing the desktop it shows what I think is a somewhat distorted view of my wallpaper and the mouse cursor in the middle of the screen. I can move the mouse but can't bring up or open any windows.

FYI :putting the laptop into standby (by pressing the standby button) and the waking it again fixes the display issue so you can see your desktop again.

However ... the driver does get flaky especally when outputting externally.

Link to post
Share on other sites

My Laptop details... still get 2.0 score for 5200

Component Details Subscore Base score

Processor Mobile Intel® Pentium® 4 CPU 3.20GHz 4.1 2.0

Determined by lowest subscore

Memory (RAM) 1.00 GB 4.2

Graphics NVIDIA GeForce FX Go 5200 2.0

Gaming graphics 319 MB Total available graphics memory 2.5

Primary hard disk 2GB Free (10GB Total) 3.8

Windows Vista Home Premium

System

--------------------------------------------------------------------------------

Manufacturer Dell Computer Corporation

Model Inspiron 5150

Total amount of system memory 1.00 GB RAM

System type 32-bit operating system

Number of processor cores 1

64-bit capable No

Storage

--------------------------------------------------------------------------------

Total size of hard disk(s) 37 GB

Disk partition (C:) 2 GB Free (10 GB Total)

Disk partition (D:) 19 GB Free (27 GB Total)

Media drive (E:) CD/DVD

Graphics

--------------------------------------------------------------------------------

Display adapter type NVIDIA GeForce FX Go 5200

Total available graphics memory 319 MB

Dedicated graphics memory 64 MB

Dedicated system memory 0 MB

Shared system memory 255 MB

Display adapter driver version 7.14.10.9686

Primary monitor resolution 1366x768

DirectX version DirectX 9.0 or better

Network

--------------------------------------------------------------------------------

Network Adapter Broadcom 440x 10/100 Integrated Controller

Network Adapter Intel® PRO/Wireless 2200BG Network Connection

Network Adapter Microsoft Tun Miniport Adapter

Link to post
Share on other sites

I know this may sound strange, but I've gone back to 67.77 driver for vista.

Now as you know I'v been trying to get 1366x768 and have had troubles.

Installing pieters inf + reg that larry suggested for 97.74 didnt bring up 1368x768.

So I tried powerstrip and I managed to add the resolution in using the predefined 1368x768.

It WORKED!!!!!

I then decided re-install 67.77 with JUST larry's inf and 1368x768 disappeared :) I couldnt add it in via powerstrip or anything.

So I then went back and installed pietes inf + mod and the custom resolution 1368x768 added previosly by powerstrip was there.

There must be something different about the two inf's. Pieters allows 1368x768 and Larry's doesnt.....

(no wonder I've been having so many issues with custom resolutions)

Please let me know if I can assist in fixing the bug in your driver inf larry.

Cheers

Larry_67.66_nv4_disp.inf

Pieter__s_67.66_nv4_disp___Larry_Sug.inf

Link to post
Share on other sites

Try this one and see if it works. For some reason I had it listed as 1368 instead of 1366.

nv4_disp.inf

Link to post
Share on other sites

^

thanks, I used the inf above, but still didnt get the resolution.

However this time I was able to add 1368x768 using powerstrip with this driver....and it works!

Thanks

P.S I had issue with pieters inf for 67.66 under vista- resuming from standby would just leave a blank screen and then colored lines and then it reboots itself.

your driver doesnt have this issue! :)

Edited by kane81
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...



×
×
  • Create New...