Jump to content
LaptopVideo2Go Forums
LSudlow

Larry's INFs for Dell 5150/5160

Recommended Posts

Guest Martin

Hello guys, I have been reading your thread and I tried installing the drivers. The problem I have is that I followed the procedure step by step, first deleting the driver I had using the Control Panel (Add/Remove Programs) and then following the procedure. Everything was ok except that by the end, the driver could not be installed at it gave me the error 'Parameter is incorrect'. I recently bought a new hard drive so I going to try to do it from fresh. In any case, what do you think I did wrong?

I tried to install the 67.66 with the INF nv4_disp (the one you have on the first page of this thread).

My Specs are.

-Nvidia go5200 64 MB

-P4, 1.5 GB RAM

Thank you

Share this post


Link to post
Share on other sites
LSudlow

It sounds like you're doing it the right way. Let us know if the fresh install doesn't work and we'll try to troubleshoot it.

Share this post


Link to post
Share on other sites
LSudlow

January 14, 2008

- Added 167.58 inf. 167.58 is a huge improvement over earlier 167-series drivers. I don't think it's any better than 169.28, but since it's a true mobile-series driver, some of you may want to give it a try.

As always, let me know if there are any problems.

Share this post


Link to post
Share on other sites
LSudlow

January 15, 2008

- Removed 9x series infs. (The 9x series was horrible for the 5150/5160.)

- Added 169.28 Vista inf

- Updated all 169 series infs

Let me know if anything doesn't work properly.

Share this post


Link to post
Share on other sites
®®®

:)

Share this post


Link to post
Share on other sites
Guest Malaclypse5

Hello,

Thanks for the work on the inf's! I just took to updating my 5150 to Vista (shifting from meedio to vista media center) and was quite happy to find your custom inf's. I am however, having a problem getting any newer driver to work. I have tried a few of the driver revs available on the site for vista x86 with their custom inf's, and while they will install, I get a rundll error on startup and windows disables the display device (code 43). I have tried the 169.28 release by downloading it from nvidia's site, extracting to directory, replacing nv_disp.inf with the inf you posted (renamed). If i install then using setup - it quickly "installs" but does not, in fact update the driver (install clearly does not take long enough, and there is no unsigned driver warning). If i install manually through device manager (have disk method) then the install stops after prompting for unsigned driver approval with a notice that the driver is not suitable for windows vista. Any advice? Many thanks for your effort and time!

Cheers

Share this post


Link to post
Share on other sites
LSudlow

It sounds like you have the XP version of either the driver or inf. Make sure you have the Vista versions of both and you should be okay.

If you do have the Vista versions, let me know and we'll try some troubleshooting steps.

Share this post


Link to post
Share on other sites
Guest Malaclypse5

Thanks for the rapid response. I did go ahead and re-download the 16928_vista inf, and the 169.28 vista x86 driver (from a different site just for kicks). I run the driver executable, choose a custom directory to extract to.. install fails as expected. I then replace the nv_disp.inf with the 16928_vista inf (renamed to nv_disp.inf). Same behavior: if I run setup, it appears to complete successfuly, but takes only about 10 seconds and does not actually update the driver. If I use the have disk method, the install errors out indicating that the driver is not compatible with vista...

Any suggestions of another release that might be worth trying in vista x86 on a 5150, or any thoughts on what I should try? this is a clean install of vista with all current updates installed (only other programs installed are the driver for a remote wonder and radmin (tried the driver install before radmin install though with same results so it shouldn't be the remote viewing hook)).

Thanks!!

Share this post


Link to post
Share on other sites
LSudlow

First, I would try Pieter's inf (on the same page as the driver download) and see if it behaves any differently. If it still fails, try dropping back to the 167 series drivers (again with the relevant inf from Pieter) and see if that works better. If so, I'll make a custom inf for that version.

If not, we'll try some other things.

Share this post


Link to post
Share on other sites
Guest Malaclypse5

Thanks again for the help! Here are the current results:

Tried the above, tried the following revs: 169.28, 167.58, 167.45 all with the same result (Pieter inf will "install" driver, but device does not start (code 43, os runs display off generic vga driver, no nvidia control panel)). Using your inf for 169.28 - running setup results in rapid driver install, completes "sucessfully" but does not actually update driver. Have disk method results in error notice that the driver is not for the os).

So, I went back further... I have another laptop running vista (m1210, so a 7400go) which had some driver issues in games, and some of the late 9x series worked better for it than some of the newer 'desktop' drivers. So on the 5150 I installed 96.85 with a custom inf, which installed, but performance was quirky, so I installed 97.46 with Pieter's custom inf. This brought the aero score up to 2.0 (enough to run aero, and as good as it gets with a 5200 i imagine, although I disable it since this is intended to be used as a vista media center pc).

So now the only problem I am having is that vista media center will 'go blank' or 'stop refreshing' in fullscreen. works like a charm in windowed mode, but even tho the app keeps running in fullscreen, after a few menu movements, the screen either goes solid black, or stops refresing/updating. I know this gets OT but i figured for 5150 owners running vista with custom inf's this should be the place for it. (May still be a driver issue... who knows).

Thanks again for your time and help! I am going to slowly step up through driver rev's and see what results I get, I will try and post these whenever I get a chance to do so.

Cheers!

Share this post


Link to post
Share on other sites
LSudlow

Thanks for the update - it's an interesting problem. I wonder if there's a stray or corrupted file somewhere that's causing the problem.

Anyway, yes, please do let us know what you find out. Thanks!

Share this post


Link to post
Share on other sites
Guest Douglas C. Weber

LArry - thanks for the custom .inf I now have 169.28 driver and it's working fine. With the latetest Dell driver (from 2004), I was getting resolution changes after rebooting. I have a Dell 2007FP (1600x1200) hooked-up to vga output. It was changing resolution to the same as native Epson lcd. Seems ok now. Thanks, Doug

Share this post


Link to post
Share on other sites
LSudlow

Thanks for the good words. I'm glad it's working!

Share this post


Link to post
Share on other sites
LSudlow

January 31, 2008:

- Removed obsolete infs.

- Added 169.32 Vista and XP infs

ALSO: I've had several requests for a 171 series inf for the 5150/5160. Unfortunately, as far as i can tell, the 171 series is intended for SLI machines and won't work for us. I've tried a few different methods and get a dangrous instant reboot any time I open the nvidia control panel. If anyone discovers something that will let these drivers work on our laptops, please let me know and I'll give them another shot.

In the meantime, enjoy the 169.32 driver. It looks like a good one.

Share this post


Link to post
Share on other sites
Guest CBChapman

Larry,

I downloaded one of your inf's and installed it, everything works good, but just curious about a couple of things that may or may not be related to the graphics card / drivers. I downloaded the 169.28 and it worked good. I have recently just completed formatting my HD because of a driver issue with my CD Rom, and I upgraded to Windows XP Pro over the Home Edition, just got a clean start. Before the format I had a driver that allowed me to overclock the card (GE Force FX 5200 - 64 MB). I'm not so concerned about the overclocking, but I would like to have the best driver/inf for video. I've noticed that some of streaming video is now choppy, where it wasn't before I formatted the had and started over. Is there a driver/inf that you would recommend for Video playback, or just the best all round driver.

Thanks

Brian

I 5150

Pentium 4 3.06 Ghz

40 GB HD

1.25 GB Ram

Share this post


Link to post
Share on other sites
LSudlow

Hi, Brian...

I'm using the same driver for streaming and I've also noticed some choppiness from time to time - mostly with FlashVideo. YouTube and WMV videos seem better and I can watch entire Netflix movies with no choppiness at all, which leads me to think something else is going on with the formats that are dropping frames. It's possible the driver is locking up some resource or other, but I haven't really tried to track it down yet. The driver is good enough in most other ways that I've overlooked it.

Another possibility is that the driver is defaulting to VMR mode, which is very CPU intensive. If you run the task manager while playing a video and find the CPU load pegged at 100 percent, that's probably the reason for the choppiness. If so, try using overlay mode wherever you can and see if it helps.

If you feel like doing some experimenting, try uninstalling the 169 driver and dropping back to a known good driver like 84.98 or 71.44. If streaming vidos start playing smoothly, let me know and I'll see if I can figure out what's going on.

Share this post


Link to post
Share on other sites
Guest CBChapman

Larry,

I might revert to the other driver, but did want to say that my CPU does go up quite a bit on those videos that are choppy. If I change my speedswith option to maximum performance the videos stream nicely, and no choppy, but ofcourse the CPU runs very hot the fans kick on high, expends alot of energy and makes alot of noise.

Before I reinstall, what is the overlay mode that you spoke about? How does that work?

Thanks

Brian

Share this post


Link to post
Share on other sites
LSudlow

Hi, Brian...

There doesn't seem to be any way to choose between VMR (Video Machine Rendering) and Overlay Mode in these new drivers. I hope it's because the drivers are now smart enough to accomodate both modes, depending on the settings in your video player.

Assuming you're watching streaming video in your browser, those settings are picked up from Windows Media Player and can be found under Tools\Options\Performance\Advanced. Check both "Use Overlays" boxes and you should be all set.

If you're using another media player, the settings will be somewhere else, but virtually all media players include an overlay setting someplace. Using overlay mode requires much less CPU power than VMR does.

Share this post


Link to post
Share on other sites
Guest CBChapman

Larry,

It was configured to use the overlay mode, and my CPU would run between 60% and 100% on certain videos, like you said it seemed to do better streaming from You Tube and the like. I switched to the 84.98 Driver and CPU drops into the 40%-50%, and runs without choppy frames or the excess heat, the CPU stays around 39-42 degrees Celcius, which has been good for my machine. That driver seems to be a better fit for me.

Thanks for all of your work / Help!!

I've learned alot from reading these post, I'll continue to read, and I'm glad somebody is still looking out for the Inspiron 5150!! I've put a lot of work into mine, and learned a lot in the process, when it's running it's generally been a very good laptop.

Brian

Share this post


Link to post
Share on other sites
LSudlow

Thanks for reporting back, Brian. 84.98 is hard to beat and should be the driver of choice for most 5150/5160 owners. I'll investigate further, but from what you're describing, the 169 series may be defaulting to VMR mode, which would be a problem for us. If so, I'm not sure there's anything we can do about it.

EDIT: I've just thought of something, if you're willing to do a bit more experimenting: Can you try reinstalling 169.28 or 169.32 (be sure to uninstall your present driver first) and do the following:

- Go into the nvidia control panel

- Click on "Set up multiple displays

- Click on "Use only one display (Single)."

Then try some of the same videos that have been choppy. It may well be that your installation defaulted to Clone or DualView mode, which could be causing the choppiness.

On the other hand, if you already know you were in single display mode, or prefer to stick with what you've got, then nevermind. <g>

Share this post


Link to post
Share on other sites
Guest CBChapman

Larry,

I did try that, and it was still choppy, and caused more cpu usage. It definitely seems like the higher cpu usage and maybe the throttling of the cpu has a lot to do with the choppy video, like I said while on the 169, if I went to speed switch and raised my setting to max performance, the choppiness went away, although the heat jumped up considerably, as it always does while on max performance with speed switch.

In short, I did set it to single display, but still got choppy video.

Thanks

Brian

Share this post


Link to post
Share on other sites
LSudlow

Then it's defintely something in the new driver. I appreciate your reporting back.

On another note, the 5150/5160 is notorious for heat problems but you still should be able to run at max performance with all drivers. Have you tried cleaning out the cooling fins inside the vent on the back panel (near the power connecter)? I use a can of compressed air to blast the dust out of the fins every couple of weeks. It makes a big difference.

Share this post


Link to post
Share on other sites
Guest CBChapman

Larry,

Yeah I have worked with this heat issue alot on this computer, my monitor went out about 1 1/2 year after I got the laptop from Dell, I had no warranty at that time, so I just sat it aside for awhile and researched. When I got brave enough to fix the monitor myself, I replaced the FL Inverter, and it was back in action, I then I began working on the heat issue. I stripped the computer down, took the heat sink off, and cpu off, replaced the thermal grease, cleaned the fan and all the assembly area well. I then disabled speedstep in the bios, downloaded the diefer cpu/fan monitoring tool and speed switch XP. By disabling Speedstep in the bios, and setting the speed switch xp to Max battery I get much lower heat, in cool temps here in Charleston (40-60 degrees F ambient temp) the cpu will idle at about 33-38 degrees Celsius (fan stays on low, about 1000 RPM - constant), and under load get up to about 45 degrees Celsius and I show no loss of performance that I can tell (except the choppy video that started this conversation). But If I switch to max performance on speed switch XP the temp will idle about 40-45 degrees Celsius and quickly rise above that under any load, just as it would without the program speed switch and the speedstep enabled in the bios screen.

So this has been the best solution for me to keep the temperature down, If you have any other advice, I would welcome it, and be willing to try it. What does your CPU typically run at (temperature) , at idle and under load?

So far I've had all the problems that have been common with the Inspiron 5150, except the charging problem (crossing my fingers!!) - The random shut off, b/c of a loose chip on the motherboard, was the worst!! - I'm amazed that my solution is still working!

Thanks

Brian

Share this post


Link to post
Share on other sites
LSudlow

I can sympathize - I've had the full range of 5150 problems and am on my fourth motherboard. One due to the instant shutoff issue and three due to the inability to charge the battery. This last time around the service guy put in a different type of heat sink and replaced the old aluminum cooling fins with copper ones. It's been running over a year now with no problems, so I'm keeping my fingers crossed.

I'm running much hotter than you are - around 52 Centigrade under light use and up around 63 under heavy use with the fan really cranking, so you're way ahead of me on heat control.

I thought disabling SpeedStep in the BIOS locked the CPU at half speed. If so, it would account for both your cooler temps and your lagging video. Are you sure SpeedSwitch overrides that and allows full throttle? (I assume you've checked this, but thought I'd ask to be sure.)

Share this post


Link to post
Share on other sites
Guest Arken

Hi Larry,

I had the same problem as mercurius with OpenGL programs such as Celestia and Blender. So I tried to change the different lines you mentioned, and found that changing the line

HKR,, Ogl_QualityEnhancements, %REG_BINARY%, 14,00,00,00

to :

HKR,, Ogl_QualityEnhancements, %REG_BINARY%, 00,00,00,00

make the textures fine again. I did not change the other parameters.

I don't have many other OpenGL programs to make further testing, but it seems to work fine with 169.28 inf.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...