Jump to content
LaptopVideo2Go Forums
LSudlow

Larry's INFs for Dell 5150/5160

Recommended Posts

kane81

Hi Larry,

I tried out the new drivers on Win 7

as you said with 98.16 - Windows Media Player works full and windows now! :)

However Window Media Centre windowed is fine - but full screen is JERKY!

Trying 169.72 on Win7 -

Windows Media Player and Windows Media Centre are jerky windowed - but full screen is smooth.

What were the direct3d tweaks?

Do you think it is possible to narrow what settings make MCE full screen smooth on 169.72 and incorperate that into 98.16?

Thanks

Share this post


Link to post
Share on other sites
LSudlow

Unfortunately, it's a fundamental difference between the driver versions. We badly need a newer Vista/W7 driver than 98.16.

You might want to try 97.14. The poster before you found it solved some of his problems. Just use my W7 inf and change the version line.

Share this post


Link to post
Share on other sites
kane81

Hi Larry,

In Win7 tried 97.15 and it still had the same issues with jerky MCE in full screen.

I then tried 96.86 (selecting Ti 4800) and MCE became smooth in full screen and windowed - however custom resolutions were not showing.

I played around more and seem to have broken something as 96.86 is jerky when windowed again...

Ill have a play around and see if I can replicate like what I did with Vista to get smooth MCE windowed and full sceen.

I copied you from 98.16 into 96.86

[nv_SoftwareDeviceSettings]

as attached, but it doesnt seem to work properly. - I get 8 bit color.

Could you help adapt this driver as MCE full screen for me is the most imporatant?

Thanks

nv4_disp_9686_Org.inf

nv4_disp_9686_Win7.inf

Share this post


Link to post
Share on other sites
LSudlow

Looking at that driver, I see it's really old and was designed for cards even older than our FX Go52000. I'm surprised it works, but since it did work once for you, let's see if we can do it again.

Here's a new inf for it - give it a try and let me know how it works. Remember to uninstall your present driver in the W7 Device Manager (not the Control Panel) before you install this. I suspect you've ended up with files from multiple driver versions and need to clean them out.

Once you've done that, give this one a try and see what happens. Good luck!

nv_9686_W7.inf

Share this post


Link to post
Share on other sites
kane81

^

Thanks - Didnt work - I had to replace

[sourceDisksFiles]

*.*

with the orginal

[sourceDisksFiles]

nv4_disp.dll = 3426

nv4_mini.sys = 3426

After doing that I then get 'Operation requires an interactive window station' :/

Share this post


Link to post
Share on other sites
kane81

edit: snip

no longer applicable

Edited by kane81

Share this post


Link to post
Share on other sites
LSudlow

Hi, Kane...

Yes, I remembered that workaround, which was excellent detective work on your part. The reason it doesn't enable Aero Glass is it's forcing installation from an inf that doesn't include any Kernal device or User device information. I'd like to figure out a way to do the same thing with a Vista driver, but I've had no success yet. (And, of course, I'd like to do it with a much newer driver than the 98 series!)

Thanks for your help with all of this!

Share this post


Link to post
Share on other sites
kane81

^ No thank you Larry - I still cant beleive you have a 5150! techs like you like to upgrade usually! Glad you still looking at this thread :)

Anyway Larry

I discovered that the hack fix works using the XP 16972 drivers :)

I however had to use the default inf in the zip as your 19672 inf caused the following problems

- Windows MCE is laggy in window mode

- Windows Media Player is laggy in window mode

- Max resolution was 1280x1024

Larry do you think you can "fix" the 16972 inf so the 3 major problems mentioned problems are fixed?

I'm happy to test.

Share this post


Link to post
Share on other sites
LSudlow

Not having MCE, I don't really have a way to figure out what's wrong. The easiest way to solve this would be if you could try commenting out various lines in my inf to see what's causing those lags.

I assume the problem is in the [nv_SoftwareDeviceSettings] section. I would start by commenting out (putting a semicolon in front of) all the D3D lines to see if it's one of those. If that's not it, try using Pieter's overlay settings instead of mine and see that's the problem. Those are the two most likely areas. (If you really need me to do those, I can - it's just faster to do it yourself.)

I'm very interested in solving this, so thanks!

Share this post


Link to post
Share on other sites
kane81

Thanks I will give commenting out the D3D lines a go and then pieter's overlay settings!

where can I find pieters overlay settings?

btw: MCE comes with windows 7 normally.

Edited by kane81

Share this post


Link to post
Share on other sites
LSudlow

I've just checked and Pieter and I use the same overlay lines, except for OverlayMode3. Here's the one he uses:

HKR,, OverlayMode3, %REG_BINARY%, 05,00,40,10

As an alternative, also try commenting the overlay lines out entirely.

My suspicion is that what you're seeing is due to the difference between hardware overlay and VMR. Video Machine Rendering is the newer technology, but is much more demanding of hardware and often causes our poor 5150 to lag and stutter. I default to hardware overlay in my overlay lines, but MCE may not like that for some reason. I'm pretty sure the drivers that work for you don't use any overlay settings, so commenting them out may be what you need.

Share this post


Link to post
Share on other sites
kane81

Yay!

Ok, no more hack work around - if you use this driver you get video and mce working nicely in full screen and windowed in Windows 7!

First remove old driver, then install this one.

I tested this on a clean install of Win7 RTM.

Note: Dual display is on once driver is insalled, so you proabaly want to turn off the secondary display.

Larry - see the sections marked with 'KLI' - basically I compared the two infs and added value in 98.16 that were not in your 16972 inf.

Keys that appeared to be casuing problems were commented out

;HKR,, DrvOptions, %REG_DWORD%, 1 --KLI Seemed to cause jerky video in window mode - not sure what value to set to if we use this, so it is just never set.

;HKR,, EnableDynamicEdidMode, %REG_DWORD%, 1 --KLI Caused resolution problems - ie 1280x800 was max res allowed on the 5150 screen

Cheers

Kane

BTW: No Aero of course with ths driver.

I also tried the regisrty settings in 98.16 but full screen mce was jerky

nv4_16972_win7.inf

Edited by kane81

Share this post


Link to post
Share on other sites
LSudlow

Excellent detective work, Kane! Here's a slightly different version that incorporates all your changes, adds a couple more D3D changes, moves your HKLM changes from the software settings section to the control panel section, and moves your OpenGL settings to the ICD settings section.

I've also attached an inf for 98.16 that incorporates those same changes, to see if we can get the same result and have Aero Glass too.

If you can verify that I haven't broken anything, I'll publish them. (The 169.72 inf should work equally well for both XP and Windows 7.)

Thanks!

EDIT: I've just updated this 98.16 Windows 7 inf. If anyone downloaded the previous version, please try this new one and see if it adds any control panel options. Thanks!

nv4_16972_W7.inf

nv_9816_W7.inf

Share this post


Link to post
Share on other sites
kane81

169.72 inf works as expected for MCE and Media Player :)

98.16 MCE is jerky in full screen, windowed is not. Media Player is fine in both windowed and full screen.

note: if I turn Aero on, MCE in full and windowed is jerky.

Control Panel works as before - under 'Display; there might be more options under 'Apperance'? Flat panel scale options are greyed though. but you just get '3D Settings' and 'Display' as before

Cheers

Share this post


Link to post
Share on other sites
LSudlow

Thanks, Kane - I'll publish these as our new baseline, and keep trying to improve the performance of 98.16.

I really appreciate your help!

:)

Share this post


Link to post
Share on other sites
LSudlow

September 5, 2009

- Thanks to some excellent detective work by kane81, we have better infs for driver 169.72 (which should work with XP, Vista, and Windows 7) and for driver 98.16 for Windows 7. The changes to 169.72 allow for smoother Windows 7 video, under both MCE and Media Player, though Aero Glass effects won't be available.

- I've incorporcated the same changes to the 98.16 Windows 7 inf. The benefit is less when you have Aero Glass enabled, but I hope there might still be some improvement.

- I've also tried to enable additional nVidia Control Panel options. I don't know if there's much difference, but maybe.

As always, please let me know if anything doesn't work correctly.

Share this post


Link to post
Share on other sites
Guest Paolo

Hi Larry,

I have a laptop exactly as yours (Inspiron 5150 with Geforce Go5200with 64 MB), with 750 MB of RAM and the original 40 GB HD (I think the HD it's kind of slow). I am still running Windodows XP and NVidia 67.42 drivers.

I can still work fairly well with the notebook, except for:

- Flash player which tends to clog the resources pretty quickly on Internet Explorer/Firefox (especially with a few tabs open)

- Playback of HD Video (720p as 1080p is downright unplayable) over VLC media player / Media Player Classic / ITunes is really difficult.

Do you think upgrading the video driver would improve the performance in the areas above? And in such case which version would you recommend? Bear in mind I do not play games.

Thanks in advance,

Paolo

Share this post


Link to post
Share on other sites
LSudlow

Hi, Paolo...

I highly recommend 169.72. I watch 720p video and it's (mostly) free of stutter. (1080p is too much for this laptop.)

The driver can be found at:

...and my modded inf can be found at the bottom of the first post in this thread.

Make sure you replace the original inf with mine. And make sure you first uninstall your current driver in the Windows Control Panel. When you reboot and Windows tries to install a new driver, tell it that you want to choose the driver and that you have a disk. Browse to the folder with the driver and the modded inf and you should be fine.

In your video player, always use Overlay mode, not VMR. VMR is the newer technology, but the Go5200 doesn't have enough horsepower to render it without stuttering and tearing.

Let me know if you have any trouble with it.

Share this post


Link to post
Share on other sites
Guest Guest

Hi, Paolo...

I highly recommend 169.72. I watch 720p video and it's (mostly) free of stutter. (1080p is too much for this laptop.)

The driver can be found at:

...and my modded inf can be found at the bottom of the first post in this thread.

Make sure you replace the original inf with mine. And make sure you first uninstall your current driver in the Windows Control Panel. When you reboot and Windows tries to install a new driver, tell it that you want to choose the driver and that you have a disk. Browse to the folder with the driver and the modded inf and you should be fine.

In your video player, always use Overlay mode, not VMR. VMR is the newer technology, but the Go5200 doesn't have enough horsepower to render it without stuttering and tearing.

Let me know if you have any trouble with it.

Share this post


Link to post
Share on other sites
LSudlow

Just installed the driver you suggested. I see some improvements; thanks a lot!

Thanks for letting me know. I'm glad it helped.

Share this post


Link to post
Share on other sites
Guest Paolo

Thanks for letting me know. I'm glad it helped.

Larry,

Everything seems to be working fine except for resuming activity from standby where I get a black display and I have to restart the computer.

Is there any workaround for this?

Share this post


Link to post
Share on other sites
LSudlow

Larry,

Everything seems to be working fine except for resuming activity from standby where I get a black display and I have to restart the computer.

Is there any workaround for this?

I have the same problem so I've set it to go into Hibernation instead of Standby. I have no idea why one works when the other doesn't, but hibernation works fine.

Share this post


Link to post
Share on other sites
mobilenvidia

I have issues with resuming from standby with the 190's and I get a very dim screen, like the Backlight refuses to turn on.

Don't get it with 187.66.

Still one of my favourite threads even after all these years, great work Larry, long live the i5150 :)

Share this post


Link to post
Share on other sites
LSudlow

Thanks, Pieter! It's been good, but I think it's nearing the end of it's era!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...