Jump to content
LaptopVideo2Go Forums

Black & White TV-Out


MTaylor40

Recommended Posts

Hi,

I'm just wondering if anyone can help me and hopefully tell me what I'm doing wrong.

When I connect a TV to the TV-Out on my laptop it only displays in Black and White. This never used to happen witht he original driver, but that was something in the v4 series and was a bit out of date. I updated my driver to version 6.6.2.9 and everything still worked fine, but every so often i could only get black and white output to a TV.

I've now updated my graphics driver to version 8.1.4.0 and my TV-Out now only displays in Black & White all of the time.

I've tried alot of drivers from this site and most of the ones that worked fine on my laptop had problems with the TV out, only the 66.29 driver worked, and it still had intermitted problems with the colour.

If I connect a 2nd monitor to my laptop via the D-Sub it works perfectly fine with full colour. Most of the other drivers that I tried between this one and the 66.29 had the same problem with the colour on both TV and 2nd Monitor.

Can someone please help me as I cant afford to upgrade my TV to a LCD/Plasma with the D-Sub input lol.

Thanks alot and keep up the good work with these drivers!!!

M_Taylor40

Link to comment
Share on other sites

You aren't alone but, unfortunately, we've never been able to figure out why this happens. It seems to be machine-specific, with some machines failing while identical ones work fine. It may well be due to variations in the TV output chip.

My only advice is to keep trying different drivers until you find one that works. A good place to start might be with one of the MCE drivers like 72.14. Those should be compatible with a wide variety of TV output chips.

Also, some people have reported success by trying different cables, so that's another possiblity.

Link to comment
Share on other sites

Edit the INF and zip down to [Mobile_Tweaks].

Add below here this line:

HKR,, DisableTVClockInversion,      %REG_DWORD%,    1

This is supposed to stop the TV clock from inverting on Chrotel TV encoders, I'm hoping that this will fix that problem.

Get back to us with your results, I can add it to INFs from here on if it works :)

Link to comment
Share on other sites

I've fixed it!!!

For some reason the saturation setting was set as low as it could be, so ive set that and I now get beautiful colour!

But as with computers, you fix one problem and you find another straight after! My laptop now doesn't display video playback, I get the sound from the movies but no video.

Well, I'll have a go at that now, but from what I know thats a driver issue, but at least I know how to fix the TV-Out colour problems. I'll post instructions on what to do as soon as I have time, but on with the next problem!

Link to comment
Share on other sites

Congrats on that fix! I'm embarassed to admit that another person reported the same fix a while ago and I completely forgot it. We need to create a FAQ about this.

The black video is just as easy to fix: Just go into the Overlay Settings and enable VMR. (You may also need to enable VMR in whatever video player you use.)

Link to comment
Share on other sites

Lol, yeah ive fixed that as well now, I found it on another post and just done it and its working fine now.

and BF2 looks great now to what it looked like with the old 4series drivers lol, the buildings look, well like buildings and not big grey boxes!

Thank you both for your help! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...