Jump to content
LaptopVideo2Go Forums

What's the latest news on the 5600Go problem?


exorcism

Recommended Posts

I'm trying to find the right drivers for my laptop and my sister's. I have a GeForce 420 Go 32mb and she has a GeForce Go5600 64mb. I am running the latest from Compaq (I have an r3000) which are 72.30 and work quite well. However, for her laptop, Sony (she has a Vaio) has not updated the drivers since something like 43.90 and don't work with most modern games. I installed the latest DNA forceware drivers from guru3d.com and all the game run horribly slow now. I found this forum and read a little about the problem here but the thread is much too long to find the latest resolutions for this problem. What is the concensus for the problem? Seems 53.77 is the sweet spot (and update, I installed those and it didn't seem to make much difference. Are there different varieties of the 53.77 drivers?)

Also, it seems that all of the release 80 drivers I've tried (which are the only ones I've tried that weren't official drivers from the manufacturer) don't have proper powermizer support. The sliders are missing and they seem to default to "maximum power savings" which must be very slow (assuming it's working at all.) Did they remove the proper support for this in release 80, or is it just bugged in modified drivers?

Thanks

Edited by exorcism
Link to comment
Share on other sites

For the Vaio try driver 67.66. It's a fast driver that supports all but the most recent games (which are probably too much for that machine anyway). If it still runs slow, uninstall the driver via the Windows Control Panel's Add/Remove Programs. to clear out the old driver junk, then reinstall the new driver.

For the PowerMizer problem, we're waiting for a new nvidia control panel to provide FX support. Until then, all you can do is disable PowerMizer and lock your clock at the normal speed. In the [nv_SoftwareDeviceSettings] section of your inf, add or modify the following lines:

HKR,, PowerMizerEnable, %REG_DWORD%, 0

HKR,, PowerMizerLevel, %REG_BINARY%, 01,00,00,00

HKR,, PowerMizerLevelAC, %REG_BINARY%, 01,00,00,00

...then reinstall.

Be aware that the graphics chip will still be at full speed even when you're running on batteries. But in my experience it doesn't shorten the time you can run on batteries all that much.

Link to comment
Share on other sites

Interesting. So you're saying that PowerMizer support doesn't work for FX chips at all, or just newer release 80 drivers? As in, do I need to do this trick for the drivers you just mentioned?

I'll try those drivers as well.

Thanks a lot!

Link to comment
Share on other sites

With 67.66 you don't need the trick. PowerMizer works fine on the FX chips with all drivers up to, and including, 72.14. ...With drivers more recent than 72.14 it's hit or miss. Some people have reported that PowerMizer work for them, but many have the same problem as you.

Link to comment
Share on other sites

Using 73.40 - PowerMizer works nice on my FX5600.

Link to comment
Share on other sites

Using 73.40 - PowerMizer works nice on my FX5600.

Yes, I wish we could figure out why some cards work and others don't. It's a mystery.

:)

Link to comment
Share on other sites

  • 2 weeks later...
For the Vaio try driver 67.66. It's a fast driver that supports all but the most recent games (which are probably too much for that machine anyway). If it still runs slow, uninstall the driver via the Windows Control Panel's Add/Remove Programs. to clear out the old driver junk, then reinstall the new driver.

For the PowerMizer problem, we're waiting for a new nvidia control panel to provide FX support. Until then, all you can do is disable PowerMizer and lock your clock at the normal speed. In the [nv_SoftwareDeviceSettings] section of your inf, add or modify the following lines:

HKR,, PowerMizerEnable, %REG_DWORD%, 0

HKR,, PowerMizerLevel, %REG_BINARY%, 01,00,00,00

HKR,, PowerMizerLevelAC, %REG_BINARY%, 01,00,00,00

...then reinstall.

Be aware that the graphics chip will still be at full speed even when you're running on batteries. But in my experience it doesn't shorten the time you can run on batteries all that much.

Is it absolutely necessary to put these in the INF and reinstall, or can I just insert them directly into the registry?

Link to comment
Share on other sites

You can put those lines in the registry if you can find the right location. You should find several adapters listed under HKLM\System\CurrentControlSet\Control\Video. Go through them all until you find the one (or more) with all the nvidia settings and add those lines to both the 0000 and 0001 keys.

Reinstalling the driver is faster since you don't have to uninstall first.

Link to comment
Share on other sites

Okay thanks.

I'm going to mod the inf file, but where in the inf file should I put these settings?

I'm thinking [nv_SoftwareDeviceSettings]

Link to comment
Share on other sites

Yes, that's right. Some of those lines may already be there with different settings at the end. If so, delete them and use these.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...