Jump to content
LaptopVideo2Go Forums

World of Warcraft issues


RoomTemp

Recommended Posts

I play World of Warcraft on my gateway m500 laptop. I have 1 gig of ram and a 2.2 ghz processor. Video card is an Nvidia GeFroce4 420 go. I have always had flickering graphics. With a new patch that was released, the flickering got worse. I can't even read the user-end agreement (the first screen that you see). I have tried downloading the forceware 72.14 driver, along with several others and none of them seem to work.

With the 72.14 driver installed I get a message when I try to open WoW, it says:

"World of Warcraft was unable to start up 3D acceleration. Please make sure DirectX 9.0c is installed and your video drivers are up-to-date."

If anyone knows of any steps I could try to fix this issue, you would save my WoW account from being cancelled. Please let me know.

Link to comment
Share on other sites

What are these other drivers you have tried?

Click the driver recommend link in my sig, read the links in it if you need, and try the 81.98 driver with Pieter's mod INF for it.

Also go onto windows update and make sure you have DX9.

Next hit start>run>dxdiag and go to the display tab and check to see the stuff is enabled and run the 3 tests.

If anything looks fishy you could post a pic of the window.

Just so you know with a modded INF the driver will not be digitally signed, we don't care about that.

Link to comment
Share on other sites

I downloaded the drivers you told me to and they seemed to work fine. I ran the direct x test the only 1 out of the 3 direct draw tests passed.

Link to comment
Share on other sites

Only 1 out of 3 tests passed?

That sounds like the problem.

Under the DX files tab does it say there are any problems?

You should go ahead and install DX9.0c again.

http://www.microsoft.com/downloads/details...&displaylang=en

Does your screen flicker while running other games?

Could try some demos or other games, like Unreal Tournament 2004, do other recent games like Doom3 or HL2 work?

One of those should have a demo, and they ran just fine on my 440 go (not using anymore, but had one in this)

If you have some other games can go ahead and tell me if those work.

If a DX test like that doesnt pass it sounds to me like it could be a problem with your gf card. (or just DX or drivers)

Link to comment
Share on other sites

The DX Files tab says that there is no problem. I downloaded the latest release of DirectX (Feb 2006). I have played Morrowind on this computer and it works fine. WoW used to run a lot better before they released a major patch. I guess the main problem with this laptop is that gateway for some reason or another does not have drivers dated newer than like 2002. They offer virtually no support for my system anymore. I have been trying to update my chipset driver also and I can't seem to find a correct one.

Link to comment
Share on other sites

If I roll back my driver to the one that Gateway gives me on their site (6.13.10.3220) All of the dxdiag tests pass.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...