Jump to content
LaptopVideo2Go Forums

Brightness Problems: SONY VGN-S4XP & VGN-S5XP (Go 6400) & VGN-S4M & VGN-S560P (Go 6400) & Sony VAIO FZ11Z (Geforce 8400M GT) & FZ15 & FE31


Guest Bomfunk

Recommended Posts

Guest Bomfunk

Hello,

I own a Sony Vaio S5XP with Geforce 6400 graphics. I've tried drivers from the 83 and 84 series (83.40, 84.12). Both installed fine but I found I couldn't change the display brightness using my Fn button anymore. I just press the button and the usual bar graph shows up on the display but nothing happens. When I reverted back to the original Sony drivers everything worked fine again.

Has anyone else had this problem or know a possible solution?

Thanks in advance,

Bomfunk

Link to comment
Share on other sites

Guest Guest

Enabling SmartDimmer worked for me. See here

Add the following to the Mobile_Tweaks section of the modded INF before installing

;Smart Dimmer Controls
HKR,, EnableBrightnessControl, %REG_DWORD%, 1
HKR,, PanelPWMFrequency, %REG_DWORD%, 200
HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32

Link to comment
Share on other sites

  • 2 months later...

Hi Guys,

I have just found this website and implemented the fantasticfix you guys have made. This is amazing!

I have one slight glitch, my function keys no longer work, is there any way to get round this?

Thanks in advance.

Link to comment
Share on other sites

Sorry to trouble you guys, with some more extensive searching, I've found how to fix this.

Regards

Link to comment
Share on other sites

fantasticfix?

What is the solution for your working function keys?

You posted... so now youre trapped by sharing your solution and providing answers for everybody's joy

Link to comment
Share on other sites

Guest Guest

I found the solution here: http://forums.laptopvideo2go.com/index.php?showtopic=8912

Enabling SmartDimmer worked for me.

Add the following to the Mobile_Tweaks section of the modded INF before installing

CODE

;Smart Dimmer Controls

HKR,, EnableBrightnessControl, %REG_DWORD%, 1

HKR,, PanelPWMFrequency, %REG_DWORD%, 200

HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32"

I realised these were just registry keys, so I found them and enabd them.

Link to comment
Share on other sites

  • 2 months later...
Guest Ducky

Hey,

Ive tried to install some new drivers for my laptop since I cant play any games with the ones that comes with sony because of the BSOD.

Installed driver 87.25 and can finally play games however I cant now change the brightness level in the power options neither can I cange it on the Fn function on my keyboard.

I searched the forum and found out that I needed to add:

;Smart Dimmer Controls

HKR,, EnableBrightnessControl, %REG_DWORD%, 1

HKR,, PanelPWMFrequency, %REG_DWORD%, 200

HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32

In the [Mobile_Tweaks] part of the .ini file.

To the ini then reinstall, I did this but it still isnt working...

Any ideas please? :)

Forgot to add Im using the modded inf.

Edited by ®®®
Link to comment
Share on other sites

I Can't help you, but it's strange the originals aren't working....

What Sony do you have ? I have an VAIO FE, and the originals (84.73) are just working fine...

Link to comment
Share on other sites

  • 4 months later...

Laptop Make/Model

Sony Vaio VGN-S560P

Graphics Card -- device id if known

GeForce Go 6400

Current Driver Version

87.25

Last Useable Driver Version

77.xx (Was the factory loaded driver, this is second driver i've tried, earlier today i installed version 93.71 which worked without erros but also prevented adjustments to screen brightness)

Operating System

Windows XP Pro SP2

An accurate description of the issue at hand

I have succesfully installed the driver version 87.25 with modded inf to get it working. Everything loads up perfectly, no funny lines or errors/bsod etc. HOWEVER i can no longer adjust the display brightness using either the function keys or the vaio power management utility. I couldn't find any options or facility for adjusting screen brightness in the nvidia display control panel. The computer boots up with brightness set to full and stays that way when running on battery regardless of what i tell it to do using the power management profiles. The FN keys i normally use to adjust the brightness do not work and the slider seems stuck on full, not changing when i try to decrease the brightness.

I have poked around these forums but havent found a solution to this... I'd most appriciate any tips or feedback from someone who's had this sort of problem or knows how to fix it...

Thanks much!

Edited by Rohan
Link to comment
Share on other sites

I did find the potential fix to this but I had no luck with it on my computer:

Add the following to the Mobile_Tweaks section of the modded INF before installing

;Smart Dimmer Controls
HKR,, EnableBrightnessControl, %REG_DWORD%, 1
HKR,, PanelPWMFrequency, %REG_DWORD%, 200
HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32"

What should I do?

Link to comment
Share on other sites

  • 6 months later...
Guest forcifer

Try updating/installing/re-installing sony event services. That's the program that is responsible for the Fn key functions. You can find the program at sony support. I hope this is the solution to your issue.

Link to comment
Share on other sites

  • 2 weeks later...
Guest alfVR

I had the same problem with a Sony VAIO VGN-S4XP

I copied the following lines from the original SONY nv4_disp.inf into the section

[Mobile_Tweaks] of the new .inf:

[Mobile_Tweaks]

HKR,, EnableBrightnessControl, %REG_DWORD%, 1

HKR,, PanelPWMFrequency, %REG_DWORD%, 200

HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32

HKR,, Panel00, %REG_SZ%, ",MS_,,0003"

HKR,, Panel01, %REG_SZ%, ",MS_,,0003"

HKR,, Panel02, %REG_SZ%, ",MS_,,0005"

HKR,, Panel03, %REG_SZ%, ",MS_,,001C"

HKR,, Panel08, %REG_SZ%, ",MS_,,0040"

HKR,, Panel09, %REG_SZ%, ",MS_,,004A"

HKR,, Panel0A, %REG_SZ%, ",MS_,,0040"

HKR,, Panel0B, %REG_SZ%, ",MS_,,001C"

HKR,, Panel0C, %REG_SZ%, ",MS_,,0006"

HKR,, Panel0D, %REG_SZ%, ",MS_,,0040"

HKR,, Panel0E, %REG_SZ%, ",MS_,,004A"

It worked for me, give it a try and post the results.

regards,

A.L.F.

Link to comment
Share on other sites

Hello!

I´ve bought an Sony Vaio FZ11Z Notebook. It has got an integrated Geforce 8400M GT Graphics Card. I´ve switched over to Windows XP because it fits better to my needs. But if i try the FN Keys on the Keyboard (especially for adjusting the brightness of the Display and Switching to an external device such as a beamer) they won´t work. In Vista they´re working fine.

I´ve read in several forums that the nvidia graphics driver handles the function of the FN keys. But i haven´t figured out how to turn them on. I´ve installed the 162.15 XP driver with an modded.inf but without a success. After this I appended to my nv4_disp.inf several changes (from a german forum) and installed the driver again. Unfortunately without a change too. In the Attachment you´ll find the modded.inf i used in my last attempt.

Thanks for your help in advance

with best regards

THINK

nv4_disp.inf

Link to comment
Share on other sites

Guest Guest

Hi think,

Could you please tell me where did you find the drivers for xp sp2?

I have also purchased a fz11z the other day, but I can't install any of the drivers on winxp. I have copied the /drivers/ directory from the vista installation, but they will not install.

Right now I am trying to download driver kits from previous Vaio series (FS at the moment) and hope that I find a version/model that has the same hardware with fz11z.

Link to comment
Share on other sites

Guest rgoggy

as far as i know you need to install vaio event service that fn keys work

if this is only aviable for vista for your notebook just select an older fe at vaio-link.com

Link to comment
Share on other sites

i already have installed the event service - but from the vista utilities package from the sony vaio fe41z.

I will try it with the fe31 xp utilities event service.

I´ll give a reply after my attempt.

Big thanks for the suggestion!

Link to comment
Share on other sites

A complete Windows reinstall with Sony FE31 utilities didn´t solve the Problem :-(

Link to comment
Share on other sites

  • 3 weeks later...

Hello!

I've bought another FZ series (FZ15 model), i managed to remove the Vista and get the Win XP working but not the fn key. As far as i can go is the fn + F2 (muting) but not the brightness or display switching. But i realise that this two function can be control by the nvidia control panel (software control) so i just make do with it until some better solution surface.

Link to comment
Share on other sites

  • 2 months later...

Hi all, how are you??

I have a VAIO VGG-SZ430N/B, and I'm experiencing the same problem with brightness control after installing Nvidia laptop2go drivers version 163.71 for windows xp 32bit.

I've installed windows xp sp2 on this notebook, and brightness control keys works fine only with Sony original drivers for windows xp.

I've being trying to solve this issue with all the solutions posted here described bellow:

[Mobile_Tweaks]
;Smart Dimmer Controls
HKR,, EnableBrightnessControl, %REG_DWORD%, 1
HKR,, PanelPWMFrequency, %REG_DWORD%, 200
HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32"

   [Mobile_Tweaks]
   HKR,, EnableBrightnessControl, %REG_DWORD%, 1
   HKR,, PanelPWMFrequency, %REG_DWORD%, 200
   HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32
   HKR,, Panel00, %REG_SZ%, ",MS_,,0003"
   HKR,, Panel01, %REG_SZ%, ",MS_,,0003"
   HKR,, Panel02, %REG_SZ%, ",MS_,,0005"
   HKR,, Panel03, %REG_SZ%, ",MS_,,001C"
   HKR,, Panel08, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel09, %REG_SZ%, ",MS_,,004A"
   HKR,, Panel0A, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel0B, %REG_SZ%, ",MS_,,001C"
   HKR,, Panel0C, %REG_SZ%, ",MS_,,0006"
   HKR,, Panel0D, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel0E, %REG_SZ%, ",MS_,,004A"

   [Mobile_Tweaks]
   HKR,, EnableBrightnessControl, %REG_DWORD%, 1
   HKR,, PanelPWMFrequency, %REG_DWORD%, 200
   HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32
   HKR,, Panel00, %REG_SZ%, ",MS_,,0003"
   HKR,, Panel01, %REG_SZ%, ",MS_,,0003"
   HKR,, Panel02, %REG_SZ%, ",MS_,,0005"
   HKR,, Panel03, %REG_SZ%, ",MS_,,001C"
   HKR,, Panel08, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel09, %REG_SZ%, ",MS_,,004A"
   HKR,, Panel0A, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel0B, %REG_SZ%, ",MS_,,001C"
   HKR,, Panel0C, %REG_SZ%, ",MS_,,0006"
   HKR,, Panel0D, %REG_SZ%, ",MS_,,0040"
   HKR,, Panel0E, %REG_SZ%, ",MS_,,004A"
  ;Smart Dimmer Controls
  HKR,, EnableBrightnessControl, %REG_DWORD%, 1
  HKR,, PanelPWMFrequency, %REG_DWORD%, 200
  HKR,, PanelBrightnessLimits, %REG_DWORD%, 0x0000FF32"

However, none of those solutions worked for me, and installing Sony Events service application haven't solved the problem either (may be because the previous solutions only works with windows vista).

Please, May someone help me with this issue??

I appreciate any help you can give me,

thanks in advance,

Roger

Link to comment
Share on other sites

It's weird but one of our members (sorry buddy forgot your name) tried to disable EnableBrightnessControl from the INF (set it to 0 or comment it out ) and he reports it works.

Link to comment
Share on other sites

Hi,

I have the same issue with my Sony vgn AR41L, 8400M GT

The weird thing is I can not install my factory drivers.... all other drivers are a go but not the ones from my recovery dvd nor those from the sony supportsite.

I was looking at the original inf and saw this part.

[nv_FAEIDS_Default_AddReg]

HKR,, OverrideEdidFlags0, %REG_BINARY%, 7C,00,40,00,00,00,FF,FF,04,00,00,00,08,02,36,7F

HKR,, EnableBrightnessControl, %REG_DWORD%, 2

HKR,, Panel00, %REG_SZ%, ",MS_,,0040"

HKR,, Panel01, %REG_SZ%, ",MS_,,0040"

HKR,, Panel02, %REG_SZ%, ",MS_,,0040"

HKR,, Panel03, %REG_SZ%, ",MS_,,0040"

HKR,, Panel04, %REG_SZ%, ",MS_,,0040"

HKR,, Panel05, %REG_SZ%, ",MS_,,0040"

HKR,, Panel06, %REG_SZ%, ",MS_,,0040"

HKR,, Panel07, %REG_SZ%, ",MS_,,0040"

HKR,, Panel08, %REG_SZ%, ",MS_,,0040"

HKR,, Panel09, %REG_SZ%, ",MS_,,0040"

HKR,, Panel0A, %REG_SZ%, ",MS_,,0040"

HKR,, Panel0B, %REG_SZ%, ",MS_,,0040"

HKR,, Panel0C, %REG_SZ%, ",MS_,,004A"

HKR,, Panel0D, %REG_SZ%, ",MS_,,004A"

HKR,, Panel0E, %REG_SZ%, ",MS_,,004A"

[nv_FAEIDS_MS0040_AddReg]

HKR,, OverrideEdidFlags0, %REG_BINARY%, 7C,00,40,00,00,00,FF,FF,04,00,00,00,08,02,36,7F

HKR,, EnableBrightnessControl, %REG_DWORD%, 2

HKR,, Panel01, %REG_SZ%, ",MS_,,0040"

HKR,, Panel02, %REG_SZ%, ",MS_,,0040"

HKR,, Panel04, %REG_SZ%, ",MS_,,0040"

HKR,, Panel05, %REG_SZ%, ",MS_,,0040"

[nv_FAEIDS_MS0045_AddReg]

HKR,, OverrideEdidFlags0, %REG_BINARY%, 7C,00,45,00,00,00,FF,FF,04,00,00,00,08,02,36,7F

HKR,, EnableBrightnessControl, %REG_DWORD%, 2

HKR,, Panel01, %REG_SZ%, ",MS_,,0045"

HKR,, Panel02, %REG_SZ%, ",MS_,,0045"

Is it safe to try and add this to the modded inf of the latest drivers ?

Or am I gonna mess up my system ?

Greetz,

Link to comment
Share on other sites

EnableBrightnessControl 2 ??? Has anybody tried this?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...