Jump to content
LaptopVideo2Go Forums

Much newer Atheros drivers

Guest nonegiven

Recommended Posts

  • 5 weeks later...

Same drivers with English help and utility:

Go to Fujitsu US

Click on Support on the top navigation bar (red colored stripe).

On the "Support Overview" page, click on the "More Info" button next to "Notebook, Tablet, and Desktop Support".

On the "Support" page click on "Downloads".

On the Downloads Search section, searching "By Model" (default option), choose "Notebook PC" under "Select Product", "E Series" under "Select Series" and "E8010D" under "Select Model" and press the arrow button next to the "Go" text label.

On the results page shown, scroll down to find WLAN Atheros with V4.2.2.14 in the "Version" column.

* The method is elaborated rather than providing a mere direct link for future reference purposes.

* This method should work searching for any Fuijitsu laptop model with included Atheros WiFi card. This particular model happens to be the only one I know for sure it has it.

Link to comment
Share on other sites

Thanks for the info & detailed description.

Link to comment
Share on other sites

Well... in my vast ignorance I just found something about this set of drivers that puzzles me big time.

First, installation procedure (and I have the feeling that was the wrong one):

I decompressed the contents of the "WLAN_ATHEROS_V4.2.2.14_XP.EXE" file to a temporary folder and installed it WITHOUT using any of the answer files provided in the DATA3.CAB folder.

This would install the utility np... for the driver I had to use a modified .inf and it also installed np.

Now, with this alone the utility just wouldn't work. It would see no networks in the "Scan" section and it wouldn't connect to my WLAN adding manually it's profile.

With a bit of investigation I realized that it would fail to start the service "ACS" automatically. Once corrected this little glitch it worked np.

Now, the thing that really puzzles me... I opened the cab files to "have a ramage inside" (I used ZipScan for this purpose, but I guess any program that can decompress Installshield .cab files would do.

First thing, and is not the first .cab's where I see this, there are several different entries for each file, with no "path", just hanging from the root... (if you extract the contents it will ask you over and over if you want to overwrite the existing file upon decompression)

I don't know if this is a glitch of the software (ZipScan) that can't deal with these particular files properly or what... An educated guess would be these "repeated" entries being actually localized versions of the files, and IS being able to extract the ones that match the localization of the OS...

Second, when you install the software, the version of it is well, the files inside the .cab (all of them, executables, dll's...) are

I have manually extracted these overwriting the installed version, and they effectively read

Moreso there's no files with version inside the .cab's, and the file sizes of the installed and the extracted files don't match.

Now... does the installer do some kind of patching of the files during the installation or I'm losing the plot here?

Edited by MrT0ad
Link to comment
Share on other sites

I would rather and simply guess that this a mis-compressed and messed up driver package, which is not a rare circumstance in these days. People do errors, so do we.

Just wait for the next release :)

Link to comment
Share on other sites

Another distribution of the same driver but this time by Unex Technology.

The driver comes with a generic .inf file that will suit loads of models without having to "hack" it.

The driver file (ar5211.sys) is exactly the same as in the Fujitsu compilation, bit by bit.

The utility (ACU.exe) reports itself as the same version compiled and distributed by Fujitsu (, but CRCs don't match and hex comparison shows many differencies.

The supplicant (ACS.exe) is exactly the same as in the Fujitsu compilation, bit by bit.

Various libraries show differencies, but this should be expected as I guess they must match any "customization" done in the utility.

Tried in my network cards (TP-Link TL-WN650G and GigaByte GN-WI01HT) and it works ok.

As usual no changelog provided and no differencies noticed so far. I sometimes wonder why bother :)

INEXQ (UNEX) ftp site

You will see it hanging from Drivers folder


There's yet another distribution there for their CM9 cards, same driver version, slightly different in size, haven't explored that one yet.

Note: After all this blindly trying new drivers I've rolled back to version. I found that transferring large files over the WLAN with the and was somewhat "unreliable".

Edited by MrT0ad
Link to comment
Share on other sites

Hey thanks for the report, we Atheros Users appreciate it.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Download v4.2.2.27 driver only (no ACU) HERE (~260kb).

INF is dated 2006-07-17 and files have version number v4.2.2.27.

sn0wl should we merge this one with the generic Atheros driver thread, so people find all info in one thread?

Link to comment
Share on other sites

  • 5 months later...

Hi, I wish you help me, i have a Acer Aspire 5040 with an atheros AR5BMB5, i have installed de drivers form the site of Acer, from de Fujitsu, an others you posted here, bur none works,

in Windows XP Pro, in Device Manager appears the atheros wireless network adapter fine, i mean , its recognized, but i cant turn it on, the buttons infront of the laptop doest not work.

i dont know wath to do anymore. please if some have a solution.

Im from Mexico, so my english is not perfect sorry. :)

Thanks on advance. :)

Link to comment
Share on other sites

Run the NERD tool (see my signature) to exactly determine what DEV_ID, name etc. is used for the WLAN module in your ACER laptop. This will bring you to the next step of choosing the correct driver (INF) supporting this device.

Link to comment
Share on other sites


Name Atheros AR5005G Wireless Network Adapter

Driver Installer form c:Windows\inf\oem0.inf (ATHER_DEV_001A.ndi). 1 file used by driver:


thats the result of the LogFile of Nerd.

...so what does that tell me?......

shoul i examine the inf file looking for something?


Link to comment
Share on other sites

From your post i understand that the driver is installed correctly?! So only the buttons in front doesn't work, which might be solved by finding the correct FN+F key combination... which is stated in your laptop manual or by examining the blue/orange/yellow secondary F key icons (should be an WiFi icon). Try pressing for example (some DELLs) FN + F2 which turns off/on WiFi, but be patient as it might take in some occasions about 5 seconds until the WiFi is enabled.

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...