Jump to content


Photo
- - - - -

Having trouble with nvidia's drivers


  • Please log in to reply
1 reply to this topic

#1 psyddicus

psyddicus

    Beginner

  • Members
  • 1 posts
  • Country:United States

  • Brand:Alienware
  • Model:Area 51-m 766
  • Resolution:1680x1050 (WSXGA+)
  • Video Card:(031A) GeForce FX Go 5600
  • Operating System:Linux (Debian)

Posted 12 February 2007 - 12:02 AM

I've installed the nvidia drivers for linux on my desktop computer countless times, and I've never run into a problem like this. Hopefully someone around here will be able to shed some light as to what in the world's going on on my end.

The laptop is an Alienware Area-51m 766 and the video card is a GeForce Go5600. Since the drivers come with their own script for bulding and installing, that part goes off without a hitch every time. But when I try to use the driver by modifying my xorg.conf file to use "nvidia" driver instead of "nv" my screen goes goofy every time I start x. I took a picture with my camera, it's not a great picture but it'll give you the idea. The image is here.

Can anyone give me some information as to what's going on here? It's not limited to the latest nvidia drivers, but every other one I've tried. I'd use the nv driver in the meantime, but it actually crashes if I'm using x for more than a moment or so. So for now I'm stuck using the vesa driver, which doesn't support the 1680x1050 resolution I want or any resolution for that matter, so it looks pretty crappy compared to what I'm used to.

Update: I finally came across a fix. I have the situation all cleared up by adding the following to my device section of xorg.conf.
Option "ModeValidation" "NoVertRefreshCheck"

Edited by psyddicus, 12 February 2007 - 04:39 PM.


#2 wolvorine4424

wolvorine4424

    Novice

  • Members
  • Pip
  • 20 posts
  • Country:United States

  • Brand:Dell
  • Model:XPS M1710
  • Resolution:1920x1200 (WUXGA)
  • Video Card:NVIDIA Card N/A
  • SUBSYS:019B1028
  • Operating System:Vista Ultimate x86

Posted 12 February 2007 - 10:23 PM

What driver package did you install???

I use "nvidia-glx" and it works awesome... I'm on Kubuntu v6.10

If this will not work try "nvidia-glx-legacy"

After that i typed in Konsole "sudo nvidia-xconfig", not sure what command is for your perticular build... then restart X server (CTRL + ALT + BACKSPACE)


Hope this helps.