Jump to content


Photo
- - - - -

Compal FL90 BIOS


  • Please log in to reply
74 replies to this topic

#41 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 06 November 2008 - 06:06 PM

Some guy that work on BIOS for Compal send it to someone, & that person distribute it on rapidshare. AFAIK this BIOS is not final release so yes, VT may not work as it should & yes, DEP is enabled.

Yes it should work fine with JFL92.

#42 Guilherme Françoso

Guilherme Françoso

    Beginner

  • Members
  • 8 posts
  • Country:Brazil

  • Brand:Other or Custombuild
  • Model:JFL92
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:Win7 Ultimate x64

Posted 06 November 2008 - 07:34 PM

Thanks for you answer... Is great to know that someone keeps improving tho XFL9X... It is a great machine.
So... Is there any predictions about on when this BIOS is going to be released? Hope it gets ready soon...

#43 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 09 November 2008 - 05:54 AM

Noone knows it :)

#44 blueicePT

blueicePT

    Beginner

  • Members
  • 3 posts
  • Country:Portugal

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:Nothing Selected
  • Video Card:NVIDIA Card N/A
  • Operating System:Nothing Selected

Posted 23 November 2008 - 10:34 AM

I'm new in this..
If i update my compal FL90 Bios to v1.19, what diference that will make in my laptop?

#45 DarkKiller

DarkKiller

    Beginner

  • Members
  • 1 posts
  • Country:Denmark

  • Brand:Zepto
  • Model:Znote 3415W Pro
  • Resolution:Nothing Selected
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:XP Pro SP3

Posted 26 November 2008 - 06:52 AM

Nice :) Does 1.19 have any particular bugs I should know of? I would much rather have a stable BIOS than something alpha/prerelease/unstable.

#46 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 26 November 2008 - 06:33 PM

AFAIK there is some problem with VT with this BIOS (ppl say that is working very slow on 1.19), so i think most stable is 1.18.

@blueicePT: it depend from what version You will ugprade, every release got changelog that You may find in the BIOS .zip file downloaded from compal webiste.

#47 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 29 November 2008 - 09:01 PM

I've flashed my bios to 1.18 but now my computer wont fully boot. when it gets to the windows bootscreen, the green bar doesnt even move, then a bluee screen appears and then it reboots. Did i brick it? is there any way to recover?

#48 Tomcheck

Tomcheck

    Novice

  • Members
  • Pip
  • 43 posts
  • Country:Germany

  • Brand:Other or Custombuild
  • Model:Compal IFL 90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:Vista Business N

Posted 30 November 2008 - 04:46 AM

that problem was already discussed in this thread. (http://forums.laptop...indpost&p=89001)
Just disable "AHCI" in your BIOS menu under "Advanced".

#49 Guest_Del4ev_*

Guest_Del4ev_*
  • Guests

Posted 30 November 2008 - 08:57 PM

Hi all
i has a problem to update bios (Ver 1.03A) on my JFT00

First of all, i cant find this model on official site, but IFT00 should be same (i believe) 12", intel 965 chipset

When i trying update bios i always get error "COULD NOT FIND BCP DMI block in bios rom" or (if i remove /mode=3 from command line) it just halt.

i have no idea what to do. Help please

#50 Guest_Del4ev_*

Guest_Del4ev_*
  • Guests

Posted 02 December 2008 - 03:40 AM

Ooo sorry , i solve my problem. IFT00 not the same JFT00!
JFT00 has InsydeH20 bios, but i was tryid update Phoenix bios. Thanks god, this not damage my laptop.

But it very strange, that JFT00 is in products on official site, but is`t in dowload/bios.

#51 Guilherme Françoso

Guilherme Françoso

    Beginner

  • Members
  • 8 posts
  • Country:Brazil

  • Brand:Other or Custombuild
  • Model:JFL92
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:Win7 Ultimate x64

Posted 05 December 2008 - 07:36 AM

Hey guys...

Any new releases? I was wondering if you had any success about eneabling VT and DEP...

#52 Guest_Blib_*

Guest_Blib_*
  • Guests

Posted 15 December 2008 - 03:19 PM

I LOVE you! :)

I've been having a pure nightmare here with no end in sight trying to get the BIOS flashed. This just worked, no stress. You are doing the internet a huge favour here :)

#53 Beertaker

Beertaker

    Novice

  • Members
  • Pip
  • 12 posts
  • Country:Netherlands

  • Brand:Other or Custombuild
  • Model:Compal IFL 90
  • Resolution:1440x900 (WXGA/WXGA+/WSXGA)
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:XP Pro SP3

Posted 18 December 2008 - 02:00 PM

Wow lol nicely done. I was searching for newer BIOS, but this is even better because I didn't know how to install, tnx.

#54 Guest_bono_*

Guest_bono_*
  • Guests

Posted 24 January 2009 - 07:22 AM

Hi,

I've flashed the 1.19, VT works, you have to load bios default setting. But IT seems to be very slow. I'm waiting for 2.0 bios and hope win 2008 hyper V will work faster.






Hey guys...

Any new releases? I was wondering if you had any success about eneabling VT and DEP...



#55 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 17 February 2009 - 08:27 PM

I did back to 1.18 BIOS because after installing newest updates for WinXP PRO (with SP3) the laptop goes unstable (& freeze when i left it on it's own for longer moment, so when i back it's dead and only hard reset helps, but mouse cursor is still working. I think something that wake him up has been changed in some winxp update & it's not longer works with 1.19 as it should).

well when i back to 1.18 VT works great & there are no such freezing laptop problems :)
So everyone please back to 1.18 if u feel your laptop is unstable :)

#56 Guest_loomsen_*

Guest_loomsen_*
  • Guests

Posted 28 March 2009 - 04:35 AM

Thanks Dude, nice job.

Plus, I can confirm it won't cause any trouble to a linux system.

Keep it up. :)

#57 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 29 March 2009 - 06:53 PM

Well AFAIK Compal will not release any newer BIOS for FL90 systems because it is no longer supported. Sorry guys. 1.19 (unstable) beta is last release, and i recommend using 1.18.

#58 artishox

artishox

    Beginner

  • Members
  • 1 posts
  • Country:Latvia

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:NVIDIA Card N/A
  • Operating System:Nothing Selected

Posted 07 May 2009 - 12:08 AM

Hi, I flashed may compal fl90 with 1.19 which I found here and now my laptop turned to brick - it even does not start at all, just turns on power light and thats all. Is there some way to recover?

p.s.
previously was using bios 1.07 - had some issues with new RAM so decided to flash new bios

#59 Nicram

Nicram

    Novice

  • Members
  • Pip
  • 25 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:Compal FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:002514C0
  • Operating System:Win7 Professional x64

Posted 22 May 2009 - 07:42 AM

artishox it is better to update BIOS version by version, 1.07 to 1.08, 1.08 to 1.09 etc.
It is also strange that your laptop do not start.
There is method to repair it. you just need USB floppy drive for that, empty floppy disk and old verion of BIOS.
Here are all the files that you will need for that and instructions: fl90tools.rar
Give it a try. Tell us if you made it :)

#60 00raq00

00raq00

    Beginner

  • Members
  • 1 posts
  • Country:Poland

  • Brand:Other or Custombuild
  • Model:FL90
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • Operating System:Vista Business x64

Posted 31 July 2009 - 12:58 AM

Hi,
Now is modded fl90 1.18 bios for windows 7 slic 2.1
fl90 1.18 slic 2.1

BTW. How shoud i make to flash 1.18 bios to slic 2.0 1.18?

Edited by 00raq00, 31 July 2009 - 01:16 AM.