Jump to content


Photo
- - - - -

Overclocking in Ubuntu??


  • Please log in to reply
8 replies to this topic

#1 coolcop06

coolcop06

    Expert

  • Members
  • PipPipPip
  • 308 posts
  • Country:United States

  • Brand:Other or Custombuild
  • Model:See "Desktop Custom Build"
  • Resolution:Nothing Selected
  • Video Card:NVIDIA Card N/A
  • Operating System:Win7 Professional x64

Posted 08 February 2010 - 03:30 PM

Hey guys, im new to the Linux scene, just installed Ubuntu 9.10 (now dual booting that and Win7 Pro x64). Anyways I just installed the latest driver release (which was scary enough to figure out with the terminal...) from the nvidia site (190.53 for Linux x64), and everything went and is working fine, but I cannot for the life of me figure out how to overclock in Ubuntu! I installed coolbits in the terminal after I installed my driver, and in the control panel there is an overclocking section now, but everytime I change the clock speeds, they revert back to default settings without applying. This is veryyy frustrating! Does anyone else have any ideas??
Thanks

#2 mrx

mrx

    Member

  • Members
  • Pip
  • 69 posts
  • Country:United States

  • Brand:Dell
  • Model:Vostro 1500
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:2281028
  • Operating System:Win7 Ultimate x86

Posted 09 February 2010 - 02:41 PM

I would say bios overclock the card so u don't have to worry ocing in linux.
forgot to add link if u want to oc by bios. This is the guide i used to do my ocing
http://www.hardforum...d.php?t=1199078

my gpu now runs at 600 core, 1500 shader, 500 memory

Edited by mrx, 09 February 2010 - 02:51 PM.


#3 coolcop06

coolcop06

    Expert

  • Members
  • PipPipPip
  • 308 posts
  • Country:United States

  • Brand:Other or Custombuild
  • Model:See "Desktop Custom Build"
  • Resolution:Nothing Selected
  • Video Card:NVIDIA Card N/A
  • Operating System:Win7 Professional x64

Posted 09 February 2010 - 07:19 PM

Well this could be an option of mine, but i would like to stick to software overclocking, its just safer... lol. Anyone else got ideas?? This seems like a pretty simple issue, im probably just doing something really stupid... haha. But I will keep BIOS overclocking in mind.

EDIT: Well I couldnt even get nvflash to work correctly. It kept saying that it failed to start the service when I would try to back up the old BIOS... so I guess thats out...? lol

Edited by coolcop06, 09 February 2010 - 08:46 PM.


#4 mrx

mrx

    Member

  • Members
  • Pip
  • 69 posts
  • Country:United States

  • Brand:Dell
  • Model:Vostro 1500
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:2281028
  • Operating System:Win7 Ultimate x86

Posted 09 February 2010 - 11:16 PM

Nvflash is a cmd only program. U have to start up cmd and nav to where nvflash is located. then run "nvflash.exe --save oldbios.rom"

#5 coolcop06

coolcop06

    Expert

  • Members
  • PipPipPip
  • 308 posts
  • Country:United States

  • Brand:Other or Custombuild
  • Model:See "Desktop Custom Build"
  • Resolution:Nothing Selected
  • Video Card:NVIDIA Card N/A
  • Operating System:Win7 Professional x64

Posted 09 February 2010 - 11:41 PM

Thats exactly what I did, and in the elevated command prompt it said "Failed to start service" (I think the error code was 0x000004fb or something). Not quite sure why that is happening... maybe its an M1530 8600M GT thing...?

#6 mrx

mrx

    Member

  • Members
  • Pip
  • 69 posts
  • Country:United States

  • Brand:Dell
  • Model:Vostro 1500
  • Resolution:1280x800 (WXGA)
  • Video Card:(0407) GeForce 8600M GT
  • SUBSYS:2281028
  • Operating System:Win7 Ultimate x86

Posted 10 February 2010 - 08:03 AM

Well, Have u tryed this for ubuntu then http://ubuntuforums....p/t-175436.html from what i see, it looks easy to overclock in ubuntu

#7 coolcop06

coolcop06

    Expert

  • Members
  • PipPipPip
  • 308 posts
  • Country:United States

  • Brand:Other or Custombuild
  • Model:See "Desktop Custom Build"
  • Resolution:Nothing Selected
  • Video Card:NVIDIA Card N/A
  • Operating System:Win7 Professional x64

Posted 10 February 2010 - 03:34 PM

Tried that too, its the same thing as the nvidia control panel... as soon as I change the clocks and press apply, the clocks revert back to default settings. :/

#8 Aarin

Aarin

    Beginner

  • Members
  • 2 posts
  • Country:Portugal

  • Brand:Toshiba
  • Model:A100-498
  • Resolution:1280x800 (WXGA)
  • Video Card:(01D7) GeForce Go 7300 / Quadro NVS 110M
  • Operating System:Linux (Gentoo)

Posted 11 April 2010 - 05:35 AM

Tried that too, its the same thing as the nvidia control panel... as soon as I change the clocks and press apply, the clocks revert back to default settings. :/


well, you can allways try the Gentoo way :)

http://en.gentoo-wik...nVIDIA_Settings

#9 zzpulp

zzpulp

    Enthusiast

  • Super Member
  • PipPip
  • 157 posts
  • Country:United States

  • Brand:Dell
  • Model:M1710
  • Resolution:1920x1200 (WUXGA)
  • Video Card:(0297) GeForce Go 7950 GTX
  • SUBSYS:019B
  • Operating System:Linux (Other)

Posted 09 July 2010 - 09:05 AM

It sounds like your card is bios-locked for these particular drivers. Which GPU do you have? Anyway, if you post your rom here I can try to edit it for you to enable overclocking but it might not be a permanent fix as newer and newer drivers come out. I understand that you might not want to flash your card but this may be the only solution for you right now for overclocking with those particular drivers. Perhaps if you get some older drivers then you will be able to overclock. If I recall correctly, the 169.04 is the latest of the "old" video card drivers. Try that and one of the 182 series drivers if you don't wish to flash your card.

I am actually working on updating NVClock right now (or more altering it to suit users needs). NVClock is pretty much the Linux Video Card Overclocking program and offers features similar to RivaTuner. Note that I am not the original developer but he doesnt seem to be actively working on NVClock anymore. Anyway, if I can isolate this locked issue in a register then us Linux users will be able to overclock as we please without flashing our cards due to "incompatible" drivers. This would actually be a pretty big deal as this issue is not even able to be solved in Windows without flashing your GPU. I flash my card all the time but I will admit that flashing can be dangerous if you try to edit settings beyond just your clockspeeds. Anyway, just reply here if you are still interested in overclocking.