Jump to content
LaptopVideo2Go Forums

M4438G (GeForce Go 6800) don't detect DVI monitor


loshal

Recommended Posts

My Fujitsu-Siemens Amilo M4438G with a GeForce Go 6800 graphics card don't seem to detect an external monitor connected to the DVI connector. When I start up the computer is first the BIOS startup screen followed by the Windows XP boot screen shown on both the internal and external display. But the Windows login screen is only shown on the internal display, the external monitor becomes black and indicates no input signal.

When I open the nVidia tab on display properties the tab for "nView Dispaly Settings" isn't there. Instead there is a tab called "Digital Flat Panel Settings". So it seems as if the graphics card don't detect the external monitor.

The external monitor works if I use a DVI to VGA adapter and connects to the VGA input of the monitor. Using this connection I can find the "nView Display Settings" tab.

The external monitor also works when I start in Windows XP safe mode.

I've tested with my Samsung 940B monitor and a HP monitor and can't get the DVI to work. But it does work with a Dell 1800FP!!!

Graphics driver version: 79.11 (the latest supplied by F-S).

Video bios version: 5.41.02.39.49.

Does anyone have an idea about what might cause this problem?

Link to comment
Share on other sites

I recommend you to update your drivers, 70 series are not good enough for your card. Try 84.25 for example and see if it is driver related.

Link to comment
Share on other sites

Thanks for your reply!

Before posting my question I tried to install the 84.69 driver but ran into problem with the nv4_mini.sys file which caused a blue screen when booting.

Now I've installed the 84.25 driver but it doesn't solve the problem with the DVI monitor. With the new driver the "nView display settings" menu is available but there is only the internal display to choose from, so it still doesn't detect my external Samsung monitor.

I've also tried two other monitors. An LG monitor seemed to work OK at first but when I started the computer from suspend mode it didn't detect the monitor.

It is such a strange behaviour so I suspect it might be a hardware problem.

Link to comment
Share on other sites

Hmm, to be exactly sure I would recommend using a driver cleaner, or a clean install then trying again. Maybe you should look for firmware as well but as all we know it's a bit risky. Otherwise I don't have any other idea except hardware problem.

Link to comment
Share on other sites

The latest VBios (39,60) doesn't mention anything about fixing DVI issues. But it's needed with after 81.98 drivers, or severe slowdown over 70% is popping up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...