Jump to content
LaptopVideo2Go Forums

Video overlay settings doesn't work on Geforce go 7600


jammy689

Recommended Posts

I am using:

the Asus F3jv Notebook with the

Geforce Go 7600 graphics card

driver version is 86.02

and every time i watch a video and try to adjust the Video Overlay settings through the NVIDIA display settings such as decreasing the brightness or zooming into the overlay, they have no effect on the video at all. What is unsual is that the overlay settings only works when i change the display resolution and then change it back again to my original resolution. But when i restart the computer it doesn't work again unless i play with display resolutions again. :-(

I don't get why it doesn't work. Could this be a hardware problem?

Any ideas on how to fix this?

P.S i've already read and tried "[FIX] Video overlay problem" and that didn't work either.

Link to comment
Share on other sites

There are two ways of displaying video - Overlay and VMR. VMR is more processor-intensive, but is the preferred method since it integrates the video into its software environment rather than "overlaying" it on top of the video player. Doing that means your normal screen controls will also control video brightness, contrast, etc., rather than relying on the overlay controls.

Go into the Overlay Settings and uncheck the "Enable VMR" box. You also may need to disable VMR or enable overlay in your video player.

Link to comment
Share on other sites

There are two ways of displaying video - Overlay and VMR. VMR is more processor-intensive, but is the preferred method since it integrates the video into its software environment rather than "overlaying" it on top of the video player. Doing that means your normal screen controls will also control video brightness, contrast, etc., rather than relying on the overlay controls.

Go into the Overlay Settings and uncheck the "Enable VMR" box. You also may need to disable VMR or enable overlay in your video player.

Ok done that. But when i go into Color Correction and move the brightness slider it still doesn't do anything to the video that i'm playing in Windows Media player 11. Why doesn't color correction do anything on the video?

Edited by jammy689
Link to comment
Share on other sites

What is more unusual is that checking and unchecking "Enable VMR" doesn't make any difference at all.

Why is that?

Edited by jammy689
Link to comment
Share on other sites

I've just tried it with WMP 11 and am getting the same results that you're seeing.

Instead of using WMP's color controls, try using the controls in the Nvidia Control Panel, on the Color Correction page. At the upper left, you'll see "Apply color changes to:" - Change that from Desktop to Overlay and see if you can control your video settings that way.

Link to comment
Share on other sites

I've just tried it with WMP 11 and am getting the same results that you're seeing.

Instead of using WMP's color controls, try using the controls in the Nvidia Control Panel, on the Color Correction page. At the upper left, you'll see "Apply color changes to:" - Change that from Desktop to Overlay and see if you can control your video settings that way.

No actually WMP11 can make the color changes. But the Nvidia Control Panel in the Color Correction in Overlay can't make the changes. That's my problem.

So does that mean I'm in VMR mode now? Because whether I Uncheck or Check the "Enable VMR" in the Overlay settings of Nvidia Control Panel it Doesn't make a difference. Why doesn't it?

Either way the Color Correction changes for the Overlay settings don't have any effect the video i'm playing. please tell me why if you can.

Thanks

Edited by jammy689
Link to comment
Share on other sites

It looks like WMP is using VMR and not overlay mode. You shoiuld be able to change that in WMP's Performance Options.

Link to comment
Share on other sites

It looks like WMP is using VMR and not overlay mode. You shoiuld be able to change that in WMP's Performance Options.

when i go to Tools>Options>Ferformance

The video acceleration is at Full. Is that in Overlay mode?

Link to comment
Share on other sites

You're close. On that same page, click the Advanced button and you'll see two boxes for Video Mixing Renderer. Both of them have overlay boxes underneath. First try checking the overlay boxes. If that doesn't work, try unchecking the Video Mixing Renderer boxes.

Remember to uncheck the VMR box in the nvidia control panel first.

Link to comment
Share on other sites

You're close. On that same page, click the Advanced button and you'll see two boxes for Video Mixing Renderer. Both of them have overlay boxes underneath. First try checking the overlay boxes. If that doesn't work, try unchecking the Video Mixing Renderer boxes.

Remember to uncheck the VMR box in the nvidia control panel first.

Nope. I did what you said but it's still the same. It's like as if It's still in VMR Mode even though i Unchecked the "Enable VMR" in Nvidia Control Panel.

Link to comment
Share on other sites

I'm not sure what else to try. It's possible Microsoft decided to use VMR all the time with WMP 11.

In my case, WMP's controls don't do anything either. I'm lucky the default settings look pretty good.

Link to comment
Share on other sites

I'm not sure what else to try. It's possible Microsoft decided to use VMR all the time with WMP 11.

I have tried PowerDVD, VLC Player, RealPlayer and they all show the same quality video as WMP11 and the Overlay settings on NVIDIA Control Panel don't effect the video.

So I don't it's Microsoft's doing.

Maybe ASUS modified the NVIDIA Graphics Chip so that it only plays Videos using VMR Enabled?

I'm a Noobie with these things. But do you think that it is a Graphics Chip Problem/Malfunction? Because if it is i can get it looked at and repair it since it's still under Warranty.

Thanks very much with your help so far. Very much appreciated.

Link to comment
Share on other sites

Since it happens with other players too, it's either the driver or the hardeare. I wonder if the 7600 and newer GPUs have stopped supporting overlay mode since VMR is the newer technology and seems to be where everyone is headed. It might be worth checking before you put too much effort into trying other drivers.

If you feel like experimenting, you might try some different driver versions to see if they behave differently. 84.25 is an excellent driver that should work well with your laptop, or you might want to try one of the 97 series drivers since they're supposed to fix some video problems.

If you do try the 97 series, I recommend uninstalling your current driver first and doing a clean install of the new driver. Some people are reporting problems upgrading/downgrading between the 97 series and earlier drivers.

But do check first to be sure overlay mode is still supported by that card.

Link to comment
Share on other sites

But do check first to be sure overlay mode is still supported by that card.

well the overlay does work after switching screen resolutions and then switching it back to the original res.

But once the computer has been rebooted the overlay doesn't work again :)

So this is strange. Do you possibly know why this happens?

Edited by jammy689
Link to comment
Share on other sites

Okay - we might be getting closer. Try the suggestion in this topic and see if it helps.

Link to comment
Share on other sites

Okay - we might be getting closer. Try the suggestion in this topic and see if it helps.

Well i've tried the mod inf file and using the 84.25 driver. but it's still the same, but video seems to be less bright now.

However, Overlay settings in NVIDIA Display Panel still don't effect the video though. The video pic quality is good. But it just bugs me that Overlay settings don't work though :)

Seeing that this a new laptop i'd expected that everything would work. :)

Thanks 4 all your help!

Edit: I noticed that the 84.25 driver factory INF didnt support the Geforce Go 7600. Do you think using the 84.25 driver will harm the Graphics Card at all?

Edited by jammy689
Link to comment
Share on other sites

It's worth a try. If it doesn't work, you can always revert to your present driver.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...