Jump to content
LaptopVideo2Go Forums

Possible BSOD upon Install fix


mobilenvidia

Recommended Posts

ZZPULP may have found a cure for the infamous BSOD when the driver installs (or just after)

I've applies this fix to 163.75 and 173.76 as these are probably the most popular for now.

Should you have the problem as quite a few go7950 GTX owners seem to have (Dell XPS M1710), then have a look over here for all the details.

But basically grab the modded INF (that hasn't got the above fix applies)

Edit the INF with a text editor, zip down about 3/4 down the INF and/or find this line:

HKLM,"SOFTWARE\NVIDIA Corporation\Global\NVTweak", CoolBits, %REG_DWORD%, 0xffffffff

This line used to enable overclocking, the overclocking is now done with nTune.

Now all you do is remove the line or stick a ';' in front of it.

Now install the driver as per normal, may pay to uninstall old driver first to get the registry tweak deleted.

or for the more brave have a look in the registry for this line:

HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak

In here there will be this line CoolBits with a value of 0xffffffff either delete this line or set it to zero.

This will mean not having to uninstall and reinstall the driver.

But I do assume that this needs to be done in safemode as the BSOD will not allow the machine to boot :)

Or for the less adventurous just apply this registry tweak to disable coolbits

Depending on browser run either direct from the link or save it to desktop and then run.

This is a very old tweak I used many years ago to tweak the overclock page.

Hopefully the driver that installed but gave a BSOD now works like a dream.

I need users to reply back here with their finding be it good or bad

Link to comment
Share on other sites

Good catch, Pieter and ZZPULP! Thanks!

:)

Link to comment
Share on other sites

Blue Screen Of Death, I take it your a virgin to this phenomenon ? :)

Link to comment
Share on other sites

Confirmed working fix. Now I can install whatever driver I want :)

Link to comment
Share on other sites

Great news, spread the word :)

Link to comment
Share on other sites

This I cannot diagnose as the i9400 control panel behaves with all drivers.

This might be related to older driver settings

Link to comment
Share on other sites

Guest PulsatingQuasar

It might be a language file problem. The drivers installed in the Dutch language but if I choose about from the menu in the taskbar I get the copyright notice in another language.

Can such a thing screw up the control panel not working?

Link to comment
Share on other sites

Guest PulsatingQuasar

Yes! Found it. There are problems with the language files. I now have it working.

I downloaded the 163.75 English(not the multi language) beta from the NVidia site and used the modded inf. It STILL ?????? installed some files in Dutch for me. Probably because the inf is for multi language. Only the Control Panel was still in Dutch. All other files in accessible via the icon in the toolbar were now in English.

To be sure I removed al nvidia driver stuff from the system. Also from ReinstallBackups in System32. That didn't help.

After I installed I removed all files ending in *r.dll for which there is a file with the same name( for example next to nvcplui.dll was a file nccpluir.dll which was in Dutch). Do a search with nv*r.dll in system32; don't remove the file ending in bar.dll. It's English and needed.

Now everything is in English and the Control Panel is working. Whooooohoooooo!!!!

NOTE to NVIDIA: Please stop monkeying about with the damn language files. If I wanted a Dutch language Windows XP I would have installed it. I don't want that. Stop looking at the Regional Options and Languages to determine what language to use. I DON't want it in Dutch. That's why have an English version of Windows XP.

Link to comment
Share on other sites

Guest PulsatingQuasar

I meant: next to nvcplui.dll was a file nvcpluir.dll NOT nccpluir.dll but you probably got that right :-)

Have fun with good working drivers.

Regards,

Remco Komduur

The Netherlands

Link to comment
Share on other sites

it didn't do anything for me deleting that line of code in the INF, it probably made it worse if anything.

Link to comment
Share on other sites

You did reinstall the driver after deleting the line ?

Link to comment
Share on other sites

i'll try that. I think i put I changed the line then uninstalled my other drivers and installed the ones with the edited file.

Link to comment
Share on other sites

Yes installing the driver is the most important part or nothing happens :)

The INF tells the installer what to install and how

Link to comment
Share on other sites

I have the Alienware m9750 SLI (2x 7950 GTX) and can confirm that this DOESNT fix the black screen issue.

searched my registry for any coolbits entries and didnt have any.

it would appear that coolbits is not the only entry causing black screens

Link to comment
Share on other sites

Coolbit's removal or disable fixed BSOD's (Blue screens) not black screens.

I have no idea what could be causing your ailments, will need others with similar problems to try things out as with the Dell's BSOD problem we've just fixed.

have a look in the iNF for the SLI section:

;SLIEnable_AddReg

HKR,, MB_Enable, %REG_BINARY%, 01,00,00,00

HKR,, ForceSwapInterval, %REG_DWORD%, 0

HKR,, ExposePrimaryDeviceOnly, %REG_DWORD%, 1

HKR,, FeatureControl, %REG_DWORD%, 1

HKR,, RMDisablePteCoalesce, %REG_DWORD%, 1

HKR,, DCPerfLimitSLI, %REG_DWORD%, 2

have a play with these settings, change then reinstall

Link to comment
Share on other sites

Alienware m9750 SLI 94.23 inf:

[sLIEnable_AddReg]

HKR,, MB_Mobile, %REG_DWORD%, 1

HKR,, ForceSwapInterval, %REG_DWORD%, 0

HKR,, ExposePrimaryDeviceOnly, %REG_DWORD%, 1

nvidia 163.76 moddified inf:

;SLIEnable_AddReg

HKR,, MB_Enable, %REG_BINARY%, 01,00,00,00

HKR,, ForceSwapInterval, %REG_DWORD%, 0

HKR,, ExposePrimaryDeviceOnly, %REG_DWORD%, 1

noticed its commented out for some reason?

took the ; off, reinstalled clean, same, black screen

made the 163.76 inf match the alienware inf, same, black screen

Link to comment
Share on other sites

yea it didn't work I still get a lot of BSOD

Link to comment
Share on other sites

Alienware m9750 SLI 94.23 inf:

[sLIEnable_AddReg]

HKR,, MB_Mobile, %REG_DWORD%, 1

HKR,, ForceSwapInterval, %REG_DWORD%, 0

HKR,, ExposePrimaryDeviceOnly, %REG_DWORD%, 1

nvidia 163.76 moddified inf:

;SLIEnable_AddReg

HKR,, MB_Enable, %REG_BINARY%, 01,00,00,00

HKR,, ForceSwapInterval, %REG_DWORD%, 0

HKR,, ExposePrimaryDeviceOnly, %REG_DWORD%, 1

noticed its commented out for some reason?

took the ; off, reinstalled clean, same, black screen

made the 163.76 inf match the alienware inf, same, black screen

The SLI settings are always installed, even non SLI machines have the settings installed (won't obviously do anything)

By removing the ; from in front of SLIEnable_AddReg will cause an error probably I put the ; as it's a comment and the installed will just go past to the next line.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...