Jump to content
LaptopVideo2Go Forums

AMILO M3438G with VISTA: Fan always on

John Avatar

Recommended Posts

I just installed Windows Vista on my Fujitsu-Siemens AMILO M 3438G.

I am using NVIDIA driver version 7.15.0011.6369 (also called 163.69)

The fan is always on. I have installed the modification to the registration database* but that didn't help.

Is there some way I can fix this?


Off-topic PS: For some reason the sound volume scroll wheel doesn't work either (sound volume is constant)


* Reg-edit fix:




Link to comment
Share on other sites

  • 1 month later...

Any news of the m3438g and vista? I also tried a few drivers, and even the beta driver of FS itself doesn't have a fan-control

Link to comment
Share on other sites

Guest johnsawyer

I?ve been searching the web for hours how to change the settings that under Vista the laptop fan would not be always running while on AC power. I've tried multitudes of power configurations. When I run on AC the fan is constantly on, although it?s not excessively loud. If running on batteries, the notebook is silent. Under Windows XP the fan turned on only when the temperature rose above a certain level, regardless whether it was running on battery or plugged in. I thought it had to do something with the absence of nVidia PowerMizer settings under Vista. I tried SpeedFan, Notebook Hardware Control (NHC), RivaTuner ? some of them don?t work on x64, some don?t have signed drivers etc. I read that one guy even soldered a resistor to reduce the fan speed.

Well, the solution to silence my HP nw9440 mobile workstation notebook was really simple:

In BIOS under System Configuration | Device Configurations there is a setting called ?Fan Always on while on AC Power? and it was ?Enabled?. Vista?s ACPI was actually conforming to this BIOS setting and XP?s ACPI was ignoring this setting. I just disabled it and the laptop is much more pleasant to use ? even without earplugs :) I nevertheless put a CD box under the touchpad to improve cooling ? so that the fan doesn?t need to turn on that often.

I hope this helps someone. :) The same should work on other more recent HP laptops running Vista (nx9420, nx8420, 8510p, 8510w, 8710p, 8710w), and presumably also on Dell, Gateway, Asus... If you don?t see the setting, try upgrading to the latest BIOS firmware.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...