Jump to content
LaptopVideo2Go Forums

NVIDIA GeForce FX Go 5650 Driver (Confused, please help :()


Guest Riou G

Recommended Posts

Guest Riou G

Hello!

Allright, well, I tried to find the latest driver compatible with my graphics card and I was happy when I saw a post where a guy said he is using the 167.58 driver and getting nice results (on the same gpu I have), so I downloaded that one and did as the installation guides suggest, but then it said that the gpu is not supported (yes, even after replacing the .inf), that was using the have disk method.

Then I tried just using the "setup.exe" and it said my processor needs to be x64 (it is x86 as far as I know).

I would really like to have an updated driver for that card and I would really appreciate your help.

I will post some info here, it may help you help me:

OS Information:

Property Value

OS Name Microsoft Windows XP Professional|C:\WINDOWS|\Device\Harddisk0\Partition1

Service Pack 2.0

OS Manufacturer Microsoft Corporation

Windows Directory C:\WINDOWS

Processor:

Property Value

Current Clock Speed 2992

Description x86 Family 15 Model 2 Stepping 9

Manufacturer GenuineIntel

Name Intel® Pentium® 4 CPU 3.00GHz

Current Clock Speed 2992

Description x86 Family 15 Model 2 Stepping 9

Manufacturer GenuineIntel

Name Intel® Pentium® 4 CPU 3.00GHz

Motherboard:

Property Value

Manufacturer ASUSTeK Computer Inc.

Model

Name Base Board

Part Number

Product L5Gm

Serial Number BSN12345678901234567

Version 2.2

Video Card:

Property Value

Adapter Compatibility NVIDIA

Adapter RAM 67108864

Description NVIDIA GeForce FX Go5650

Installed Display Drivers nv4_disp.dll

Driver Version 6.14.10.4489

Driver Date 8.5.2007 22:28:36

Video Mode Description 800 x 600 x 4294967296 colors

Excuse the resolution, the native one is 1400x1050 but I was messing around at the time of getting that info.

Thanks in advance, looking forward to your replies!

- Riou

Link to comment
Share on other sites

Guest Riou G

Allright, it works! And it even improved FPS on a certain game I'm trying to run!

I did experience some weird split-second black screens or a flicker of some kind, and dark screen at startup (goes back to normal after a minute though) but it seems to have gone away now.

Thanks for your help, and I hope I can ask again if I have any problems :)

Link to comment
Share on other sites

Guest Riou G

Aww, I just got a quick black screen split second flicker (don't know how to call it xD) again... hmm...... should I try a different driver version?

Link to comment
Share on other sites

Guest Riou G

I'm having problems playing DotA properly with this driver :)

Might be because it is an old game?

Anyways.. I will try some other drivers...

Link to comment
Share on other sites

Guest Riou G

I feel like I'm having a monologue here, but at least it might help some people that have the same graphic card xD

I just installed the DESKTOP 169.61 driver with modded .inf and it works PERFECTLY for now (had some black flicker after install but its gone now, like the last one I had).

I would do the 169.62 but it doesnt have a modded .inf yet as far as I know.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...