Jump to content
LaptopVideo2Go Forums

Have serious trouble running games that I shouldn't


outlawauron

Recommended Posts

Hello,

I've read around the forum and most of it is absolute gibberish to me. (which is weird b/c Im pretty good with computers)

I have a Dell XPS M1730 and Im having tons of issues running games at settings which I should not.

Its 2.6 GHz Intel T9500 Core 2 Duo, 4 GB RAM, a GeForce 8700, on 32 bit Vista, etc. It's a good laptop.

I am having trouble running both Warhammer Online and The Witcher on lowest settings. Both have lag, and the Witcher's audio is lagging along side with the video.

Is their anything I can do to run these properly as I know that my specs are way above the requirements and even the reccomended settings.

Thanks again of time.

Link to comment
Share on other sites

Hello, i have a similar laptop spec as you and i'm having problems aswell on The Witcher, got a weird stuttering all the time wether i'm on low or high settings.

have you tried updating your drivers for your gpu yet?

in any case i hope someone else can help us aswell.

Link to comment
Share on other sites

This is usually a sure sign of a driver problem. You can try the 177.92 drivers as they should help you. Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...