Jump to content
LaptopVideo2Go Forums

Latest INFed drivers and Vista Aero?


supajupa

Recommended Posts

Hey!

I'm using a Dell Inspiron 1520 laptop with Vista Ultimate 32-bit, my hardware is Intel Core 2 Duo T8100, 2GB DDR2, nV 8600GT 256 GDDR2

The problem is when i use latest drivers with modded INF from here, Vista's Aero is running VERY slow (all the scrolling on windows and dragging). But if i use the drivers that Dell is providing, it works just fine! Though these drivers are over year old.

So, what is causing it? I mean other 3D applications are running fine (i think), but Aero is slow. Is it because these drivers here are not M$ Certified?

Thanks for helping me out!

Link to comment
Share on other sites

Hey,

Is it because these drivers here are not M$ Certified?

No... As far as I know, these can cause problems with Blu ray and with in game cut scenes, but not with Aero's performance.

I'm 99% sure that the PowerMizer is slowing down your card. Turning it off should help you.

Link to comment
Share on other sites

can't be, I am running aero flawlessly even downclocked to 150/300/150 : core/shader/memory, can't be powermizer problem. scrolling is fine in IE7 for me, make sure you clean out all your old drivers using driver sweeper.

Link to comment
Share on other sites

can't be, I am running aero flawlessly even downclocked to 150/300/150 : core/shader/memory, can't be powermizer problem. scrolling is fine in IE7 for me, make sure you clean out all your old drivers using driver sweeper.

You have got a 1280x800 screen. He has 1440x900. I have had 1280x800, 1440x900, and 1680x1050 screen on my laptop (same type as his) and with the smallest screen lagging was never a problem, even with Powermizer. However, with the two larger screens, it lagged like nothing else. Much of the time, scrolling still lags to 30fps on my system, even though PowerMizer is off. I am thinking about switching back to XP.

Link to comment
Share on other sites

Thanks, will try it out later. But what exactly is PowerMizer? Is it under nvidia control center, and what does it do?

Thanks

Link to comment
Share on other sites

Hi again,

I still think the problem is due to the PowerMizer... Some anonymous guy has posted a little registry hack that disables the function when laptop is plugged in and enables it back when you run on battery, just lemme quote it...

I purchased an HP DV6627ca notebook back in November, and for a while couldn't stand how slow aero performed. I came across a registry hack online not too long ago which remedied this problem. I can't remember where I found it, but just wanted to clarify that I don't take credit for creating it.

What this hack does is basically force NVidia's Powermizer feature to be disabled when the notebook is plugged in, and yet continue to save power when on battery. The jerky aero performance can be attributed to powermizer engaging even when the notebook is plugged in, and aero for some reason does not disengage this. Powermizer downclocks the GPU automatically in vista to 100MHZ to save power, and this is why aero runs slowly. After I changed the registry setting below, aero works as expected and DVD's perform flawlessly!

On Vista change the registry key PerfLevelSrc from x'3333' to x'3322' with regedit. This forces the GPU to run at max when plugged in, but allows powermizer to still work with batteries.

x'2222' will keep GPU at max on batteries or mains.

The registry key is found in:

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contr ol\Video\{**unique to you for nvidia**}\0000\PerfLevelSrc

Hopefully NVIDIA remedies the problems with powermizer in Vista in its drivers soon! In the meantime, hope this fix helps!

Hope this helps :)

(edit) I just noticed a new driver by Dox is available. It has fixed issue with laggy Aero. Link below.

http://forums.laptopvideo2go.com/index....showtopic=21250

Edited by Claw
Link to comment
Share on other sites

hey!

thanks for the explanation, but do the new drivers mess with Powermizer settings, because as i stated before Dell's supported drivers work just fine with Aero.

Link to comment
Share on other sites

Hi again,

I still think the problem is due to the PowerMizer... Some anonymous guy has posted a little registry hack that disables the function when laptop is plugged in and enables it back when you run on battery, just lemme quote it...

Hope this helps :)

(edit) I just noticed a new driver by Dox is available. It has fixed issue with laggy Aero. Link below.

http://forums.laptopvideo2go.com/index....showtopic=21250

Wow man, such great information, thank you so mcuh...you don't know how much time I've spent on this "laggy aero" issue (whenever I'd bring this up in HP forums, no one knew what I was talking about.

Nice to know it was PowerMizer causing these issues, thanks again, Claw!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...